summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild')
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
new file mode 100644
index 000000000000..8841bce111bb
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild,v 1.1 2009/04/30 12:14:56 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+PATCH_LEVEL=12
+MY_PN=${PN/gtk-engines-/}
+
+DESCRIPTION="a derivative of the standard Clearlooks engine, using a more orange approach"
+HOMEPAGE="http://packages.ubuntu.com/search?keywords=gtk2-engines-ubuntulooks"
+SRC_URI="http://archive.ubuntu.com/ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz
+ http://archive.ubuntu.com/ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_PN}_${PV}-${PATCH_LEVEL}.diff
+ EPATCH_FORCE="yes" EPATCH_SUFFIX="patch" epatch debian/patches
+}
+
+src_configure() {
+ econf --disable-dependency-tracking --enable-animation
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ newdoc debian/changelog ChangeLog.debian
+}