summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild')
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild
index 4b3e49974831..bc180be10b53 100644
--- a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild,v 1.12 2008/09/24 19:03:16 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.59.3-r1.ebuild,v 1.13 2008/10/11 20:00:40 yngwin Exp $
EAPI="1"
inherit flag-o-matic cmake-utils
@@ -13,20 +13,15 @@ SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 hppa ppc64 sparc x86"
-IUSE="kde"
+IUSE=""
-DEPEND="|| ( x11-libs/qt-gui:4 <x11-libs/qt-4.4:4 )
- kde? ( kde-base/kwin:4
- x11-libs/qt-gui:4 )"
-# kde-4 support needs methods from qt-gui-4.4
+DEPEND="|| ( x11-libs/qt-gui:4 <x11-libs/qt-4.4:4 )"
S="${WORKDIR}/${MY_P}"
DOCS="ChangeLog README TODO"
src_compile() {
- if use !kde ; then
- append-cppflags "-DQTC_NO_KDE4_LINKING=true -DQTC_DISABLE_KDEFILEDIALOG_CALLS=true";
- sed -i "s/find_package(KDE4)/#&/" "${S}"/CMakeLists.txt
- fi
+ append-cppflags "-DQTC_NO_KDE4_LINKING=true -DQTC_DISABLE_KDEFILEDIALOG_CALLS=true";
+ sed -i "s/find_package(KDE4)/#&/" "${S}"/CMakeLists.txt
cmake-utils_src_compile
}