summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild')
-rw-r--r--x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild b/x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..d493c178c219
--- /dev/null
+++ b/x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/scrotwm/scrotwm-0.10.0-r1.ebuild,v 1.1 2012/02/14 23:15:34 xmw Exp $
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Small dynamic tiling window manager for X11"
+HOMEPAGE="http://www.scrotwm.org"
+SRC_URI="http://opensource.conformal.com/snapshots/${PN}/${P}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/dmenu"
+DEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXtst"
+
+S=${WORKDIR}/${P}/linux
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ tc-export CC
+}
+
+src_install() {
+ emake PREFIX="${D}"usr LIBDIR="${D}usr/$(get_libdir)" install
+
+ cd ${WORKDIR}/${P}
+
+ insinto /etc
+ doins ${PN}.conf
+ dodoc ${PN}_*.conf {initscreen,screenshot}.sh
+
+ elog "Example keyboard config and helpful scripts can be found"
+ elog "in ${ROOT}usr/share/doc/${PF}"
+}