summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-power-manager/files/xfce4-power-manager-0.9.98-fix_polkit_switch.patch')
-rw-r--r--xfce-extra/xfce4-power-manager/files/xfce4-power-manager-0.9.98-fix_polkit_switch.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-0.9.98-fix_polkit_switch.patch b/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-0.9.98-fix_polkit_switch.patch
new file mode 100644
index 000000000000..f76f97dbfaa0
--- /dev/null
+++ b/xfce-extra/xfce4-power-manager/files/xfce4-power-manager-0.9.98-fix_polkit_switch.patch
@@ -0,0 +1,29 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=6568
+http://bugs.gentoo.org/show_bug.cgi?id=329157
+
+--- configure.ac
++++ configure.ac
+@@ -85,10 +85,10 @@
+ AC_ARG_ENABLE([polkit],
+ [AC_HELP_STRING([--disable-polkit],
+ [Do not enable PolicyKit support (default=enabled)])],
+- [],
++ [ac_cv_enable_polkit=$enableval],
+ [ac_cv_enable_polkit=polkit])
+ AC_MSG_CHECKING([whether to build with polkit support])
+-if test "x$ac_cv_enable_polkit" = !"xyes"; then
++if test "x$ac_cv_enable_polkit" = "xno"; then
+ AC_MSG_RESULT([no])
+ polkit="no"
+ else
+--- src/xfpm-polkit.c
++++ src/xfpm-polkit.c
+@@ -560,6 +560,8 @@
+
+ gboolean xfpm_polkit_check_auth (XfpmPolkit *polkit, const gchar *action_id)
+ {
++#ifdef ENABLE_POLKIT
+ xfpm_polkit_init_data (polkit);
++#endif
+ return xfpm_polkit_check_auth_intern (polkit, action_id);
+ }