summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/meteor/meteor-0.5.2.ebuild')
-rw-r--r--www-servers/meteor/meteor-0.5.2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/www-servers/meteor/meteor-0.5.2.ebuild b/www-servers/meteor/meteor-0.5.2.ebuild
new file mode 100644
index 0000000..5d26ff6
--- /dev/null
+++ b/www-servers/meteor/meteor-0.5.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit vcs-snapshot
+
+METEOR_BUNDLEV="0.2.8"
+
+DESCRIPTION="An open-source platform for building top-quality web apps in a fraction of the time."
+HOMEPAGE="http://meteor.com/"
+SRC_URI="https://github.com/meteor/meteor/tarball/v${PV} -> ${P}.tar.gz
+ x86? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_i686_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )
+ amd64? ( https://d3sqy0vbqsdhku.cloudfront.net/dev_bundle_Linux_x86_64_${METEOR_BUNDLEV}.tar.gz -> ${P}_bundle-${METEOR_BUNDLEV}.tar.gz )"
+
+LICENSE="MIT
+ Apache-2.0
+ BSD
+ public-domain
+ Unlicense
+ WTFPL-2
+ AGPL-3" # And more...; add the non-known licenses to /usr/portage/licenses or add the complete LICENSE.txt itself there?
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+src_prepare() {
+ local DEV_BUNDLE_DIR="${WORKDIR}/${P}_bundle-${METEOR_BUNDLEV}"
+
+ einfo "Patching files..."
+ sed -e 's/DEV_BUNDLE=$(dirname "$SCRIPT_DIR")/DEV_BUNDLE=$SCRIPT_DIR/g' -i meteor || die "Couldn't patch DEV_BUNDLE script dir."
+
+ einfo "Merging development bundle..."
+ mv ${DEV_BUNDLE_DIR}/* ${DEV_BUNDLE_DIR}/.bundle_version.txt .
+
+ einfo "Removing unnecessary files..."
+ rm -rf admin
+ rm -rf packages/*/.meteor/local
+ rm -rf examples/*/.meteor/local
+ rm -rf examples/unfinished
+}
+
+src_install() {
+ dodir /opt/meteor
+
+ insinto /opt/meteor
+ doins -r *
+ doins .bundle_version.txt
+
+ dosym /opt/meteor/meteor /usr/bin/meteor
+
+ fperms +x /opt/meteor/meteor
+ fperms +x /opt/meteor/bin/node
+ fperms +x /opt/meteor/mongodb/bin/mongo
+ fperms +x /opt/meteor/mongodb/bin/mongod
+}