summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-01-24 13:28:21 -0600
committerJory Pratt <anarchy@gentoo.org>2020-01-24 13:28:21 -0600
commit2bcac833ad7138fc21fbfd1f764e779ab6e5df9c (patch)
tree1a6dad2f6a6199e6614882b6fbb0a3de86bd365d
parentdev-qt/qtnetwork: Add stable for libressl support (diff)
downloadanarchy-2bcac833ad7138fc21fbfd1f764e779ab6e5df9c.tar.gz
anarchy-2bcac833ad7138fc21fbfd1f764e779ab6e5df9c.tar.bz2
anarchy-2bcac833ad7138fc21fbfd1f764e779ab6e5df9c.zip
Add group support for gpio,spi,i2c
Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--acct-group/gpio/gpio-0.ebuild9
-rw-r--r--acct-group/gpio/metadata.xml8
-rw-r--r--acct-group/i2c/i2c-0.ebuild9
-rw-r--r--acct-group/i2c/metadata.xml8
-rw-r--r--acct-group/spi/metadata.xml8
-rw-r--r--acct-group/spi/spi-0.ebuild9
6 files changed, 51 insertions, 0 deletions
diff --git a/acct-group/gpio/gpio-0.ebuild b/acct-group/gpio/gpio-0.ebuild
new file mode 100644
index 0000000..3c224c7
--- /dev/null
+++ b/acct-group/gpio/gpio-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-group
+
+DESCRIPTION="Group for users with access to SPI"
+ACCT_GROUP_ID=370
diff --git a/acct-group/gpio/metadata.xml b/acct-group/gpio/metadata.xml
new file mode 100644
index 0000000..97d01e1
--- /dev/null
+++ b/acct-group/gpio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-group/i2c/i2c-0.ebuild b/acct-group/i2c/i2c-0.ebuild
new file mode 100644
index 0000000..69bac34
--- /dev/null
+++ b/acct-group/i2c/i2c-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-group
+
+DESCRIPTION="Group for users with access to I2C"
+ACCT_GROUP_ID=371
diff --git a/acct-group/i2c/metadata.xml b/acct-group/i2c/metadata.xml
new file mode 100644
index 0000000..97d01e1
--- /dev/null
+++ b/acct-group/i2c/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-group/spi/metadata.xml b/acct-group/spi/metadata.xml
new file mode 100644
index 0000000..97d01e1
--- /dev/null
+++ b/acct-group/spi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sakaki@deciban.com</email>
+ <name>sakaki</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-group/spi/spi-0.ebuild b/acct-group/spi/spi-0.ebuild
new file mode 100644
index 0000000..1fecc44
--- /dev/null
+++ b/acct-group/spi/spi-0.ebuild
@@ -0,0 +1,9 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-group
+
+DESCRIPTION="Group for users with access to SPI"
+ACCT_GROUP_ID=372