summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-04-22 13:15:52 +0200
committerChristoph Mende <angelos@gentoo.org>2011-04-22 13:15:52 +0200
commitc00ee59e7214adb4027a314cd2516172569b6c0f (patch)
tree4fe42fa22f89ce1c3f0b4aa47ddbd50eeaa3d61b /scripts
parentGet PORTDIR via portageq and make OVERLAY editable via environment (diff)
downloadangelos-c00ee59e7214adb4027a314cd2516172569b6c0f.tar.gz
angelos-c00ee59e7214adb4027a314cd2516172569b6c0f.tar.bz2
angelos-c00ee59e7214adb4027a314cd2516172569b6c0f.zip
Use portageq to get the overlay paths too
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/commit-xfce-sync.sh2
-rwxr-xr-xscripts/sync-xfce-overlay.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/scripts/commit-xfce-sync.sh b/scripts/commit-xfce-sync.sh
index bad7e55..d4e7ab6 100755
--- a/scripts/commit-xfce-sync.sh
+++ b/scripts/commit-xfce-sync.sh
@@ -1,6 +1,6 @@
#!/bin/sh
-: ${OVERLAY=/home/angelos/overlays/xfce}
+OVERLAY="$(portageq get_repo_path / xfce-dev)"
pushd "${OVERLAY}" >/dev/null
for i in $(git status --porcelain|grep ebuild|awk '{ print $2 }'); do
diff --git a/scripts/sync-xfce-overlay.sh b/scripts/sync-xfce-overlay.sh
index 7b76fa1..b05b15c 100755
--- a/scripts/sync-xfce-overlay.sh
+++ b/scripts/sync-xfce-overlay.sh
@@ -1,6 +1,7 @@
#!/bin/bash
-: ${OVERLAY=${HOME}/overlays/xfce"
+OVERLAY="$(portageq get_repo_path / xfce-dev)"
+PORTDIR="$(portageq portdir)"
# collect ebuilds
pushd "${OVERLAY}" >/dev/null
@@ -8,7 +9,6 @@ pkgs=$(echo */*/*.ebuild)
popd >/dev/null
changes=0
-PORTDIR=$(portageq portdir)
for i in ${pkgs}; do
# get cat/pkg