summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen/xen-3.0.2-r1.ebuild')
-rw-r--r--app-emulation/xen/xen-3.0.2-r1.ebuild34
1 files changed, 8 insertions, 26 deletions
diff --git a/app-emulation/xen/xen-3.0.2-r1.ebuild b/app-emulation/xen/xen-3.0.2-r1.ebuild
index 9ea9e82..145446f 100644
--- a/app-emulation/xen/xen-3.0.2-r1.ebuild
+++ b/app-emulation/xen/xen-3.0.2-r1.ebuild
@@ -4,21 +4,15 @@
inherit mount-boot flag-o-matic
-DESCRIPTION="The Xen virtual machine monitor"
-HOMEPAGE="http://xen.sourceforge.net"
-if [[ ${PV} == *_p* ]]; then
- XEN_UNSTABLE="xen-unstable-${PV#*_p}"
- SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
- S="${WORKDIR}/${XEN_UNSTABLE}"
-else
- SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/${P}-src.tgz"
- S="${WORKDIR}/xen-${PV}"
-fi
+DESCRIPTION="The Xen hypervisor"
+HOMEPAGE="http://www.xensource.com/xen/xen/"
+SRC_URI="http://www.cl.cam.ac.uk/Research/SRG/netos/xen/downloads/${P}-src.tgz"
+S="${WORKDIR}/xen-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug custom-cflags pae hardened"
+IUSE="debug custom-cflags pae"
DEPEND="sys-devel/dev86"
RDEPEND=""
@@ -27,9 +21,9 @@ RESTRICT="test"
pkg_setup() {
if [[ -z ${XEN_TARGET_ARCH} ]] ; then
- if use x86 ; then
+ if use x86; then
export XEN_TARGET_ARCH="x86_32"
- elif use amd64 ; then
+ elif use amd64; then
export XEN_TARGET_ARCH="x86_64"
else
die "Unsupported architecture!"
@@ -65,7 +59,7 @@ src_compile() {
use pae && myopt="${myopt} pae=y"
if use custom-cflags; then
- filter-flags -fPIE -fstack-protector
+ filter-flags -fPIE -fstack-protector -fstack-protector-all
else
unset CFLAGS
fi
@@ -80,11 +74,6 @@ src_install() {
make DESTDIR="${D}" ${myopt} install-xen \
|| die "install failed"
-
- # for upstream change tracking
- if [[ -n ${XEN_UNSTABLE} ]]; then
- dodoc "${S}"/XEN-VERSION
- fi
}
pkg_postinst() {
@@ -95,13 +84,6 @@ pkg_postinst() {
einfo "Note: xen tools have been moved to app-emulation/xen-tools;"
einfo "you need to install that package to manage your domains."
- if [[ -n ${XEN_UNSTABLE} ]]; then
- echo
- einfo "This is a snapshot of the xen-unstable tree."
- einfo "Please report bugs in xen itself (and not the packaging) to"
- einfo "bugzilla.xensource.com"
- fi
-
if use pae; then
echo
einfo "This is a PAE build of Xen. It will *only* boot PAE kernels!"