summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/netcdf/netcdf-4.3.3.1.ebuild')
-rw-r--r--sci-libs/netcdf/netcdf-4.3.3.1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sci-libs/netcdf/netcdf-4.3.3.1.ebuild b/sci-libs/netcdf/netcdf-4.3.3.1.ebuild
deleted file mode 100644
index 347d2b3..0000000
--- a/sci-libs/netcdf/netcdf-4.3.3.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools-utils
-
-DESCRIPTION="Scientific library and interface for array oriented data access"
-HOMEPAGE="http://www.unidata.ucar.edu/software/netcdf/"
-SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
-
-LICENSE="UCAR-Unidata"
-SLOT="0/7"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+dap doc examples hdf +hdf5 mpi static-libs szip test tools"
-
-RDEPEND="
- dap? ( net-misc/curl:0= )
- hdf? ( sci-libs/hdf:0= sci-libs/hdf5:0= )
- hdf5? ( sci-libs/hdf5:0=[mpi=,szip=,zlib] )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )"
-
-REQUIRED_USE="test? ( tools ) szip? ( hdf5 ) mpi? ( hdf5 )"
-
-src_configure() {
- local myeconfargs=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- --disable-examples
- --disable-dap-remote-tests
- $(use_enable dap)
- $(use_enable doc doxygen)
- $(use_enable hdf hdf4)
- $(use_enable hdf5 netcdf-4)
- $(use_enable tools utilities)
- )
- if use mpi; then
- export CC=mpicc
- myeconfargs+=( --enable-parallel )
- use test && myeconfargs+=( --enable-parallel-tests )
- fi
- autotools-utils_src_configure
-}
-
-src_test() {
- autotools-utils_src_test -j1
-}
-
-src_install() {
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}