summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2020-09-25 11:52:20 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2020-09-25 11:52:20 +0300
commit24985fa2c72adacecc68f0c90bd5e72fa13256e4 (patch)
tree732c7e68e1ef2db457b1a6a2c1f918590d94db65
parentRemove clsync live packages as they are upstream now (diff)
downloadbircoph-24985fa2c72adacecc68f0c90bd5e72fa13256e4.tar.gz
bircoph-24985fa2c72adacecc68f0c90bd5e72fa13256e4.tar.bz2
bircoph-24985fa2c72adacecc68f0c90bd5e72fa13256e4.zip
suspend: sync with tree changes
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--sys-power/suspend/metadata.xml6
-rw-r--r--sys-power/suspend/suspend-9999.ebuild21
2 files changed, 12 insertions, 15 deletions
diff --git a/sys-power/suspend/metadata.xml b/sys-power/suspend/metadata.xml
index 959bb49..4c01d22 100644
--- a/sys-power/suspend/metadata.xml
+++ b/sys-power/suspend/metadata.xml
@@ -2,18 +2,14 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>xmw@gentoo.org</email>
- <name>Michael Weber</name>
- </maintainer>
- <maintainer type="person">
<email>bircoph@gentoo.org</email>
<name>Andrew Savchenko</name>
</maintainer>
<use>
- <flag name="fbsplash">Add support for framebuffer splash</flag>
<flag name="crypt">Allows suspend and resume from encrypted disk</flag>
</use>
<upstream>
<remote-id type="sourceforge">suspend</remote-id>
+ <remote-id type="github">bircoph/suspend</remote-id>
</upstream>
</pkgmetadata>
diff --git a/sys-power/suspend/suspend-9999.ebuild b/sys-power/suspend/suspend-9999.ebuild
index b929ed5..2304118 100644
--- a/sys-power/suspend/suspend-9999.ebuild
+++ b/sys-power/suspend/suspend-9999.ebuild
@@ -1,39 +1,40 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools git-r3
DESCRIPTION="Userspace Software Suspend and S2Ram"
-HOMEPAGE="http://suspend.sourceforge.net/"
-EGIT_REPO_URI="git://github.com/bircoph/${PN}.git"
+HOMEPAGE="http://suspend.sourceforge.net
+https://github.com/bircoph/suspend"
+EGIT_REPO_URI="https://github.com/bircoph/${PN}.git"
LICENSE="GPL-2"
SLOT="0"
-IUSE="crypt fbsplash +lzo threads"
+IUSE="crypt +lzo threads"
RDEPEND="
dev-libs/libx86
+ >=sys-apps/pciutils-2.2.4
crypt? (
>=dev-libs/libgcrypt-1.6.3:0[static-libs]
dev-libs/libgpg-error[static-libs] )
- fbsplash? ( >=media-gfx/splashutils-1.5.4.4-r6 )
lzo? ( >=dev-libs/lzo-2[static-libs] ) "
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
>=dev-lang/perl-5.10
- >=sys-apps/pciutils-2.2.4
virtual/pkgconfig"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
econf \
- --docdir="/usr/share/doc/${PF}" \
+ --disable-fbsplash \
$(use_enable crypt encrypt) \
- $(use_enable fbsplash) \
$(use_enable lzo compress) \
$(use_enable threads)
}