summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-08-12 00:04:54 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-08-12 00:04:54 +0300
commitc53d802f26d0b15a041d346a27dc58cbbdcac59f (patch)
tree8450916d7118eb1af73a598054425ca08111d99a
parentnet-libs/libnemesi: update (diff)
downloadbircoph-c53d802f26d0b15a041d346a27dc58cbbdcac59f.tar.gz
bircoph-c53d802f26d0b15a041d346a27dc58cbbdcac59f.tar.bz2
bircoph-c53d802f26d0b15a041d346a27dc58cbbdcac59f.zip
net-misc/prtunnel: update and fixes
- bump to EAPI 6 - GLEP 67 update - add longdescription - cleanup ebuild - use proper license Package-Manager: portage-2.3.0 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
-rw-r--r--net-misc/prtunnel/metadata.xml19
-rw-r--r--net-misc/prtunnel/prtunnel-0.2.7.ebuild37
2 files changed, 31 insertions, 25 deletions
diff --git a/net-misc/prtunnel/metadata.xml b/net-misc/prtunnel/metadata.xml
index 38b86b8..84943f9 100644
--- a/net-misc/prtunnel/metadata.xml
+++ b/net-misc/prtunnel/metadata.xml
@@ -1,8 +1,21 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer>
- <email>bircoph@gentoo.org</email>
- <name>Andrew Savchenko</name>
+<maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
</maintainer>
+<longdescription>
+prtunnel can tunnel TCP/IP connections in a variety of ways, including through
+HTTP and SOCKS5 proxy servers. Some if its possible uses include:
+- Tunneling TCP connections from client programs to a remote server through an
+HTTP or SOCKS5 proxy (useful if you're behind such a proxy and want to use a
+program that doesn't have native proxy support)
+- Tunneling TCP connections from SOCKS-capable client programs through an HTTP
+or SOCKS5 proxy
+- Tunneling TCP connections from an IPv4 client program to an IPv6 server and
+vice-versa
+- Forwarding TCP connections
+- Running as a simple SOCKS proxy server
+</longdescription>
</pkgmetadata>
diff --git a/net-misc/prtunnel/prtunnel-0.2.7.ebuild b/net-misc/prtunnel/prtunnel-0.2.7.ebuild
index 62e93bf..6a672ed 100644
--- a/net-misc/prtunnel/prtunnel-0.2.7.ebuild
+++ b/net-misc/prtunnel/prtunnel-0.2.7.ebuild
@@ -1,31 +1,24 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Id$
-EAPI=5
+EAPI=6
-DESCRIPTION="Tunnels TCP/IP connections in a variety of ways, including through HTTP and SOCKS5 proxy servers"
-HOMEPAGE="http://joshbeam.com/software/prtunnel.php"
-SRC_URI="http://joshbeam.com/files/${P}.tar.gz"
-LICENSE="BSD"
+DESCRIPTION="Tunnels TCP/IP through HTTP, SOCKS5 proxies; IPv4/IPV6 bridge"
+HOMEPAGE="http://joshbeam.com/software/prtunnel/"
+SRC_URI="https://github.com/joshb/${PN}/releases/download/${PV}/${P}.tar.gz"
+LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="ipv6"
-DEPEND="virtual/libc"
-RDEPEND=${DEPEND}
src_prepare() {
- sed -i -e "s:CFLAGS=:CFLAGS+=:" Makefile
- sed -i -e "s:-o prtunnel:\$\(LDFLAGS\) -o prtunnel:" Makefile
- use ipv6 || {
- sed -i -e "s:CFLAGS+= -DIPV6:#CFLAGS+= -DIPV6:" Makefile
- sed -i -e "s|direct6\.o:.*||" Makefile
- sed -i -e "s|direct6.o ||" Makefile
- }
-}
+ default
-src_install() {
- dobin prtunnel
- doman prtunnel.1
- dodoc README ChangeLog
+ sed -i -e "s|PREFIX=.*|PREFIX=${EPREFIX}/usr|" \
+ -e 's|CFLAGS=|CFLAGS+=|' \
+ -e 's|$(CC)|$(CC) $(CFLAGS) $(LDFLAGS)|' Makefile
+ use ipv6 || sed -i -e "s|CFLAGS+= -DIPV6||" \
+ -e "s|direct6\.o:.*||" \
+ -e "s|direct6\.o ||" Makefile
}