summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-03-18 07:49:33 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-03-18 09:07:57 +0300
commitd7a5808473390ff50a9333890dbd7e6a9f4f6a43 (patch)
tree195149c6a1f83500612674418012a8d032842717
parentmplayer: fix repoman warnings (diff)
downloadbircoph-d7a5808473390ff50a9333890dbd7e6a9f4f6a43.tar.gz
bircoph-d7a5808473390ff50a9333890dbd7e6a9f4f6a43.tar.bz2
bircoph-d7a5808473390ff50a9333890dbd7e6a9f4f6a43.zip
distcc: fix repoman warnings
- remove unused arches - migrate from fdo-mime to xdg-utils - replace http by https whenever is appropriate
-rw-r--r--sys-devel/distcc/distcc-3.2_rc1-r2.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-devel/distcc/distcc-3.2_rc1-r2.ebuild b/sys-devel/distcc/distcc-3.2_rc1-r2.ebuild
index 35b46ba..71f2285 100644
--- a/sys-devel/distcc/distcc-3.2_rc1-r2.ebuild
+++ b/sys-devel/distcc/distcc-3.2_rc1-r2.ebuild
@@ -1,21 +1,21 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils fdo-mime flag-o-matic multilib python-single-r1 toolchain-funcs user
+inherit autotools eutils flag-o-matic multilib python-single-r1 toolchain-funcs user xdg-utils
MY_P="${P/_}"
DESCRIPTION="Distribute compilation of C code across several machines on a network"
HOMEPAGE="http://distcc.org/"
-SRC_URI="http://distcc.googlecode.com/files/${MY_P}.tar.bz2
- http://dev.gentoo.org/~bircoph/patches/${P}-native.patch.xz"
+SRC_URI="https://distcc.googlecode.com/files/${MY_P}.tar.bz2
+ https://dev.gentoo.org/~bircoph/patches/${P}-native.patch.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="avahi cc32_64 crossdev gnome gssapi gtk hardened ipv6 +secure selinux xinetd"
RESTRICT="test"
@@ -23,7 +23,7 @@ RESTRICT="test"
CDEPEND="dev-libs/popt
avahi? ( >=net-dns/avahi-0.6[dbus] )
cc32_64? (
- amd64? ( sys-devel/gcc[multilib] )
+ amd64? ( sys-devel/gcc[multilib(-)] )
x86? ( cross-x86_64-pc-linux-gnu/gcc )
)
gnome? (
@@ -222,7 +222,7 @@ pkg_postinst() {
elog
elog "Tips on using distcc with Gentoo can be found at"
- elog "http://www.gentoo.org/doc/en/distcc.xml"
+ elog "https://www.gentoo.org/doc/en/distcc.xml"
elog
elog "How to use pump mode with Gentoo:"
elog "# distcc-config --set-hosts \"foo,cpp,lzo bar,cpp,lzo baz,cpp,lzo\""
@@ -256,7 +256,7 @@ pkg_postrm() {
rmdir "${EPREFIX}${DCCC_PATH}"
fi
- use gnome && fdo-mime_desktop_database_update
+ use gnome && xdg_desktop_database_update
}
pkg_config() {