summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2010-08-06 11:42:21 +0100
committerRobert Piasek <dagger@gentoo.org>2010-08-06 11:42:21 +0100
commit5d30909ebef164df2ae617a7aa14736d20841917 (patch)
treebc254e9164db3bdcccae91aeaf51a50faf68673f
parentNew version of NM gentoo plugin (diff)
downloaddagger-5d30909ebef164df2ae617a7aa14736d20841917.tar.gz
dagger-5d30909ebef164df2ae617a7aa14736d20841917.tar.bz2
dagger-5d30909ebef164df2ae617a7aa14736d20841917.zip
Adding new ebuild for Zarafa.
-rw-r--r--www-apps/zarafa-webaccess/Manifest2
-rw-r--r--www-apps/zarafa-webaccess/zarafa-webaccess-6.40.1.ebuild45
-rw-r--r--www-apps/zarafa/Manifest11
-rw-r--r--www-apps/zarafa/files/zarafa-6.40.1-uuid-link.patch31
-rw-r--r--www-apps/zarafa/files/zarafa-gateway.rc630
-rw-r--r--www-apps/zarafa/files/zarafa-ical.rc630
-rw-r--r--www-apps/zarafa/files/zarafa-indexer.rc632
-rw-r--r--www-apps/zarafa/files/zarafa-licensed.rc631
-rw-r--r--www-apps/zarafa/files/zarafa-monitor.rc630
-rw-r--r--www-apps/zarafa/files/zarafa-server.rc635
-rw-r--r--www-apps/zarafa/files/zarafa-spooler.rc630
-rw-r--r--www-apps/zarafa/files/zarafa.logrotate65
-rw-r--r--www-apps/zarafa/zarafa-6.40.1.ebuild84
13 files changed, 456 insertions, 0 deletions
diff --git a/www-apps/zarafa-webaccess/Manifest b/www-apps/zarafa-webaccess/Manifest
new file mode 100644
index 0000000..a412508
--- /dev/null
+++ b/www-apps/zarafa-webaccess/Manifest
@@ -0,0 +1,2 @@
+DIST zarafa-6.40.1.tar.gz 4518286 RMD160 bbbbeacd0dc0d05bccda2c782e6353fff4d418cc SHA1 d7041698302316d33a9fd41b564fdbfc8f6355cc SHA256 7e6c5c088db5491e6873f73a3b9574be2ec434c17fbd49ba24148fec2f6b7668
+EBUILD zarafa-webaccess-6.40.1.ebuild 898 RMD160 dbf7ceb5bc6eed09b08d53004668fb64106ba609 SHA1 579b24fb9c57bfb8c973d7b806a4d7b1c6adbe0a SHA256 a3bfae3d16f6a9fc3b82dc5065d9e4c6c60f372c56cc7729fc0a3e7b4302e2bc
diff --git a/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.1.ebuild b/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.1.ebuild
new file mode 100644
index 0000000..8e19fa5
--- /dev/null
+++ b/www-apps/zarafa-webaccess/zarafa-webaccess-6.40.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit webapp eutils depend.php
+
+MY_P=${P/webaccess-/}
+ZARAFA_PACKAGE="http://download.zarafa.com/zarafa/drupal/beta/ondemand.php?version=${PV}&src=${MY_P} -> ${MY_P}.tar.gz"
+
+DESCRIPTION="Open Source Groupware Solution"
+HOMEPAGE="http://zarafa.com/"
+SRC_URI="${ZARAFA_PACKAGE}"
+
+LICENSE="AGPL-3"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+need_php_httpd
+
+S="${WORKDIR}"/${MY_P}/php-webclient-ajax
+
+RDEPEND=">=dev-libs/libical-0.40"
+DEPEND="${RDEPEND}"
+
+pkg_setup () {
+ webapp_pkg_setup
+ require_php_with_use mysql zlib xml
+}
+
+
+src_install() {
+ webapp_src_preinst
+
+ cp "${S}"/config.php.dist "${S}"/config.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r "${S}"/*
+
+
+ webapp_configfile "${MY_HTDOCSDIR}"/config.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/config.php
+
+ webapp_src_install
+}
diff --git a/www-apps/zarafa/Manifest b/www-apps/zarafa/Manifest
new file mode 100644
index 0000000..023d91c
--- /dev/null
+++ b/www-apps/zarafa/Manifest
@@ -0,0 +1,11 @@
+AUX zarafa-6.40.1-uuid-link.patch 1416 RMD160 da5e90e883e1331a5ac1bf9891ece199b61b422d SHA1 f5277c620f78693b05500189fdd869569a1c1fd1 SHA256 ead0383bc69c3c2fce4f69e8dce19161d123dc5fb91b2abbefcf3a83299f855c
+AUX zarafa-gateway.rc6 706 RMD160 341b4a029972290fdac747d65cf324a22d3ee8b0 SHA1 646f1aca42f5457b3beec2a60b0e70b2af17ef93 SHA256 c8d6f0a86338f7a7a68847abcb27c5f254bc837b63ce76d9541f02be70e4a699
+AUX zarafa-ical.rc6 663 RMD160 db306a10e7777889e9460488575cbdd1ddc9037e SHA1 8fa807d0da22ab4fc1f3156c3a7dc0fe3cdab1ad SHA256 1eec0c538a0264eb2757b5687c8285394f899740bc4cba913115f82ccab703e2
+AUX zarafa-indexer.rc6 720 RMD160 7ac4e46479cf7d1469df6a388aa6231cf1e2c5a5 SHA1 7b9e0e90bcdaee3f84fdeeb1214ee52c36d8c396 SHA256 ff10705b5b109b22448fdc01c45046f8984131f57094685af467e96f85a872a2
+AUX zarafa-licensed.rc6 719 RMD160 8a21e42750cff10a81fbb7808944bca7d9eb9aec SHA1 5f5e3863ac7aea1c1f3218f97cb08612b83bfff8 SHA256 acb3a77842078fb7416a7ad2856d200737a8311433958640ac95776583ff52d6
+AUX zarafa-monitor.rc6 705 RMD160 d1e524b7ed48ec5b53594595a35d4fb3c02b1a5a SHA1 d9cbd4df039ae95048bc53edcd4c1968166fdde4 SHA256 6d7cc1b2f0c7049f28dccf0d65530f1075e932898ab9b7d68cd73ffc2e4dd6e9
+AUX zarafa-server.rc6 732 RMD160 4472d58c669351295191e78ad6a5dfb1942457ed SHA1 ada87c0687dff4060b65e85b1fc00c986ea163f8 SHA256 ccc3d84acb28f9f72960b74506bb82a032e6661c453941952b1fa0fda7b49160
+AUX zarafa-spooler.rc6 705 RMD160 a2981b8e9b60df19d5adce5507ec51ac6d5b12e8 SHA1 09527095beb3891986656cb0e1c53414b7f038bf SHA256 4cf183daf6d86e2bb39073993af8f244bc28ee90feb4cf1ba34e5302894aa2fe
+AUX zarafa.logrotate 1227 RMD160 a0b3e0a50886d04cd28ad2ead2cc8589101f47f9 SHA1 d0f2b3a01641f821d60353ed77935b46abf451fc SHA256 f7276f0ccd48b3c9e71545630ad41cdc2748af45148bf0576f2ca14ee8f9d129
+DIST zarafa-6.40.1.tar.gz 4518286 RMD160 bbbbeacd0dc0d05bccda2c782e6353fff4d418cc SHA1 d7041698302316d33a9fd41b564fdbfc8f6355cc SHA256 7e6c5c088db5491e6873f73a3b9574be2ec434c17fbd49ba24148fec2f6b7668
+EBUILD zarafa-6.40.1.ebuild 2015 RMD160 4490f505abb46d220fa1f84c866932164bfa649b SHA1 77728ae582480c010fc58b06c02f6d3fb4686a63 SHA256 1eb34dd372450217f7e8ecc8295b302b29d47d00be5773aebe5375e1e0fc8219
diff --git a/www-apps/zarafa/files/zarafa-6.40.1-uuid-link.patch b/www-apps/zarafa/files/zarafa-6.40.1-uuid-link.patch
new file mode 100644
index 0000000..d434dd9
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-6.40.1-uuid-link.patch
@@ -0,0 +1,31 @@
+--- provider/server/Makefile.in~ 2010-08-03 10:42:59.000000000 +0100
++++ provider/server/Makefile.in 2010-08-06 10:17:15.391932752 +0100
+@@ -265,7 +265,7 @@
+ $(MYSQL_INCLUDES) $(GSOAP_CFLAGS) $(SSL_CFLAGS) $(SSL_HAS_EVP_PKEY_CMP) $(EPOLL_CFLAGS)
+
+ zarafa_server_LDFLAGS = ${DL_LIBS} -Wl,-E
+-zarafa_server_LDADD = $(UUID_LIBS) $(INTL_LIBS) $(ICONV_LIBS) \
++zarafa_server_LDADD = $(INTL_LIBS) $(ICONV_LIBS) \
+ ${top_builddir}/provider/libserver/libserver.la \
+ ${top_builddir}/provider/soap/libgsoap.la \
+ ${top_builddir}/provider/soap/libsoapserver.la \
+@@ -273,7 +273,7 @@
+ ${top_builddir}/common/libcommon_util.la \
+ ${top_builddir}/common/libcommon_mapi.la \
+ ${top_builddir}/common/libcommon_ssl.la \
+- $(MYSQL_LIBS) $(SSL_LIBS) $(PAM_LIBS) $(KRB5_LIBS) $(TCMALLOC_LIBS) -lrt
++ $(MYSQL_LIBS) $(SSL_LIBS) $(PAM_LIBS) $(KRB5_LIBS) $(TCMALLOC_LIBS) $(UUID_LIBS) -lrt
+
+ zarafa_server_SOURCES = ECServer.cpp \
+ ECSoapServerConnection.h ECSoapServerConnection.cpp \
+--- ECtools/zarafa-stats/Makefile.in~ 2010-08-03 10:42:54.000000000 +0100
++++ ECtools/zarafa-stats/Makefile.in 2010-08-06 10:23:27.988995191 +0100
+@@ -249,7 +249,7 @@
+ ${top_builddir}/mapi4linux/src/libmapi.la \
+ ${top_builddir}/common/libcommon_mapi.la \
+ ${top_builddir}/common/libcommon_util.la \
+- -lncurses
++ -lncurses $(UUID_LIBS)
+
+ zarafa_stats_SOURCES = zarafa-stats.cpp
+ all: all-am
diff --git a/www-apps/zarafa/files/zarafa-gateway.rc6 b/www-apps/zarafa/files/zarafa-gateway.rc6
new file mode 100644
index 0000000..d9e7f7a
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-gateway.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+GATEWAYCONFIG=/etc/zarafa/gateway.cfg
+GATEWAYPROGRAM=/usr/bin/zarafa-gateway
+
+[ -x $GATEWAYPROGRAM ] || exit 0
+
+GATEWAYCONFIG_OPT=""
+[ ! -z $GATEWAYCONFIG -a -f $GATEWAYCONFIG ] && GATEWAYCONFIG_OPT="-c $GATEWAYCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${GATEWAYPROGRAM} -- ${GATEWAYCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --exec ${GATEWAYPROGRAM} -- ${GATEWAYCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-ical.rc6 b/www-apps/zarafa/files/zarafa-ical.rc6
new file mode 100644
index 0000000..fec3b5c
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-ical.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ICALCONFIG=/etc/zarafa/ical.cfg
+ICALPROGRAM=/usr/bin/zarafa-ical
+
+[ -x $ICALPROGRAM ] || exit 0
+
+ICALCONFIG_OPT=""
+[ ! -z $ICALCONFIG -a -f $ICALCONFIG ] && ICALCONFIG_OPT="-c $ICALCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${ICALPROGRAM} -- ${ICALCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --exec ${ICALPROGRAM} -- ${ICALCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-indexer.rc6 b/www-apps/zarafa/files/zarafa-indexer.rc6
new file mode 100644
index 0000000..789f3b6
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-indexer.rc6
@@ -0,0 +1,32 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+INDEXERCONFIG=/etc/zarafa/indexer.cfg
+INDEXERPROGRAM=/usr/bin/zarafa-indexer
+
+[ -x $INDEXERPROGRAM ] || exit 0
+
+INDEXERCONFIG_OPT=""
+[ ! -z $INDEXERCONFIG -a -f $INDEXERCONFIG ] && INDEXERCONFIG_OPT="-c
+$INDEXERCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${INDEXERPROGRAM} -- ${INDEXERCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --retry 65 \
+ --exec ${INDEXERPROGRAM} -- ${INDEXERCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-licensed.rc6 b/www-apps/zarafa/files/zarafa-licensed.rc6
new file mode 100644
index 0000000..73d7e44
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-licensed.rc6
@@ -0,0 +1,31 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+LICENSEDCONFIG=/etc/zarafa/licensed.cfg
+LICENSEDPROGRAM=/usr/bin/zarafa-licensed
+
+[ -x $LICENSEDPROGRAM ] || exit 0
+
+LICENSEDCONFIG_OPT=""
+[ ! -z $LICENSEDCONFIG -a -f $LICENSEDCONFIG ] && LICENSEDCONFIG_OPT="-c
+$LICENSEDCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${LICENSEDPROGRAM} -- ${LICENSEDCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --exec ${LICENSEDPROGRAM} -- ${LICENSEDCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-monitor.rc6 b/www-apps/zarafa/files/zarafa-monitor.rc6
new file mode 100644
index 0000000..0b9b790
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-monitor.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+MONITORCONFIG=/etc/zarafa/monitor.cfg
+MONITORPROGRAM=/usr/bin/zarafa-monitor
+
+[ -x $MONITORPROGRAM ] || exit 0
+
+MONITORCONFIG_OPT=""
+[ ! -z $MONITORCONFIG -a -f $MONITORCONFIG ] && MONITORCONFIG_OPT="-c $MONITORCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${MONITORPROGRAM} -- ${MONITORCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --exec ${MONITORPROGRAM} -- ${MONITORCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-server.rc6 b/www-apps/zarafa/files/zarafa-server.rc6
new file mode 100644
index 0000000..41d3a20
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-server.rc6
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SERVERCONFIG=/etc/zarafa/server.cfg
+SERVERPROGRAM=/usr/bin/zarafa-server
+
+[ -x $SERVERPROGRAM ] || exit 0
+
+SERVERCONFIG_OPT=""
+[ ! -z $SERVERCONFIG -a -f $SERVERCONFIG ] && SERVERCONFIG_OPT="-c $SERVERCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+depend() {
+ need mysql
+}
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${SERVERPROGRAM} -- ${SERVERCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --retry 65 \
+ --exec ${SERVERPROGRAM} -- ${SERVERCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa-spooler.rc6 b/www-apps/zarafa/files/zarafa-spooler.rc6
new file mode 100644
index 0000000..0a24b9c
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa-spooler.rc6
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+SPOOLERCONFIG=/etc/zarafa/spooler.cfg
+SPOOLERPROGRAM=/usr/bin/zarafa-spooler
+
+[ -x $SPOOLERPROGRAM ] || exit 0
+
+SPOOLERCONFIG_OPT=""
+[ ! -z $SPOOLERCONFIG -a -f $SPOOLERCONFIG ] && SPOOLERCONFIG_OPT="-c $SPOOLERCONFIG"
+
+PIDFILE=/var/run/"${SVCNAME}".pid
+
+start() {
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${SPOOLERPROGRAM} -- ${SPOOLERCONFIG_OPT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop \
+ --pidfile ${PIDFILE} \
+ --exec ${SPOOLERPROGRAM} -- ${SPOOLERCONFIG_OPT}
+ eend $?
+}
diff --git a/www-apps/zarafa/files/zarafa.logrotate b/www-apps/zarafa/files/zarafa.logrotate
new file mode 100644
index 0000000..e964bc4
--- /dev/null
+++ b/www-apps/zarafa/files/zarafa.logrotate
@@ -0,0 +1,65 @@
+#
+# This is an example for the common logrotate system.
+# Copy this file to /etc/logrotate.d/zarafa to activate it.
+# Also, check the location of the logfiles, and replace if needed.
+#
+
+/var/log/zarafa/server.log {
+ weekly
+ missingok
+ rotate 52
+ compress
+ delaycompress
+ notifempty
+ postrotate
+ killall -HUP zarafa-server
+ endscript
+}
+
+/var/log/zarafa/spooler.log {
+ weekly
+ missingok
+ rotate 52
+ compress
+ delaycompress
+ notifempty
+ postrotate
+ killall -HUP zarafa-spooler
+ endscript
+}
+
+/var/log/zarafa/monitor.log {
+ weekly
+ missingok
+ rotate 52
+ compress
+ delaycompress
+ notifempty
+ postrotate
+ killall -HUP zarafa-monitor
+ endscript
+}
+
+/var/log/zarafa/gateway.log {
+ weekly
+ missingok
+ rotate 52
+ compress
+ delaycompress
+ notifempty
+ postrotate
+ killall -HUP zarafa-gateway
+ endscript
+}
+
+/var/log/zarafa/ical.log {
+ weekly
+ missingok
+ rotate 52
+ compress
+ delaycompress
+ notifempty
+ postrotate
+ killall -HUP zarafa-ical
+ endscript
+}
diff --git a/www-apps/zarafa/zarafa-6.40.1.ebuild b/www-apps/zarafa/zarafa-6.40.1.ebuild
new file mode 100644
index 0000000..64bf5ba
--- /dev/null
+++ b/www-apps/zarafa/zarafa-6.40.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+PHP_EXT_NAME="mapi"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit eutils php-ext-base-r1
+
+ZARAFA_PACKAGE="http://download.zarafa.com/zarafa/drupal/beta/ondemand.php?version=${PV}&src=${P} -> ${P}.tar.gz"
+
+DESCRIPTION="Open Source Groupware Solution"
+HOMEPAGE="http://zarafa.com/"
+SRC_URI="${ZARAFA_PACKAGE}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug ldap +logrotate static"
+
+RDEPEND=">=dev-libs/libical-0.40
+ =dev-cpp/libvmime-0.7.1
+ >=dev-lang/php-5.2.0
+ app-text/catdoc
+ app-text/poppler
+ dev-cpp/clucene
+ dev-db/mysql
+ dev-libs/libxml2
+ dev-libs/openssl
+ net-misc/curl
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ ldap? ( net-nds/openldap )
+ logrotate? ( app-admin/logrotate )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+
+src_prepare() {
+
+ # Fixes zarafa-server linking
+ epatch "${FILESDIR}"/"${P}"-uuid-link.patch
+
+}
+
+src_configure() {
+ econf \
+ --enable-oss \
+ --disable-perl \
+ --disable-testtools \
+ --with-userscript-prefix=/etc/zarafa/userscripts \
+ --with-quotatemplate-prefix=/etc/zarafa/quotamails \
+ --with-indexerscripts-prefix=/etc/zarafa/indexerscripts \
+ $(use_enable static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ php-ext-base-r1_src_install
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/zarafa.logrotate zarafa || die "Failed to install logrotate"
+ fi
+
+ insinto /etc/zarafa
+ doins "${S}"/installer/linux/*.cfg || die "Failed to install config files"
+
+ dodir /var/log/zarafa
+ keepdir /var/log/zarafa
+
+ newinitd ${FILESDIR}/zarafa-gateway.rc6 zarafa-gateway
+ newinitd ${FILESDIR}/zarafa-ical.rc6 zarafa-ical
+ newinitd ${FILESDIR}/zarafa-indexer.rc6 zarafa-indexer
+ newinitd ${FILESDIR}/zarafa-monitor.rc6 zarafa-monitor
+ newinitd ${FILESDIR}/zarafa-server.rc6 zarafa-server
+ newinitd ${FILESDIR}/zarafa-spooler.rc6 zarafa-spooler
+}