summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2008-01-22 01:47:44 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2008-01-22 01:47:44 +0000
commit8e37441bba61be7275d70b7f5a35e33129663913 (patch)
treed456bc3d2508e68d024c5f0dd7cfd221a55b9208
parentBump to 0.3.3 (diff)
downloadmaintainer-8e37441bba61be7275d70b7f5a35e33129663913.tar.gz
maintainer-8e37441bba61be7275d70b7f5a35e33129663913.tar.bz2
maintainer-8e37441bba61be7275d70b7f5a35e33129663913.zip
Add pigment-python
svn path=/maintainer/; revision=69
-rw-r--r--dev-python/pigment-python/Manifest8
-rw-r--r--dev-python/pigment-python/files/digest-pigment-python-0.3.13
-rw-r--r--dev-python/pigment-python/pigment-python-0.3.1.ebuild43
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pigment-python/Manifest b/dev-python/pigment-python/Manifest
new file mode 100644
index 0000000..cccf08d
--- /dev/null
+++ b/dev-python/pigment-python/Manifest
@@ -0,0 +1,8 @@
+DIST pigment-python-0.3.1.tar.gz 558803 RMD160 25226e8d4655eed6af12d19f51d051966d80e44f SHA1 283ae547d023327ddb905c1110458107a47e7a2d SHA256 8fd56c4c8a416d998459ffdf534e2215c2b6b8bfbada6b0feaeaa92b79ee165f
+EBUILD pigment-python-0.3.1.ebuild 866 RMD160 30cc842af7695f7d51520afe32151aff64eafc5d SHA1 ecd3f18ebb5d7e66527019c8f096754f8be96731 SHA256 149d13e2233dca5b9b099e11b69a2eb87c1092a40eef31042d117fc7e0e63cf2
+MD5 d8b7a1788401c252b5e6c04fad31cc0c pigment-python-0.3.1.ebuild 866
+RMD160 30cc842af7695f7d51520afe32151aff64eafc5d pigment-python-0.3.1.ebuild 866
+SHA256 149d13e2233dca5b9b099e11b69a2eb87c1092a40eef31042d117fc7e0e63cf2 pigment-python-0.3.1.ebuild 866
+MD5 9d9e1ddccac93b69b2462c360a00fc12 files/digest-pigment-python-0.3.1 262
+RMD160 6b5e3734d228d943538a453c5c3d0854f2002718 files/digest-pigment-python-0.3.1 262
+SHA256 1557982e46df4b0d8d07b1e67a3cb695528597130b22bec5360fe01689edeed1 files/digest-pigment-python-0.3.1 262
diff --git a/dev-python/pigment-python/files/digest-pigment-python-0.3.1 b/dev-python/pigment-python/files/digest-pigment-python-0.3.1
new file mode 100644
index 0000000..f9e168a
--- /dev/null
+++ b/dev-python/pigment-python/files/digest-pigment-python-0.3.1
@@ -0,0 +1,3 @@
+MD5 d104461aa5732afb7b69987923b1a82c pigment-python-0.3.1.tar.gz 558803
+RMD160 25226e8d4655eed6af12d19f51d051966d80e44f pigment-python-0.3.1.tar.gz 558803
+SHA256 8fd56c4c8a416d998459ffdf534e2215c2b6b8bfbada6b0feaeaa92b79ee165f pigment-python-0.3.1.tar.gz 558803
diff --git a/dev-python/pigment-python/pigment-python-0.3.1.ebuild b/dev-python/pigment-python/pigment-python-0.3.1.ebuild
new file mode 100644
index 0000000..d228ae6
--- /dev/null
+++ b/dev-python/pigment-python/pigment-python-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2006-2007 BreakMyGentoo.org
+# Distributed under the terms of the GNU General Public License v2
+
+inherit gnome2 python
+
+DESCRIPTION="Python bindings for pigment"
+HOMEPAGE="http://elisa.fluendo.com/"
+SRC_URI="http://elisa.fluendo.com/static/download/pigment/${P}.tar.gz"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/pigment-0.3.3
+ >=dev-libs/glib-2.8
+ >=dev-python/pygobject-2.8
+ >=media-libs/gstreamer-0.10
+ >=media-libs/gst-plugins-base-0.10
+ >=x11-libs/gtk+-2
+ >=dev-lang/python-2.4"
+
+DEPEND="${DEPEND}"
+
+DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS README TODO"
+
+MAKEOPTS="-j1"
+
+src_install() {
+ einstall || die
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/python${PYVER}/site-packages/gtk-2.0
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}