summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gupnp/gupnp-0.12.ebuild')
-rw-r--r--net-libs/gupnp/gupnp-0.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/gupnp/gupnp-0.12.ebuild b/net-libs/gupnp/gupnp-0.12.ebuild
new file mode 100644
index 0000000..862d5b0
--- /dev/null
+++ b/net-libs/gupnp/gupnp-0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp/gupnp-0.8.ebuild,v 1.1 2008/04/24 15:20:00 drac Exp $
+
+EAPI=1
+
+DESCRIPTION="an object-oriented framework for creating UPnP devs and control points."
+HOMEPAGE="http://gupnp.org"
+SRC_URI="http://${PN}.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-libs/gssdp-0.3
+ net-libs/libsoup:2.2
+ dev-libs/libxml2
+ x11-misc/shared-mime-info
+ sys-fs/e2fsprogs"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_compile() {
+ econf --disable-dependency-tracking --disable-gtk-doc
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README
+}