aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2011-11-28 12:20:47 -0600
committerDonnie Berkholz <dberkholz@gentoo.org>2011-11-28 12:20:47 -0600
commit98f371584107e86f629f9ad4e5100017533b9dad (patch)
tree05a2d1c7b9e96202e4ed3a538d7b6fe804453eb6
parentAdd pystache from <https://github.com/aegypius/overlay>. (diff)
downloaddberkholz-98f371584107e86f629f9ad4e5100017533b9dad.tar.gz
dberkholz-98f371584107e86f629f9ad4e5100017533b9dad.tar.bz2
dberkholz-98f371584107e86f629f9ad4e5100017533b9dad.zip
Add Requests, based on bug #380137.
-rw-r--r--dev-python/requests/Manifest2
-rw-r--r--dev-python/requests/requests-0.8.3.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
new file mode 100644
index 0000000..4c125c4
--- /dev/null
+++ b/dev-python/requests/Manifest
@@ -0,0 +1,2 @@
+DIST requests-0.8.3.tar.gz 51252 RMD160 7e931879303afc2caf2a92154750e061521ede8e SHA1 64cb104ae78bcf6b5ea84cc9389dcaf0b60628ac SHA256 7277ec1fc8b8251bc1ce628651cbfad886704a77aea9f6203dcc042a4f12d214
+EBUILD requests-0.8.3.ebuild 815 RMD160 76f47a6d3edce8e01f8e3480b545e269e47500a1 SHA1 3743e1675038bf3752e50ee59eae360bea9c0c5e SHA256 cc1f769071976ea6d34184cdc3f90c774eca91fb8bffffbca778bdfcc4d38932
diff --git a/dev-python/requests/requests-0.8.3.ebuild b/dev-python/requests/requests-0.8.3.ebuild
new file mode 100644
index 0000000..03247e7
--- /dev/null
+++ b/dev-python/requests/requests-0.8.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Requests is an ISC Licensed HTTP library, written in Python, for human beings."
+HOMEPAGE="http://python-requests.org/ http://pypi.python.org/pypi/requests"
+SRC_URI="https://github.com/kennethreitz/requests/tarball/v${PV} -> ${P}.tar.gz http://pypi.python.org/packages/source/r/requests/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/libevent
+ dev-python/gevent"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="requests"
+
+src_test() {
+ testing() {
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" test_requests.py
+ }
+ python_execute_function testing
+}