aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2010-05-03 19:37:14 -0500
committerDonnie Berkholz <dberkholz@gentoo.org>2010-05-03 19:37:14 -0500
commitd478867602fdef1c554efe7be0fc48fba8edbbd6 (patch)
treecc87c37469939c51a40b51bb478f1a756d19a10f /app-pda
parentbiopython: add a 1.54 beta ebuild. (diff)
downloaddberkholz-d478867602fdef1c554efe7be0fc48fba8edbbd6.tar.gz
dberkholz-d478867602fdef1c554efe7be0fc48fba8edbbd6.tar.bz2
dberkholz-d478867602fdef1c554efe7be0fc48fba8edbbd6.zip
Add ipheth-pair for iphone USB tethering, modified from bug #306495.
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/ipheth-pair/Manifest2
-rw-r--r--app-pda/ipheth-pair/files/Makefile.patch19
-rw-r--r--app-pda/ipheth-pair/ipheth-pair-9999.ebuild32
3 files changed, 53 insertions, 0 deletions
diff --git a/app-pda/ipheth-pair/Manifest b/app-pda/ipheth-pair/Manifest
new file mode 100644
index 0000000..5a1875e
--- /dev/null
+++ b/app-pda/ipheth-pair/Manifest
@@ -0,0 +1,2 @@
+AUX Makefile.patch 599 RMD160 bcafed0d2452d76df214ad9043d9ea3dc1624b07 SHA1 41ee0f0bfa4aaeb457453b674b71037873cfd200 SHA256 5a9f0b45bfe397501d5503ff94fed6f275f9d7567051dd9a8fd60feeeaa519d2
+EBUILD ipheth-pair-9999.ebuild 690 RMD160 8f3b774c7a53c358986c11295543d3d4357c2af0 SHA1 c55159132c46ebf16008a3b49c0260f5ecbe01e0 SHA256 3fa896db490607fe1511faf1e8ed3cf80d75e39a5281b9f8368362612e38afb5
diff --git a/app-pda/ipheth-pair/files/Makefile.patch b/app-pda/ipheth-pair/files/Makefile.patch
new file mode 100644
index 0000000..6ec0cd4
--- /dev/null
+++ b/app-pda/ipheth-pair/files/Makefile.patch
@@ -0,0 +1,19 @@
+--- ipheth-pair/Makefile.orig 2010-02-23 10:35:56.000000000 +0200
++++ ipheth-pair/Makefile 2010-02-23 10:37:02.099913826 +0200
+@@ -1,4 +1,3 @@
+-CFLAGS += -Wall -O2
+ LDLIBS += -limobiledevice
+
+ all: ipheth-pair
+@@ -6,9 +5,8 @@
+ ipheth-pair: ipheth-pair.o
+
+ install:
+- install -m 0755 ipheth-pair /lib/udev/
+- install -m 0644 90-iphone-tether.rules /etc/udev/rules.d
+- /sbin/udevadm control --reload-rules
++ install -D -m 0755 ipheth-pair ${DESTDIR}/lib/udev/ipeth-pair
++ install -D -m 0644 90-iphone-tether.rules ${DESTDIR}/etc/udev/rules.d/90-iphone-tether.rules
+
+ clean:
+ rm -f *.o ipheth-pair
diff --git a/app-pda/ipheth-pair/ipheth-pair-9999.ebuild b/app-pda/ipheth-pair/ipheth-pair-9999.ebuild
new file mode 100644
index 0000000..4e86e5e
--- /dev/null
+++ b/app-pda/ipheth-pair/ipheth-pair-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit git autotools
+
+DESCRIPTION="iPhone USB Ethernet Driver for Linux pairing helper"
+HOMEPAGE="http://giagio.com/wiki/moin.cgi/iPhoneEthernetDriver"
+EGIT_REPO_URI="git://github.com/dgiagio/ipheth.git/"
+EGIT_PROJECT="ipheth"
+
+EGIT_PATCHES="${FILESDIR}/Makefile.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="app-pda/libimobiledevice"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ emake -C ipheth-pair || die
+}
+
+src_install() {
+ emake -C ipheth-pair DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ udevadm control --reload-rules && udevadm trigger
+}