aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-04-18 21:57:02 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-04-18 21:57:02 -0700
commit6c84aefc5fa51fc1069ab20a91131d27eacc5d2b (patch)
treef1712d3c509add73ca9221a45abd78553fe61946 /dev-lang
parentsap: Structure Alignment Program. Required for some t-coffee operations. (diff)
downloaddberkholz-6c84aefc5fa51fc1069ab20a91131d27eacc5d2b.tar.gz
dberkholz-6c84aefc5fa51fc1069ab20a91131d27eacc5d2b.tar.bz2
dberkholz-6c84aefc5fa51fc1069ab20a91131d27eacc5d2b.zip
sunstudio: forgot to actually commit the 200709 ebuild.
It's probably way out of date by now, anyway, but it's something to base an update on.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/sunstudio/sunstudio-12_p200709.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-lang/sunstudio/sunstudio-12_p200709.ebuild b/dev-lang/sunstudio/sunstudio-12_p200709.ebuild
new file mode 100644
index 0000000..3e0c52b
--- /dev/null
+++ b/dev-lang/sunstudio/sunstudio-12_p200709.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Installation README:
+# http://developers.sun.com/sunstudio/downloads/tarfile_info.html
+
+inherit versionator
+
+MY_PN="SunStudio"
+MY_TAG="-ii"
+PV_VER=$(get_version_component_range 1 ${PV})
+PV_DATE=$(get_version_component_range 2 ${PV})
+# Can't figure out how to make this generic to pre, p, rc, etc..
+PV_DATE=${PV_DATE#p}
+MY_P="${MY_PN}${PV_VER}ml-linux-x86-${PV_DATE}${MY_TAG}"
+DESCRIPTION="Sun Studio Compilers for Linux"
+HOMEPAGE="http://developers.sun.com/sunstudio/downloads/index.jsp"
+RESTRICT="fetch"
+SRC_URI="${MY_P}.tar.bz2"
+# Change to the actual license if adding to the tree
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+# dev-util/netbeans-cnd is in java-overlay, but doesn't seem to work
+RDEPEND="!amd64? ( virtual/libstdc++ )
+ amd64? ( app-emulation/emul-linux-x86-compat )
+ sys-libs/zlib
+ =virtual/jre-1.5*
+ =dev-util/netbeans-5.5*"
+DEPEND=""
+S="${WORKDIR}"
+
+pkg_nofetch() {
+ einfo "Go to ${HOMEPAGE}"
+ einfo "and download ${SRC_URI}"
+}
+
+pkg_setup() {
+ if ! [ -d "${ROOT}"usr/share/netbeans-5.5/cnd1 ]; then
+ local msg="You must install the C/C++ pack from http://www.netbeans.org/products/cplusplus/ as root"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_install() {
+ DIR="/opt/sun/sunstudio12"
+
+ dodir /opt/sun
+ cp -r sunstudio12 "${D}"/opt/sun/
+
+ # Set SUNW_NO_UPDATE_NOTIFY to anything but false to disable writes
+ # to /root/.sunstudio
+ # These writes break the sandbox when building anything with Sun compilers
+ cat << EOF >> ${T}/envd
+ROOTPATH="${DIR}/bin"
+PATH="${DIR}/bin"
+MANPATH="${DIR}/man"
+SUNW_NO_UPDATE_NOTIFY="true"
+EOF
+
+ newenvd ${T}/envd 05${PN}
+}