aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-12-03 14:42:10 -0800
committerDonnie Berkholz <dberkholz@gentoo.org>2008-12-03 14:42:10 -0800
commitd38fc415233de34989bccbc30890d5ad58325b5c (patch)
treeff0506b906892ba182506aee1530b7044aadbfee /dev-python
parentpython-biggles: bupm to 1.6.5. (diff)
downloaddberkholz-d38fc415233de34989bccbc30890d5ad58325b5c.tar.gz
dberkholz-d38fc415233de34989bccbc30890d5ad58325b5c.tar.bz2
dberkholz-d38fc415233de34989bccbc30890d5ad58325b5c.zip
spasmoidal: another python package for multitasking.
The SpasmodicEngine selects tasks (spasmoids) from a (heapqueue based) priority queue. The tasks are Python 2.5 extended generators (some call them coroutines: PEP 342). The engine calls task.send() with an appropriate argument. One of the library of tasks is Pollster. Pollster calls poll() with for tasks that are waiting I/O. Tasks that are ready for I/O are fed to the priority queue. Spasmodic provides an efficient way to manage a large number of sockets and/or files. Other processing works well too, if it can be subdivided into brief spasms.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/spasmoidal/Manifest8
-rw-r--r--dev-python/spasmoidal/files/digest-spasmoidal-0.1.13
-rw-r--r--dev-python/spasmoidal/spasmoidal-0.1.1.ebuild14
3 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/spasmoidal/Manifest b/dev-python/spasmoidal/Manifest
new file mode 100644
index 0000000..1e31d4c
--- /dev/null
+++ b/dev-python/spasmoidal/Manifest
@@ -0,0 +1,8 @@
+DIST spasmoidal-0.1.1.tar.gz 9324 RMD160 731ff07ac19c3e39d05828eadfe524e2adaf9f9e SHA1 25b857ea2934d199718d32769c6b9162aec5839f SHA256 c716a37b56e034e5885ee923093a5bbb3ce79c52cb78d54d7f507ed2f2eb4e02
+EBUILD spasmoidal-0.1.1.ebuild 393 RMD160 16b446862423dc782014f3cf2d9e70431be4a8be SHA1 484ce750ac6050c7651728915badf0f9fc6f8f2a SHA256 68db2c52abf46f4e1860d176c5d9845f50860878501fe0d31c07e14c8aa8db72
+MD5 06618e5a388146e58efe5b5851ae5ef6 spasmoidal-0.1.1.ebuild 393
+RMD160 16b446862423dc782014f3cf2d9e70431be4a8be spasmoidal-0.1.1.ebuild 393
+SHA256 68db2c52abf46f4e1860d176c5d9845f50860878501fe0d31c07e14c8aa8db72 spasmoidal-0.1.1.ebuild 393
+MD5 1b3ac6a5140f2e05bfb14e3b3a521c90 files/digest-spasmoidal-0.1.1 244
+RMD160 418db9a55ba4953cd88de89af6683b649a6af70d files/digest-spasmoidal-0.1.1 244
+SHA256 c04574e5052cca1f51c8187a0724b4487f70e8a1826caffb32f1908e1f3c2770 files/digest-spasmoidal-0.1.1 244
diff --git a/dev-python/spasmoidal/files/digest-spasmoidal-0.1.1 b/dev-python/spasmoidal/files/digest-spasmoidal-0.1.1
new file mode 100644
index 0000000..afd0aac
--- /dev/null
+++ b/dev-python/spasmoidal/files/digest-spasmoidal-0.1.1
@@ -0,0 +1,3 @@
+MD5 2baddbca1db1dfb0c4ea3c493071459f spasmoidal-0.1.1.tar.gz 9324
+RMD160 731ff07ac19c3e39d05828eadfe524e2adaf9f9e spasmoidal-0.1.1.tar.gz 9324
+SHA256 c716a37b56e034e5885ee923093a5bbb3ce79c52cb78d54d7f507ed2f2eb4e02 spasmoidal-0.1.1.tar.gz 9324
diff --git a/dev-python/spasmoidal/spasmoidal-0.1.1.ebuild b/dev-python/spasmoidal/spasmoidal-0.1.1.ebuild
new file mode 100644
index 0000000..2056f0c
--- /dev/null
+++ b/dev-python/spasmoidal/spasmoidal-0.1.1.ebuild
@@ -0,0 +1,14 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+# Ebuild generated by g-pypi 0.2.0 (rev. 204)
+
+inherit distutils
+
+DESCRIPTION="Spasmodic Engine"
+HOMEPAGE="http://code.google.com/p/spasmoidal/"
+SRC_URI="http://pypi.python.org/packages/source/s/spasmoidal/${P}.tar.gz"
+LICENSE="Apache-2.0"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""