aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-04-15 01:21:04 -0700
committerDonnie Berkholz <dberkholz@gentoo.org>2008-04-15 01:21:04 -0700
commit561b7121b0393a041330600e267dc6c49aa14dd7 (patch)
tree49712657e7e126d0f41ae9097737e3056c0a8aca /sci-physics
parentpython: add 2.5.2. (diff)
downloaddberkholz-561b7121b0393a041330600e267dc6c49aa14dd7.tar.gz
dberkholz-561b7121b0393a041330600e267dc6c49aa14dd7.tar.bz2
dberkholz-561b7121b0393a041330600e267dc6c49aa14dd7.zip
octopus: Add a time-dependent density functional theory program.
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/octopus/Manifest2
-rw-r--r--sci-physics/octopus/octopus-3.0.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-physics/octopus/Manifest b/sci-physics/octopus/Manifest
new file mode 100644
index 0000000..1b6a3eb
--- /dev/null
+++ b/sci-physics/octopus/Manifest
@@ -0,0 +1,2 @@
+DIST octopus-3.0.0.tar.gz 3448044 RMD160 a6470e8803b237e3b7aa81bb7e9fe16d6669df4f SHA1 53cb51d96fdb9491a558803cb1c51eea869ebf43 SHA256 cdf31d17044b2de5b81f647085f9b40605ca48bc9e6170762f0a633d53cbde67
+EBUILD octopus-3.0.0.ebuild 1013 RMD160 e1e35fd1c5fe6c2f8b9c19a8d3a889505ebb7503 SHA1 fffdb976ee546fb38d45c63eb9d9ffd472107a71 SHA256 7b933168cbf66d80a4a3276ea18e44bb32d05f2c0ebe452a2a92072d95a6a338
diff --git a/sci-physics/octopus/octopus-3.0.0.ebuild b/sci-physics/octopus/octopus-3.0.0.ebuild
new file mode 100644
index 0000000..9283d7b
--- /dev/null
+++ b/sci-physics/octopus/octopus-3.0.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=1
+
+inherit fortran
+
+FORTRAN="gfortran"
+
+DESCRIPTION="A first principles, electronic structure, excited states, time-dependent density functional theory program"
+HOMEPAGE="http://www.tddft.org/programs/octopus/"
+SRC_URI="http://www.tddft.org/programs/octopus/download/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="mpi openmp"
+RDEPEND="virtual/lapack
+ virtual/blas
+ sci-libs/fftw:3.0
+ >=sci-libs/gsl-1.9
+ mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf \
+ $(use_enable mpi) \
+ $(use_enable openmp) \
+ --with-fft=fftw3 \
+ --disable-gsltest \
+ FCFLAGS="${FFLAGS:- -O2}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake test
+ elog "If eigenvalue tests failed, it may be because they didn't converge."
+ elog "This is not a problem."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}