aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <donnie@comet.(none)>2006-04-24 00:11:19 -0700
committerDonnie Berkholz <donnie@comet.(none)>2006-04-24 00:11:19 -0700
commite4a6ce681f4b854bbb3cfdd53ae192cd7ff8b087 (patch)
tree6386a70c59a8d1e33bb7cd8533dea220efbe1a90 /sys-cluster
parentMerge branch 'master' of git+ssh://spyderous@people.freedesktop.org/~spyderou... (diff)
downloaddberkholz-e4a6ce681f4b854bbb3cfdd53ae192cd7ff8b087.tar.gz
dberkholz-e4a6ce681f4b854bbb3cfdd53ae192cd7ff8b087.tar.bz2
dberkholz-e4a6ce681f4b854bbb3cfdd53ae192cd7ff8b087.zip
Remove things in sync with gentoo-x86.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old84
1 files changed, 0 insertions, 84 deletions
diff --git a/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old b/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old
deleted file mode 100644
index 2bf6cca..0000000
--- a/sys-cluster/mpich2/mpich2-1.0.2_p1.ebuild.old
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit flag-o-matic fortran
-
-MY_P=${P/_}
-DESCRIPTION="MPICH 2 - A portable MPI implementation, version 2"
-HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich2"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${MY_P}.tar.gz"
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="fortran f90 threads"
-
-DEPEND="virtual/libc
- >=dev-lang/python-2.2.3
- dev-python/pyxml
- dev-libs/expat"
-
-RDEPEND="${DEPEND}
- !sys-cluster/lam-mpi"
-
-S=${WORKDIR}/${MY_P}
-
-# Allowed Fortran compilers
-FORTRAN="g77 ifc"
-
-pkg_setup() {
- if [ -n "${MPICH2_CONFIGURE_OPTS}" ]; then
- einfo "Custom configure options are ${MPICH2_CONFIGURE_OPTS}."
- fi
-
- if use fortran; then
- fortran_pkg_setup
- fi
-}
-
-src_compile() {
- if use fortran; then
- export F77=${FORTRANC}
- fi
-
- local myconf="${MPICH2_CONFIGURE_OPTS}"
-
- append-ldflags -Wl,-z,now
-
- # Can't assume f90 is available if f77 is
- if use fortran; then
- myconf="${myconf} --enable-f77"
-
- if use f90; then
- myconf="${myconf}--enable-f90"
- ewarn "Only >=gcc-4 supports Fortran 90."
- fi
- else
- myconf="${myconf} --disable-f77 --disable-f90"
- fi
-
- if use threads; then
- myconf="${myconf} --enable-threads"
- fi
-
- econf \
- ${myconf} \
- --with-common-prefix=/usr/share/mpich2 \
- --with-arch=LINUX \
- --sysconfdir=/etc/mpich2 \
- || die "configure failed"
-# --with-wwwdir=${D}/usr/share/doc/${PF}/html \
-# --disable-mpe \
-
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- # Fix mpe2 includes
- export PREFIX="${D}/usr"
-
- einstall \
- includedir="${D}/usr/include" || die "make install failed"
-# make DESTDIR=${D} install || die "make install failed"
- dodoc README COPYRIGHT
-}