aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/ccp1gui/Manifest2
-rw-r--r--sci-chemistry/ccp1gui/ccp1gui-0.7.ebuild72
-rw-r--r--sci-chemistry/ccp1gui/files/digest-ccp1gui-0.63
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/ccp1gui/Manifest b/sci-chemistry/ccp1gui/Manifest
new file mode 100644
index 0000000..9203180
--- /dev/null
+++ b/sci-chemistry/ccp1gui/Manifest
@@ -0,0 +1,2 @@
+DIST ccp1gui-0.7.tar.gz 1615847 RMD160 9dc9cfc1104a076910fb0e80e21e098f6b620384 SHA1 20f97f9349e2595c68f151c4ad6b2be2e8ad4483 SHA256 d79cea6e0d450ab5ba66045a3d3be524060790fab8d9e08d5b090fef71e30a47
+EBUILD ccp1gui-0.7.ebuild 1808 RMD160 5924c0c66e92e511eb7b0d88671ce856d10f171d SHA1 402981234f37d3e58e7a107f7e03d5195e0df4d6 SHA256 947e5f62f54309056954a9473954a1cda2b420d63040a5ceee18638eb6bc9b1e
diff --git a/sci-chemistry/ccp1gui/ccp1gui-0.7.ebuild b/sci-chemistry/ccp1gui/ccp1gui-0.7.ebuild
new file mode 100644
index 0000000..77b8de3
--- /dev/null
+++ b/sci-chemistry/ccp1gui/ccp1gui-0.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# Inherit distutils for convenience functions, not because this uses distutils
+# build system
+inherit python distutils
+
+DESCRIPTION="A free, extensible Graphical User Interface (GUI) for community chemistry programs"
+HOMEPAGE="http://www.cse.scitech.ac.uk/ccg/software/ccp1gui/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RDEPEND="dev-lang/python
+ dev-python/numeric
+ dev-python/scientificpython
+ sci-libs/vtk
+ dev-python/pmw"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ distutils_python_tkinter
+}
+
+src_unpack() {
+ unpack ${A}
+
+ ebegin "Removing CVS directories"
+ find . -type d -name CVS \
+ | xargs rm -rf
+ eend $?
+
+ ebegin "Updating for MOPAC script name in Gentoo, run_mopac7"
+ sed -i \
+ -e "s:\(run_mopac\):\17:g" \
+ "${S}"/interfaces/mopac.py
+ eend $?
+}
+
+# Overwrite distutils.eclass default
+src_compile() { :; }
+
+src_install() {
+ python_version
+
+ local PYDIR="$(get_libdir)/python${PYVER}/site-packages/${PN}"
+ local DIR="/usr/${PYDIR}"
+ dodir ${DIR} || die "Creating installation directory failed"
+
+ local subdir
+ for subdir in basis chempy generic idle interfaces jobmanager objects scripts viewer; do
+ cp -pPR ${subdir} "${D}${DIR}" \
+ || die "Copying files to installation directory failed"
+ done
+
+ dodoc README doc/*txt || die "Installing docs failed"
+ dohtml -r doc/*htm doc/html/* || die "Installing html docs failed"
+
+ dodir /usr/share/${PN}
+ cp -pPR examples ${D}usr/share/${PN}/ || die "Installing examples failed"
+
+ # Create a wrapper executable
+ cat >> "${T}"/${PN} <<- EOF
+ #!/bin/sh
+ python "${DIR}"/viewer/main.py $*
+ EOF
+
+ dobin "${T}"/${PN} || die "Installing wrapper failed"
+}
diff --git a/sci-chemistry/ccp1gui/files/digest-ccp1gui-0.6 b/sci-chemistry/ccp1gui/files/digest-ccp1gui-0.6
new file mode 100644
index 0000000..2e53223
--- /dev/null
+++ b/sci-chemistry/ccp1gui/files/digest-ccp1gui-0.6
@@ -0,0 +1,3 @@
+MD5 c07e36bb08542eeae7d524858b319892 ccp1gui-0.6.tar.gz 1406995
+RMD160 e324d16e6551c652fa13ac911b3b2aa44afeb65d ccp1gui-0.6.tar.gz 1406995
+SHA256 5fcbc11e2e2bf01478718e4cebcbb664e33482aa248b22ee4027b6015d11d41b ccp1gui-0.6.tar.gz 1406995