summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-03-28 23:01:05 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-03-28 23:01:05 +0200
commit834351e6088e4f8f254df6d84db174913071ca82 (patch)
tree827dd8c90abff1a858f91d0b4e44099e0fcf941f
parentmedia-gfx/odafileconverter: deps & QA_PREBUILT (diff)
downloaddilfridge-834351e6088e4f8f254df6d84db174913071ca82.tar.gz
dilfridge-834351e6088e4f8f254df6d84db174913071ca82.tar.bz2
dilfridge-834351e6088e4f8f254df6d84db174913071ca82.zip
media-gfx/odafileconverter: add bundled-libs use
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--media-gfx/odafileconverter/odafileconverter-24.2.ebuild20
1 files changed, 19 insertions, 1 deletions
diff --git a/media-gfx/odafileconverter/odafileconverter-24.2.ebuild b/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
index 1dd6a18..57f468d 100644
--- a/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
+++ b/media-gfx/odafileconverter/odafileconverter-24.2.ebuild
@@ -13,17 +13,35 @@ SRC_URI="https://download.opendesign.com/guestfiles/Demo/ODAFileConverter_QT5_ln
KEYWORDS="-* ~amd64"
SLOT="0"
LICENSE="all-rights-reserved"
+IUSE="bundled-libs"
RESTRICT="mirror bindist"
RDEPEND="
- media-libs/tiff-compat:4
+ bundled-libs? ( media-libs/tiff-compat:4 )
"
S=${WORKDIR}
QA_PREBUILT="*"
+src_prepare() {
+ eapply_user
+
+ if ! use bundled-libs ; then
+ MY_REMOVE_LIBS=(
+ libQt5
+ )
+ for name in ${MY_REMOVE_LIBS} ; do
+ find "${S}" -name ${name}'*' -delete
+ done
+
+ # remove qt plugins
+ rm -rfv "${S}"/usr/local/bin/ODAFileConverter_${PV}*/plugins
+ rm -rfv "${S}"/usr/local/bin/ODAFileConverter_${PV}*/qt.conf
+ fi
+}
+
src_install() {
# we dont want automated desktop icons
rm -r "${S}"/etc