summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-12-14 11:14:36 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-12-14 11:14:36 +0000
commitf58bc21a4898a1af109deae0464bbf1fada6aa73 (patch)
treea59da70e31914fba83373bd78192295289cffa8b
parentVersion bump (diff)
downloaddrizzt-f58bc21a4898a1af109deae0464bbf1fada6aa73.tar.gz
drizzt-f58bc21a4898a1af109deae0464bbf1fada6aa73.tar.bz2
drizzt-f58bc21a4898a1af109deae0464bbf1fada6aa73.zip
New package
svn path=/; revision=140
-rw-r--r--net-analyzer/imspector/Manifest2
-rw-r--r--net-analyzer/imspector/imspector-0.3.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/imspector/Manifest b/net-analyzer/imspector/Manifest
new file mode 100644
index 0000000..89c97a5
--- /dev/null
+++ b/net-analyzer/imspector/Manifest
@@ -0,0 +1,2 @@
+DIST imspector-0.3.tar.gz 29919 RMD160 6f07843b99f9ff7a5018e0f0676d118332e6a8ff SHA1 eee72eaaa7bc6202094cf6c1bcbd411b80e576a8 SHA256 134f84c58e897a9447ea6700ba805ba601a765a3fd0db5b495d37e0b31eb7d3a
+EBUILD imspector-0.3.ebuild 552 RMD160 82de97796d078c7d50750ce567fc94be86866b34 SHA1 2734078469f6cbbcf927b336a7711605bf3550dd SHA256 8dcf07e463352b3112326c40c2cc33b113ad6e37f51f565377fc71c609a012d3
diff --git a/net-analyzer/imspector/imspector-0.3.ebuild b/net-analyzer/imspector/imspector-0.3.ebuild
new file mode 100644
index 0000000..7d69ef9
--- /dev/null
+++ b/net-analyzer/imspector/imspector-0.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Instant Messenger transparent proxy with logging capabilities."
+HOMEPAGE="http://www.imspector.org/"
+SRC_URI="http://www.imspector.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i -e 's/^CXXFLAGS =.*/CXXFLAGS += -fPIC/' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" || die 'emake failed'
+}