summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-26 17:28:53 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-26 17:28:53 +0200
commit25864e03b9961718d2e3bb617deaece802d6a1c2 (patch)
tree531d16e991f27822aac320af7ff30cb08d2d3691 /app-crypt
parentdev-python/rq: add missing dependency on importlib (diff)
downloadeva-25864e03b9961718d2e3bb617deaece802d6a1c2.tar.gz
eva-25864e03b9961718d2e3bb617deaece802d6a1c2.tar.bz2
eva-25864e03b9961718d2e3bb617deaece802d6a1c2.zip
app-crypt/gnomint: fix missing gcrypt references
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnomint/Manifest8
-rw-r--r--app-crypt/gnomint/files/gnomint-1.2.1-add-missing-gcrypt.patch50
-rw-r--r--app-crypt/gnomint/gnomint-1.2.1.ebuild16
3 files changed, 65 insertions, 9 deletions
diff --git a/app-crypt/gnomint/Manifest b/app-crypt/gnomint/Manifest
index 565c3cb..405ed48 100644
--- a/app-crypt/gnomint/Manifest
+++ b/app-crypt/gnomint/Manifest
@@ -1,11 +1,11 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512
-DIST gnomint-1.2.1.tar.gz 703316 SHA256 6186ca6073e912bad5e0b026bc704430098a54392f3741d62929cc6fca3c38b0
+DIST gnomint-1.2.1.tar.gz 703316 SHA256 6186ca6073e912bad5e0b026bc704430098a54392f3741d62929cc6fca3c38b0 SHA512 7f286d92aaa00a8b340f785a21ed3ff322304b8f97b898585814588bc81c968140b7270e1d2c8c3a091b6555d148f63b1cac14de72be336911c00eeb33283a94 WHIRLPOOL 3f8a5653bc24eb88956e2691074bbf284429c9dde1a079d5502f6c4bbbd49163c314a644b6aeeacc6ba6f578ba68f1e162757f3ba19a7e4e1e437d5005cfaf87
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)
-iEYEAREKAAYFAlCCf4UACgkQ1fmVwcYIWAZ4PQCgpKw6pf21XoIPYHGmhYNHj9we
-S3MAn1NA2lZ4CZureNHjuuBesu82eFcp
-=zNyt
+iEYEAREKAAYFAlCKrBcACgkQ1fmVwcYIWAbrcwCePnvSBiB8scQfniDfMU9WYCmk
+lFsAoMqADQbT83Bf7MJB3P9JScj3rv9S
+=SE8G
-----END PGP SIGNATURE-----
diff --git a/app-crypt/gnomint/files/gnomint-1.2.1-add-missing-gcrypt.patch b/app-crypt/gnomint/files/gnomint-1.2.1-add-missing-gcrypt.patch
new file mode 100644
index 0000000..aff6bb9
--- /dev/null
+++ b/app-crypt/gnomint/files/gnomint-1.2.1-add-missing-gcrypt.patch
@@ -0,0 +1,50 @@
+From 8168b5a2d1c7cfebf84a2045c2ae094033f0fe71 Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <gilles@gandi.net>
+Date: Wed, 24 Oct 2012 11:37:05 +0200
+Subject: [PATCH] Add missing libgcrypt in CFLAGS/LDADD
+
+---
+ src/Makefile.am | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index cbb66d0..f4395db 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -7,7 +7,7 @@ gnomint_CFLAGS = \
+ -I$(top_builddir) \
+ $(GNOMINT_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) \
+- $(LIBGCRYPT_CFLAGS) \
++ $(LIBGCRYPT_CFLAGS) \
+ $(SQLITE_CFLAGS) \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DCOMPILATION_DATE=`date +%s` \
+@@ -40,7 +40,7 @@ gnomint_SOURCES = \
+
+ gnomint_LDADD = \
+ $(GNOMINT_LIBS) \
+- $(LIBGCRYPT_LIBS) \
++ $(LIBGCRYPT_LIBS) \
+ $(LIBGNUTLS_LIBS) \
+ $(SQLITE_LIBS) \
+ $(LTLIBINTL)
+@@ -54,6 +54,7 @@ gnomint_cli_CFLAGS = \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(GNOMINTCLI_CFLAGS) \
++ $(LIBGCRYPT_CFLAGS) \
+ $(LIBGNUTLS_CFLAGS) \
+ $(SQLITE_CFLAGS) \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+@@ -82,6 +83,7 @@ gnomint_cli_SOURCES = \
+ gnomint_cli_LDADD = \
+ $(GNOMINTCLI_LIBS) \
+ $(LIBGNUTLS_LIBS) \
++ $(LIBGCRYPT_LIBS) \
+ $(SQLITE_LIBS) \
+ $(READLINE_LIBS) \
+ $(LTLIBINTL)
+--
+1.7.12.4
+
diff --git a/app-crypt/gnomint/gnomint-1.2.1.ebuild b/app-crypt/gnomint/gnomint-1.2.1.ebuild
index 9dea535..722e9e1 100644
--- a/app-crypt/gnomint/gnomint-1.2.1.ebuild
+++ b/app-crypt/gnomint/gnomint-1.2.1.ebuild
@@ -5,7 +5,7 @@
EAPI="4"
GCONF_DEBUG="no"
-inherit gnome2
+inherit autotools eutils gnome2
DESCRIPTION="A Certification Authority Software for Gnome"
HOMEPAGE="http://gnomint.sourceforge.net"
@@ -33,16 +33,22 @@ DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
"
-DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README TODO"
-
src_prepare() {
- gnome2_src_prepare
+ DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README TODO"
# Fix intltool tests
echo "src/country_table.c" >> po/POTFILES.in
# Do not build released software with stupid CFLAGS
- sed 's/-Werror//' configure.in configure || die "sed failed"
+ sed -e 's/-Werror//' \
+ -e 's/-g -O0//' \
+ -i configure.in configure || die
+
+ # Fix build due to missing gcrypt in LDADD/CFLAGS
+ epatch "${FILESDIR}/${P}-add-missing-gcrypt.patch"
+
+ eautoreconf
+ gnome2_src_prepare
}
src_install() {