summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/lam/lam-5.6.ebuild')
-rw-r--r--www-apps/lam/lam-5.6.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/www-apps/lam/lam-5.6.ebuild b/www-apps/lam/lam-5.6.ebuild
deleted file mode 100644
index c5a1cbd..0000000
--- a/www-apps/lam/lam-5.6.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit webapp
-
-MY_P="ldap-account-manager-${PV}"
-DESCRIPTION="Frontend for managing accounts stored in an LDAP directory."
-HOMEPAGE="http://lam.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="${DEPEND}
- >=dev-lang/php-5.6[ldap,nls,session,xml]
- virtual/httpd-php
-"
-
-S="${WORKDIR}"/${MY_P}
-
-src_prepare() {
- default
-
- for conffile in config/*.cfg.sample
- do
- mv ${conffile} ${conffile/.sample/}
- done
-}
-
-src_compile() {
- :
-}
-
-src_install() {
- webapp_src_preinst
-
- local docs="copyright HISTORY README VERSION"
- dodoc ${docs}
- docinto html
- dodoc -r docs/{devel,manual}
-
- einfo "Copying VERSION file"
- cp VERSION "${D}${MY_HTDOCSDIR}"
- rm -f ${docs}
-
- einfo "Copying main files"
- cp -r . "${D}${MY_HTDOCSDIR}"
- cd "${D}${MY_HTDOCSDIR}"
-
- webapp_serverowned "${MY_HTDOCSDIR}"/config/config.cfg
- webapp_serverowned "${MY_HTDOCSDIR}"/sess
- webapp_serverowned "${MY_HTDOCSDIR}"/tmp
- webapp_serverowned "${MY_HTDOCSDIR}"/config
- webapp_serverowned "${MY_HTDOCSDIR}"/lib
-
- webapp_configfile "${MY_HTDOCSDIR}"/config/config.cfg
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}