summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wput/files/wput-0.6-gentoo.diff')
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff50
1 files changed, 8 insertions, 42 deletions
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
index 1f2a39f..3121723 100644
--- a/net-misc/wput/files/wput-0.6-gentoo.diff
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -1,52 +1,18 @@
-diff -urN wput/Makefile wput/Makefile
---- wput/Makefile 2006-04-04 19:06:27.000000000 +0100
-+++ wput/Makefile 2006-11-06 06:24:58.000000000 +0000
-@@ -15,8 +15,10 @@
+diff -urN wput/Makefile.in wput/Makefile.in
+--- wput/Makefile.in 2006-04-04 18:16:52.000000000 +0100
++++ wput/Makefile.in 2006-11-07 17:31:10.000000000 +0000
+@@ -15,8 +15,12 @@
install: all
cd po && $(MAKE) $(MAKEDEFS) $@
- install -m0755 wput $(bindir)
- install -m0644 doc/wput.1.gz $(mandir)
-+ mkdir -p $(DESTDIR)/$(bindir)
-+ mkdir -p $(DESTDIR)/$(mandir)
++
++ install -d $(DESTDIR)/$(bindir)
+ install -m0755 wput $(DESTDIR)/$(bindir)
++ install -d $(DESTDIR)/$(mandir)
+ install -m0644 doc/wput.1.gz $(DESTDIR)/$(mandir)
++
@echo "----------------"
@echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
@echo "Further documentation is located in the doc/USAGE.* files."
-diff -urN wput/src/ftp.c wput/src/ftp.c
---- wput/src/ftp.c 2006-04-07 23:14:47.000000000 +0100
-+++ wput/src/ftp.c 2006-11-06 06:21:24.000000000 +0000
-@@ -88,7 +88,7 @@
- * path and change there again */
- /* error-levels: ERR_RECONNECT, ERR_FAILED, ERR_SKIP (failed for '/'), 1 */
- int try_do_cwd(ftp_con * ftp, char * path, int mkd) {
-- int res;
-+ int res = -1;
- if(!strcmp(path, "."))
- return mkd;
- if(!strcmp(path, ".."))
-@@ -201,7 +201,7 @@
- }
-
- int open_input_file(_fsession * fsession) {
-- int fd;
-+ int fd = -1;
- int oflags = O_RDONLY;
- char * cmd;
- FILE * pipe;
-diff -urN wput/src/ftp-ls.c wput/src/ftp-ls.c
---- wput/src/ftp-ls.c 2006-04-06 22:09:18.000000000 +0100
-+++ wput/src/ftp-ls.c 2006-11-06 06:21:24.000000000 +0000
-@@ -44,6 +44,11 @@
- #include <sys/types.h>
- #include <errno.h>
-
-+#ifndef _XOPEN_SOURCE
-+# define _XOPEN_SOURCE
-+#endif
-+#include <time.h>
-+
- #include "wget.h"
- #include "utils.h"
- #include "ftp.h"