summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2021-11-05 13:50:44 +0100
committerHans de Graaff <hans@degraaff.org>2021-11-05 13:50:44 +0100
commit4e5af752336b5ee40d88c93d8065ecfc81ffc714 (patch)
tree920e5510661faa7ad63d490949ed279a125a5996 /app-emacs
parentdev-ruby/active_model_serializers: cleanup (diff)
downloadgraaff-4e5af752336b5ee40d88c93d8065ecfc81ffc714.tar.gz
graaff-4e5af752336b5ee40d88c93d8065ecfc81ffc714.tar.bz2
graaff-4e5af752336b5ee40d88c93d8065ecfc81ffc714.zip
app-emacs/typescript-mode: import of 0.4
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/typescript-mode/Manifest1
-rw-r--r--app-emacs/typescript-mode/files/50typescript-mode-gentoo.el10
-rw-r--r--app-emacs/typescript-mode/metadata.xml5
-rw-r--r--app-emacs/typescript-mode/typescript-mode-0.4.ebuild24
4 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/typescript-mode/Manifest b/app-emacs/typescript-mode/Manifest
new file mode 100644
index 00000000..f75396bf
--- /dev/null
+++ b/app-emacs/typescript-mode/Manifest
@@ -0,0 +1 @@
+DIST typescript-mode-0.4.tar.gz 65534 BLAKE2B b72047749cac571ad4a109b0d8650319137c2f75672882940092bff097e3a8c877b59cb51aa89b28a6cbeacfddbd6730e634a5a33305c006d401d326fd7f5704 SHA512 5bb38ab14fa9b022744b790e62740a95cee4ca906bab9eaaea8804cfae78c4ead54770d7e53d323ee57799bff5101cc10b7327105b7b0d0b17c74bda64203972
diff --git a/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el b/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el
new file mode 100644
index 00000000..00d6b45d
--- /dev/null
+++ b/app-emacs/typescript-mode/files/50typescript-mode-gentoo.el
@@ -0,0 +1,10 @@
+
+;;; typescript-mode site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'typescript-mode "typescript-mode" "Major mode for editing typescript." t)
+(add-to-list 'auto-mode-alist '("\\.ts\\'" . typescript-mode))
+(eval-after-load 'folding
+ '(when (fboundp 'folding-add-to-marks-list)
+ (folding-add-to-marks-list 'typescript-mode "// {{{" "// }}}" )))
diff --git a/app-emacs/typescript-mode/metadata.xml b/app-emacs/typescript-mode/metadata.xml
new file mode 100644
index 00000000..bd70e455
--- /dev/null
+++ b/app-emacs/typescript-mode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person"><email>graaff@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-emacs/typescript-mode/typescript-mode-0.4.ebuild b/app-emacs/typescript-mode/typescript-mode-0.4.ebuild
new file mode 100644
index 00000000..d9800ef7
--- /dev/null
+++ b/app-emacs/typescript-mode/typescript-mode-0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Major mode for typescript files"
+HOMEPAGE="https://github.com/emacs-typescript/typescript.el"
+SRC_URI="https://github.com/emacs-typescript/typescript.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/typescript.el-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+SITEFILE="50${PN}-gentoo.el"
+
+DOCS="README.md"
+
+# Uses unpackaged Cask
+RESTRICT="test"