summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-25 13:31:25 +0300
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-25 13:31:25 +0300
commit01b4c23d63d189a6d6bec1b548a20200d56c8c0e (patch)
tree5deaf68b984eeab8f567c64f0180d02359bc7e49
parentImport mesa-7.4.4 which fixes intel regressions. (diff)
downloadhwoarang-01b4c23d63d189a6d6bec1b548a20200d56c8c0e.tar.gz
hwoarang-01b4c23d63d189a6d6bec1b548a20200d56c8c0e.tar.bz2
hwoarang-01b4c23d63d189a6d6bec1b548a20200d56c8c0e.zip
On tree
-rw-r--r--media-libs/mesa/Manifest6
-rw-r--r--media-libs/mesa/files/6.5.2-i965-wine-fix.patch109
-rw-r--r--media-libs/mesa/files/7.4-fix-parallel-make.patch13
-rw-r--r--media-libs/mesa/files/lib/libGL.la32
-rw-r--r--media-libs/mesa/files/lib/libGLU.la32
-rw-r--r--media-libs/mesa/mesa-7.4.4.ebuild273
6 files changed, 0 insertions, 465 deletions
diff --git a/media-libs/mesa/Manifest b/media-libs/mesa/Manifest
deleted file mode 100644
index f6572e2..0000000
--- a/media-libs/mesa/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX 6.5.2-i965-wine-fix.patch 2888 RMD160 e899ac128933eb1a65e5c79de97408679beb2a50 SHA1 741221fba69b3891665e16da5baf6e66be62449d SHA256 bc19f4b5ce44a90c6b2aeab2c1148200539791ff9d0c60c5ffc2d4d8fe5fee78
-AUX 7.4-fix-parallel-make.patch 552 RMD160 06fdc748ef5ffa9ced1fd0b13d24299ad3522f97 SHA1 72801ed7e6951506811637675947aa9a869365f6 SHA256 4df0f41cffa5a0472f934da8ca1adf6c2b051a068943392a7ceeea3ae9c1b30a
-AUX lib/libGL.la 755 RMD160 a60984e0d56d559c2c15bd4693e01404a7e0a408 SHA1 d6e231ffaccd1b13c3628744031cc761ffaf76d8 SHA256 b32ffd7f3f866da7dbae80ba78b1dc5b4924b33ab133b13397af9cda0a274f91
-AUX lib/libGLU.la 752 RMD160 04de8835526a3472480d7c285dd33d497bcc0bd7 SHA1 12c57ac5e7e8a94d4d41b0f37b0fb3f470791c39 SHA256 e28519d7ae719bc106f7d4239799580474d1b69a2254ede3b2179a5e50655fe5
-DIST MesaLib-7.4.4.tar.bz2 3375615 RMD160 9c9a5e8b7f8d2fd175cc8542e2aecf48edf8c084 SHA1 1cdcef24900489bc0a879013b2138c0d9aedffe3 SHA256 eaf73d7a3a2dc959ddc0753abaa18160c64bec00b35bf4a0c96040b2072918ec
-EBUILD mesa-7.4.4.ebuild 7727 RMD160 df2d6717da22a38f89691efcc9fbc353c383ee78 SHA1 0007586afa4e417e45a22f4b8638c6247819c84a SHA256 19ec309998de434d3327eaa5e2dd967cfcc6bd8d98c97a7139eab2e10aa10e54
diff --git a/media-libs/mesa/files/6.5.2-i965-wine-fix.patch b/media-libs/mesa/files/6.5.2-i965-wine-fix.patch
deleted file mode 100644
index 63acd15..0000000
--- a/media-libs/mesa/files/6.5.2-i965-wine-fix.patch
+++ /dev/null
@@ -1,109 +0,0 @@
---- a/src/mesa/drivers/dri/i965/brw_context.h
-+++ b/src/mesa/drivers/dri/i965/brw_context.h
-@@ -599,6 +599,7 @@ struct brw_context
-
- struct {
- struct brw_wm_prog_data *prog_data;
-+ struct brw_wm_compile *compile_data;
-
- /* Input sizes, calculated from active vertex program:
- */
-diff --git a/src/mesa/drivers/dri/i965/brw_wm.c b/src/mesa/drivers/dri/i965/brw_wm.c
-index 3e2f2d0..0f842d2 100644
---- a/src/mesa/drivers/dri/i965/brw_wm.c
-+++ b/src/mesa/drivers/dri/i965/brw_wm.c
-@@ -138,64 +138,75 @@ static void do_wm_prog( struct brw_conte
- struct brw_fragment_program *fp,
- struct brw_wm_prog_key *key)
- {
-- struct brw_wm_compile c;
-+ struct brw_wm_compile *c;
- const GLuint *program;
- GLuint program_size;
-
-- memset(&c, 0, sizeof(c));
-- memcpy(&c.key, key, sizeof(*key));
-+ c = brw->wm.compile_data;
-+ if (c == NULL) {
-+ brw->wm.compile_data = calloc(1, sizeof(*brw->wm.compile_data));
-+ c = brw->wm.compile_data;
-+ } else {
-+ memset(c, 0, sizeof(*brw->wm.compile_data));
-+ }
-+ memcpy(&c->key, key, sizeof(*key));
-
-- c.fp = fp;
-- c.env_param = brw->intel.ctx.FragmentProgram.Parameters;
-+ c->fp = fp;
-+ c->env_param = brw->intel.ctx.FragmentProgram.Parameters;
-
-
- /* Augment fragment program. Add instructions for pre- and
- * post-fragment-program tasks such as interpolation and fogging.
- */
-- brw_wm_pass_fp(&c);
-+ brw_wm_pass_fp(c);
-
- /* Translate to intermediate representation. Build register usage
- * chains.
- */
-- brw_wm_pass0(&c);
-+ brw_wm_pass0(c);
-
- /* Dead code removal.
- */
-- brw_wm_pass1(&c);
-+ brw_wm_pass1(c);
-
- /* Hal optimization
- */
-- brw_wm_pass_hal (&c);
-+ brw_wm_pass_hal (c);
-
- /* Register allocation.
- */
-- c.grf_limit = BRW_WM_MAX_GRF/2;
-+ c->grf_limit = BRW_WM_MAX_GRF/2;
-
- /* This is where we start emitting gen4 code:
- */
-- brw_init_compile(&c.func);
-+ brw_init_compile(&c->func);
-
-- brw_wm_pass2(&c);
-+ brw_wm_pass2(c);
-
-- c.prog_data.total_grf = c.max_wm_grf;
-- c.prog_data.total_scratch = c.last_scratch ? c.last_scratch + 0x40 : 0;
-+ c->prog_data.total_grf = c->max_wm_grf;
-+ if (c->last_scratch) {
-+ c->prog_data.total_scratch =
-+ c->last_scratch + 0x40;
-+ } else {
-+ c->prog_data.total_scratch = 0;
-+ }
-
- /* Emit GEN4 code.
- */
-- brw_wm_emit(&c);
-+ brw_wm_emit(c);
-
- /* get the program
- */
-- program = brw_get_program(&c.func, &program_size);
-+ program = brw_get_program(&c->func, &program_size);
-
- /*
- */
- brw->wm.prog_gs_offset = brw_upload_cache( &brw->cache[BRW_WM_PROG],
-- &c.key,
-- sizeof(c.key),
-+ &c->key,
-+ sizeof(c->key),
- program,
- program_size,
-- &c.prog_data,
-+ &c->prog_data,
- &brw->wm.prog_data );
- }
-
diff --git a/media-libs/mesa/files/7.4-fix-parallel-make.patch b/media-libs/mesa/files/7.4-fix-parallel-make.patch
deleted file mode 100644
index 908fbce..0000000
--- a/media-libs/mesa/files/7.4-fix-parallel-make.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/glx/x11/Makefile b/src/glx/x11/Makefile
-index 419cb28..4d69a59 100644
---- a/src/glx/x11/Makefile
-+++ b/src/glx/x11/Makefile
-@@ -70,7 +70,7 @@ INCLUDES = -I. \
- default: depend $(TOP)/$(LIB_DIR)/$(GL_LIB_NAME)
-
- # Make libGL
--$(TOP)/$(LIB_DIR)/$(GL_LIB_NAME): $(OBJECTS) Makefile
-+$(TOP)/$(LIB_DIR)/$(GL_LIB_NAME): $(OBJECTS) $(TOP)/$(LIB_DIR) Makefile
- $(MKLIB) -o $(GL_LIB) -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- -major 1 -minor 2 $(MKLIB_OPTIONS) \
- -install $(TOP)/$(LIB_DIR) -id $(INSTALL_LIB_DIR)/lib$(GL_LIB).1.dylib \
diff --git a/media-libs/mesa/files/lib/libGL.la b/media-libs/mesa/files/lib/libGL.la
deleted file mode 100644
index cc2fd24..0000000
--- a/media-libs/mesa/files/lib/libGL.la
+++ /dev/null
@@ -1,32 +0,0 @@
-# libGL.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname='libGL.so.1'
-
-# Names of this library.
-library_names='libGL.so.1.2 libGL.so.1 libGL.so'
-
-# The name of the static archive.
-old_library=''
-
-# Libraries that this one depends upon.
-dependency_libs=' -L/usr/${libdir} -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
-
-# Version information for libGL.
-current=3
-age=2
-revision=0
-
-# Is this an already installed library?
-installed=yes
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='/usr/${libdir}'
diff --git a/media-libs/mesa/files/lib/libGLU.la b/media-libs/mesa/files/lib/libGLU.la
deleted file mode 100644
index cc76b4b..0000000
--- a/media-libs/mesa/files/lib/libGLU.la
+++ /dev/null
@@ -1,32 +0,0 @@
-# libGLU.la - a libtool library file
-# Generated by ltmain.sh - GNU libtool 1.4 (1.920 2001/04/24 23:26:18)
-#
-# Please DO NOT delete this file!
-# It is necessary for linking the library.
-
-# The name that we can dlopen(3).
-dlname='libGLU.so.1'
-
-# Names of this library.
-library_names='libGLU.so.1.3 libGLU.so.1 libGLU.so'
-
-# The name of the static archive.
-old_library=''
-
-# Libraries that this one depends upon.
-dependency_libs=' -L/usr/lib -lGL -lSM -lICE -lXmu -lXt -lXext -lXi -lX11 -ldl -lpthread '
-
-# Version information for libGLU.
-current=4
-age=3
-revision=0
-
-# Is this an already installed library?
-installed=yes
-
-# Files to dlopen/dlpreopen
-dlopen=''
-dlpreopen=''
-
-# Directory that this library needs to be installed in:
-libdir='/usr/lib'
diff --git a/media-libs/mesa/mesa-7.4.4.ebuild b/media-libs/mesa/mesa-7.4.4.ebuild
deleted file mode 100644
index 2e86295..0000000
--- a/media-libs/mesa/mesa-7.4.4.ebuild
+++ /dev/null
@@ -1,273 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.4.3.ebuild,v 1.1 2009/06/21 11:49:38 scarabeus Exp $
-
-EAPI="2"
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git"
- EXPERIMENTAL="true"
- IUSE_VIDEO_CARDS_UNSTABLE="video_cards_nouveau"
- IUSE_UNSTABLE="gallium"
- # User can also specify branch by simply adding MESA_LIVE_BRANCH="blesmrt"
- # to the make.conf, where blesmrt is desired branch.
- [[ -z ${MESA_LIVE_BRANCH} ]] || EGIT_BRANCH="${MESA_LIVE_BRANCH}"
-fi
-
-inherit autotools multilib flag-o-matic ${GIT_ECLASS} portability
-
-OPENGL_DIR="xorg-x11"
-
-MY_PN="${PN/m/M}"
-MY_P="${MY_PN}-${PV/_/-}"
-MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
-DESCRIPTION="OpenGL-like graphic library for Linux"
-HOMEPAGE="http://mesa3d.sourceforge.net/"
-
-#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
-if [[ $PV = *_rc* ]]; then
- SRC_URI="http://www.mesa3d.org/beta/${MY_SRC_P}.tar.gz
- ${SRC_PATCHES}"
-elif [[ $PV = 9999* ]]; then
- SRC_URI="${SRC_PATCHES}"
-else
- SRC_URI="mirror://sourceforge/mesa3d/${MY_SRC_P}.tar.bz2
- ${SRC_PATCHES}"
-fi
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-
-IUSE_VIDEO_CARDS="${IUSE_VIDEO_CARDS_UNSTABLE}
- video_cards_intel
- video_cards_mach64
- video_cards_mga
- video_cards_none
- video_cards_r128
- video_cards_radeon
- video_cards_radeonhd
- video_cards_s3virge
- video_cards_savage
- video_cards_sis
- video_cards_sunffb
- video_cards_tdfx
- video_cards_trident
- video_cards_via"
-IUSE="${IUSE_VIDEO_CARDS} ${IUSE_UNSTABLE}
- debug doc motif nptl pic xcb kernel_FreeBSD"
-
-# keep correct libdrm and dri2proto dep
-# keep blocks in rdepend for binpkg
-RDEPEND="!<=x11-base/xorg-x11-6.9
- !<=x11-proto/xf86driproto-2.0.3
- app-admin/eselect-opengl
- dev-libs/expat
- >=x11-libs/libdrm-2.4.6
- x11-libs/libICE
- x11-libs/libX11[xcb?]
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXxf86vm
- motif? ( x11-libs/openmotif )
- doc? ( app-doc/opengl-manpages )
-"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig
- x11-misc/makedepend
- >=x11-proto/dri2proto-1.99.3
- >=x11-proto/glproto-1.4.8
- x11-proto/inputproto
- x11-proto/xextproto
- x11-proto/xf86vidmodeproto
- x11-proto/xf86driproto
-"
-# glew depend on mesa and it is needed in runtime
-PDEPEND=">=media-libs/glew-1.5.1"
-
-S="${WORKDIR}/${MY_P}"
-
-# Think about: ggi, svga, fbcon, no-X configs
-
-pkg_setup() {
- if use debug; then
- append-flags -g
- fi
-
- # gcc 4.2 has buggy ivopts
- if [[ $(gcc-version) = "4.2" ]]; then
- append-flags -fno-ivopts
- fi
-
- # recommended by upstream
- append-flags -ffast-math
-}
-
-src_unpack() {
- [[ $PV = 9999* ]] && git_src_unpack || unpack ${A}
-}
-
-src_prepare() {
- # apply patches
- if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
- EPATCH_FORCE="yes" \
- EPATCH_SOURCE="${WORKDIR}/patches" \
- EPATCH_SUFFIX="patch" \
- epatch
- fi
- # FreeBSD 6.* doesn't have posix_memalign().
- [[ ${CHOST} == *-freebsd6.* ]] && \
- sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configure.ac
-
- eautoreconf
-}
-
-src_configure() {
- local myconf
-
- # Configurable DRI drivers
- driver_enable swrast
- driver_enable video_cards_intel i810 i915 i965
- driver_enable video_cards_mach64 mach64
- driver_enable video_cards_mga mga
- driver_enable video_cards_r128 r128
- # ATI has two implementations as video_cards
- driver_enable video_cards_radeon radeon r200 r300
- driver_enable video_cards_radeonhd r300
- driver_enable video_cards_s3virge s3v
- driver_enable video_cards_savage savage
- driver_enable video_cards_sis sis
- driver_enable video_cards_sunffb ffb
- driver_enable video_cards_tdfx tdfx
- driver_enable video_cards_trident trident
- driver_enable video_cards_via unichrome
-
- # all live (experimental) stuff is wrapped around with experimental variable
- # so the users cant get to this parts even with enabled useflags (downgrade
- # from live to stable for example)
- if [[ -n ${EXPERIMENTAL} ]]; then
- # nouveau works only with gallium and intel, radeon, radeonhd can use
- # gallium as alternative implementation (NOTE: THIS IS EXPERIMENTAL)
- if use video_cards_nouveau && ! use gallium ; then
- elog "Nouveau driver is available only via gallium interface."
- elog "Enable gallium useflag if you want to use nouveau."
- echo
- fi
- # state trackers, for now enable the one i want
- # think about this bit more...
- myconf="${myconf} $(use_enable gallium)"
- if use gallium; then
- elog "Warning gallium interface is highly experimental so use"
- elog "it only if you feel really really brave."
- elog
- elog "Intel: works only i915."
- elog "Nouveau: only available implementation, so no other choice"
- elog "Radeon: not working, disabled."
- echo
- myconf="${myconf}
- --with-state-trackers=glx,dri,egl
- $(use_enable video_cards_nouveau gallium-nouveau)
- $(use_enable video_cards_intel gallium-intel)"
- #$(use_enable video_cards_radeon gallium-radeon)
- #$(use_enable video_cards_radeonhd gallium-radeon)"
- fi
- fi
-
- # Deactivate assembly code for pic build
- # Sparc assembly code is not working
- myconf="${myconf} $(use_enable !pic asm)"
- myconf="${myconf} $(use_enable !sparc asm)"
-
- # --with-driver=dri|xlib|osmesa ; might get changed later to something
- # else than dri
- econf \
- --with-driver=dri \
- --disable-glut \
- --without-demos \
- $(use_enable debug) \
- $(use_enable motif glw) \
- $(use_enable motif) \
- $(use_enable nptl glx-tls) \
- $(use_enable xcb) \
- --with-dri-drivers=${DRI_DRIVERS} \
- ${myconf}
-}
-
-src_install() {
- dodir /usr
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Remove redundant headers
- # GLUT thing
- rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
- # Glew headers
- rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
- || die "Removing glew includes failed."
-
- # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
- # because user can eselect desired GL provider.
- ebegin "Moving libGL and friends for dynamic switching"
- dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
- local x
- for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
- || die "Failed to move ${x}"
- fi
- done
- for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
- || die "Failed to move ${x}"
- fi
- done
- eend $?
-
- # Install libtool archives
- insinto /usr/$(get_libdir)
- # Should this use the -L/usr/lib instead of -L/usr/$(get_libdir)?
- # Please confirm and update this comment or the file.
- doins "${FILESDIR}"/lib/libGLU.la || die "doins libGLU.la failed"
- sed \
- -e "s:\${libdir}:$(get_libdir):g" \
- "${FILESDIR}"/lib/libGL.la \
- > "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
-
- # On *BSD libcs dlopen() and similar functions are present directly in
- # libc.so and does not require linking to libdl. portability eclass takes
- # care of finding the needed library (if needed) witht the dlopen_lib
- # function.
- sed -i \
- -e 's:-ldl:'$(dlopen_lib)':g' \
- "${D}"/usr/$(get_libdir)/{libGLU.la,opengl/xorg-x11/lib/libGL.la} \
- || die "sed dlopen failed"
-}
-
-pkg_postinst() {
- # Switch to the xorg implementation.
- echo
- eselect opengl set --use-old ${OPENGL_DIR}
-}
-
-# $1 - VIDEO_CARDS flag
-# other args - names of DRI drivers to enable
-driver_enable() {
- case $# in
- # for enabling unconditionally
- 1)
- DRI_DRIVERS="${DRI_DRIVERS},$1"
- ;;
- *)
- if use $1; then
- shift
- for i in $@; do
- DRI_DRIVERS="${DRI_DRIVERS},${i}"
- done
- fi
- ;;
- esac
-}