summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhwoarang <hwoarang@gentoo.org>2011-01-06 14:46:22 +0200
committerhwoarang <hwoarang@gentoo.org>2011-01-06 14:46:22 +0200
commitb56250103003841457cc3274dca94ae1a746aa95 (patch)
tree87a8c09088d539cea04645c3abe04e76bf4d506a
parentInitial commit for boost-1.45.0 (diff)
downloadhwoarang-b56250103003841457cc3274dca94ae1a746aa95.tar.gz
hwoarang-b56250103003841457cc3274dca94ae1a746aa95.tar.bz2
hwoarang-b56250103003841457cc3274dca94ae1a746aa95.zip
dev-util/boost-build: Update ebuild based on bug #320039
-rw-r--r--dev-util/boost-build/Manifest2
-rw-r--r--dev-util/boost-build/boost-build-1.45.0.ebuild10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
index 7638ca1..e37738f 100644
--- a/dev-util/boost-build/Manifest
+++ b/dev-util/boost-build/Manifest
@@ -1,2 +1,2 @@
DIST boost_1_45_0.tar.bz2 39330184 RMD160 1402cb49e0d680268109ef1bf16aea9bc4a127b0 SHA1 eb7424ef99df4e38af7431e38ff9849651b8aaf5 SHA256 55ed3ec51d5687e8224c988e22bef215dacce04e037d9f689569a80c4377a6d5
-EBUILD boost-build-1.45.0.ebuild 3285 RMD160 af8fa8927ed9bca16dd41e612d82d0ac01bd3055 SHA1 c5712dd9106a010f15888dd7097e1b9debad9298 SHA256 00c2a731043e72c7b588d3c06be932a8af1cad35e46adabeaab4761ba7aa90d3
+EBUILD boost-build-1.45.0.ebuild 3252 RMD160 308ad6848d8b78b301c6cb41565731f1708a48a7 SHA1 94907e7fb09ca243aef45517f401ec7a7996b461 SHA256 b3cb7358b47e7cff76fe6046eb0b43275e9255febea1ca00e886b1fd883ef061
diff --git a/dev-util/boost-build/boost-build-1.45.0.ebuild b/dev-util/boost-build/boost-build-1.45.0.ebuild
index dba1de5..1c1565a 100644
--- a/dev-util/boost-build/boost-build-1.45.0.ebuild
+++ b/dev-util/boost-build/boost-build-1.45.0.ebuild
@@ -30,14 +30,12 @@ pkg_setup() {
}
src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/{jam,build/v2} || die
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die
}
src_prepare() {
- epatch "${FILESDIR}/ignore_extra_whitespace_in_cflags.patch"
-
# Remove stripping option
- cd "${S}/jam/src"
+ cd "${S}/build/v2/engine/src"
sed -i -e 's|-s\b||' \
build.jam || die "sed failed"
@@ -56,7 +54,7 @@ src_prepare() {
}
src_compile() {
- cd jam/src
+ cd build/v2/engine/src
local toolset
if [[ ${CHOST} == *-darwin* ]] ; then
@@ -89,7 +87,7 @@ src_compile() {
}
src_install() {
- newbin jam/src/bin.*/bjam bjam-${MAJOR_PV}
+ newbin build/v2/engine/src/bin.*/bjam bjam-${MAJOR_PV}
cd "${S}/build/v2"
insinto /usr/share/boost-build-${MAJOR_PV}