summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-06-30 18:00:01 +0300
committerMarkos Chandras <hwoarang@gentoo.org>2009-06-30 18:00:01 +0300
commitce37b6bee19cbdb8a1b62ec0f530553f7cfc2fd9 (patch)
treef6b9a4773788f065766fe62b69eebd47bf35ea5d
parentAdded nted ( bug 244716 ) (diff)
downloadhwoarang-ce37b6bee19cbdb8a1b62ec0f530553f7cfc2fd9.tar.gz
hwoarang-ce37b6bee19cbdb8a1b62ec0f530553f7cfc2fd9.tar.bz2
hwoarang-ce37b6bee19cbdb8a1b62ec0f530553f7cfc2fd9.zip
New ebuild for bug 275929
-rw-r--r--media-libs/lastfmlib/Manifest2
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.3.0.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/Manifest b/media-libs/lastfmlib/Manifest
new file mode 100644
index 0000000..b8e5557
--- /dev/null
+++ b/media-libs/lastfmlib/Manifest
@@ -0,0 +1,2 @@
+DIST lastfmlib-0.3.0.tar.gz 327211 RMD160 eb0d8947b651db8e4677ac1ccd1fd391904ed36f SHA1 910b79f8e394226ed63716f954cfbc54f961fb52 SHA256 46ee456b91e46933a4d5fb01ce5c92fe1dcb87d7ee57797f92a382ac2294a70b
+EBUILD lastfmlib-0.3.0.ebuild 685 RMD160 cbdd86f73da489e8c213d41f13fc5624eb6bb443 SHA1 722a0d16af911d72dac9564a2d09975b5620559b SHA256 edf527401e0c9f9cf4fac544bb5724ae1ccea509e43db6cc2e9ba76b1584d2d6
diff --git a/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild b/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild
new file mode 100644
index 0000000..8ea5633
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="http://code.google.com/p/lastfmlib"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="syslog test debug"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable syslog logging) \
+ $(use_enable debug) \
+ $(use_enable test unittests) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README TODO || die "dodoc failed"
+}