summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhwoarang <hwoarang@gentoo.org>2011-01-06 16:11:50 +0200
committerhwoarang <hwoarang@gentoo.org>2011-01-06 16:11:50 +0200
commit10bbe59b573e2e0265c55c4a2975f938ab754f07 (patch)
tree3835ea5eee351f74be256c9e02acd3ad6a89495c /dev-util
parentdev-libs/boost: Add remove-toolset patch (diff)
downloadhwoarang-10bbe59b573e2e0265c55c4a2975f938ab754f07.tar.gz
hwoarang-10bbe59b573e2e0265c55c4a2975f938ab754f07.tar.bz2
hwoarang-10bbe59b573e2e0265c55c4a2975f938ab754f07.zip
Boost ebuilds moved to tree
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/Manifest2
-rw-r--r--dev-util/boost-build/boost-build-1.45.0.ebuild109
2 files changed, 0 insertions, 111 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
deleted file mode 100644
index e37738f..0000000
--- a/dev-util/boost-build/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST boost_1_45_0.tar.bz2 39330184 RMD160 1402cb49e0d680268109ef1bf16aea9bc4a127b0 SHA1 eb7424ef99df4e38af7431e38ff9849651b8aaf5 SHA256 55ed3ec51d5687e8224c988e22bef215dacce04e037d9f689569a80c4377a6d5
-EBUILD boost-build-1.45.0.ebuild 3252 RMD160 308ad6848d8b78b301c6cb41565731f1708a48a7 SHA1 94907e7fb09ca243aef45517f401ec7a7996b461 SHA256 b3cb7358b47e7cff76fe6046eb0b43275e9255febea1ca00e886b1fd883ef061
diff --git a/dev-util/boost-build/boost-build-1.45.0.ebuild b/dev-util/boost-build/boost-build-1.45.0.ebuild
deleted file mode 100644
index 1c1565a..0000000
--- a/dev-util/boost-build/boost-build-1.45.0.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.40.0.ebuild,v 1.2 2009/10/24 09:20:57 vapier Exp $
-
-EAPI="2"
-
-inherit flag-o-matic toolchain-funcs versionator
-
-MY_PV=$(replace_all_version_separators _)
-MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
-
-DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
-HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
-SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
-LICENSE="Boost-1.0"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="examples python"
-
-DEPEND="!<dev-libs/boost-1.34.0
- !<=dev-util/boost-build-1.35.0-r1
- python? ( dev-lang/python )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/boost_${MY_PV}/tools"
-
-pkg_setup() {
- ewarn "Compilation of boost-build is known to break if {C,LD}FLAGS contain"
- ewarn "extra white space (bug 293652)"
-}
-
-src_unpack() {
- tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die
-}
-
-src_prepare() {
- # Remove stripping option
- cd "${S}/build/v2/engine/src"
- sed -i -e 's|-s\b||' \
- build.jam || die "sed failed"
-
- # Force regeneration
- rm jambase.c
-
- # This patch allows us to fully control optimization
- # and stripping flags when bjam is used as build-system
- # We simply extend the optimization and debug-symbols feature
- # with empty dummies called 'none'
- cd "${S}/build/v2"
- sed -i \
- -e 's/\(off speed space\)/\1 none/' \
- -e 's/\(debug-symbols : on off\)/\1 none/' \
- tools/builtin.jam || die "sed failed"
-}
-
-src_compile() {
- cd build/v2/engine/src
- local toolset
-
- if [[ ${CHOST} == *-darwin* ]] ; then
- toolset=darwin
- else
- # Using boost's generic toolset here, which respects CC and CFLAGS
- toolset=cc
- fi
-
- append-flags -fno-strict-aliasing
-
- # For slotting
- sed -i \
- -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
- Jambase || die "sed failed"
-
- # The build.jam file for building bjam using a bootstrapped jam0 ignores
- # the LDFLAGS env var (bug #209794). We have now two options:
- # a) change the cc-target definition in build.jam to include separate compile
- # and link targets to make it use the LDFLAGS var, or
- # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
- # (which should not be set by us).
- if [[ -z "${LDFLAGS}" ]] ; then
- CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
- || die "building bjam failed"
- else
- LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
- $(use_with python) || die "building bjam failed"
- fi
-}
-
-src_install() {
- newbin build/v2/engine/src/bin.*/bjam bjam-${MAJOR_PV}
-
- cd "${S}/build/v2"
- insinto /usr/share/boost-build-${MAJOR_PV}
- doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
- build kernel options tools util || die
-
- dodoc changes.txt hacking.txt release_procedure.txt \
- notes/build_dir_option.txt notes/relative_source_paths.txt
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r example
- fi
-}
-
-src_test() {
- cd jam/test
- ./test.sh || die "tests failed"
-}