summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-06-07 06:32:06 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-06-07 06:32:06 +0000
commit2c4a27c74560629ca47ac8e654bf5d17b88722dd (patch)
tree36256bc933bde6b38ec514cb3af691ac48e535fd
parentfix VERSION given by charmc (diff)
downloadje_fro-2c4a27c74560629ca47ac8e654bf5d17b88722dd.tar.gz
je_fro-2c4a27c74560629ca47ac8e654bf5d17b88722dd.tar.bz2
je_fro-2c4a27c74560629ca47ac8e654bf5d17b88722dd.zip
removing
svn path=/; revision=285
-rw-r--r--sys-cluster/charm/Manifest6
-rw-r--r--sys-cluster/charm/charm-6.1.2.ebuild141
-rw-r--r--sys-cluster/charm/charm-9999.ebuild147
-rw-r--r--sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch15
-rw-r--r--sys-cluster/charm/files/charm-6.1.2-charmrun.patch11
-rw-r--r--sys-cluster/charm/files/charm-9999-charmc-gentoo.patch25
6 files changed, 0 insertions, 345 deletions
diff --git a/sys-cluster/charm/Manifest b/sys-cluster/charm/Manifest
deleted file mode 100644
index 6b7657f..0000000
--- a/sys-cluster/charm/Manifest
+++ /dev/null
@@ -1,6 +0,0 @@
-AUX charm-6.1.2-charmc-gentoo.patch 446 RMD160 1ef514f464a885f09bde4cca33eac6c2b7807ed8 SHA1 7b3d49a1bfd4ecdc7ac44b5737593abb644717fb SHA256 44004b8f9ea8a46887f92906edb3ab12b92f5689c2188d75fb491cb0ca645731
-AUX charm-6.1.2-charmrun.patch 451 RMD160 c6fbdf5fd290d5d5c0d52a8b521326f080ed646e SHA1 22a398366f8df2a37253c034afefe33566cc3105 SHA256 2e3a0279f81e76cfb5087f6c23cc0e39dff50618b0635925e373cd0c773ce603
-AUX charm-9999-charmc-gentoo.patch 963 RMD160 0f6001288cc8e9fa2d471c0d7cb9395d6fcd6399 SHA1 a68f5edab5da468a425dd8f17956c48ad0f85676 SHA256 b46d982eb9244d9e97cf7a48afd320e84788a060beddfa86b13be18547e93138
-DIST charm_src.tar.gz 23903605 RMD160 6a4ec1e725001073903de0241f23c7e53cdb5e97 SHA1 0443fe79a4d7f489c227316a50927ed9c71685d5 SHA256 d30a6d069d334760fcf919d1f6dba3ac76b64336fe7570e43f91af8de5b21839
-EBUILD charm-6.1.2.ebuild 3228 RMD160 06e288679cd17c88a2338dd5a307d70651e46940 SHA1 889a9014f504328364c802421ac7cd39ba9b6b8a SHA256 8d1b5d5cbf8cca64e462665dc647fcc08289567d20d077f0bf5531a7709b8605
-EBUILD charm-9999.ebuild 3335 RMD160 1dfce9d798191fe74bb5a04e9ba7bb3fddc7210f SHA1 4154bbb0eac565832074f6f03c526eb04afe5d00 SHA256 c75770a17900a6553339335fdeb63e72e409ef3f4eeab77f4ba18b41f1a66f09
diff --git a/sys-cluster/charm/charm-6.1.2.ebuild b/sys-cluster/charm/charm-6.1.2.ebuild
deleted file mode 100644
index fd4422f..0000000
--- a/sys-cluster/charm/charm-6.1.2.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Charm++ is a message-passing parallel language and runtime system."
-LICENSE="charm"
-HOMEPAGE="http://charm.cs.uiuc.edu/"
-SRC_URI="${PN}_src.tar.gz"
-S="${WORKDIR}/${PN}"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cmkopt tcp smp doc icc"
-
-DEPEND="icc? ( >=dev-lang/icc-8.1 )
- doc? (
- app-text/poppler
- dev-tex/latex2html
- virtual/tetex
- )"
-
-case ${ARCH} in
-
- x86)
- CHARM_ARCH="net-linux" ;;
-
- amd64)
- CHARM_ARCH="net-linux-amd64" ;;
-esac
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-charmrun.patch"
-
- # TCP instead of default UDP for socket comunication
- # protocol
- if use tcp; then
- CHARM_OPTS="${CHARM_OPTS} tcp"
- fi
-
- # enable direct SMP support using shared memory
-# if use smp && [ "${ARCH}" != "amd64" ]; then
- if use smp; then
- CHARM_OPTS="${CHARM_OPTS} smp"
- fi
-
- # compile with icc if requested
- if use icc; then
- if [ $(tc-getCC) != "icc" ]; then
- die "You cannot use $(tc-getCC) with USE='icc'"
- fi
- CHARM_OPTS="${CHARM_OPTS} icc"
- else
- CHARM_OPTS="${CHARM_OPTS} gcc gfortran"
- fi
-
- # CMK optimization
- if use cmkopt; then
- append-flags -DCMK_OPTIMIZE=1
- fi
-
- echo "charm opts: ${CHARM_OPTS}"
-}
-
-src_compile() {
- # build charmm++ first
- cd "${S}"
- ./build charm++ ${CHARM_ARCH} ${CHARM_OPTS} ${CFLAGS} || \
- die "Failed to build charm++"
-
- # make pdf/html docs
- if use doc; then
- cd "${S}"/doc
- make doc || die "failed to create pdf/html docs"
- fi
-}
-
-src_install() {
- # make charmc play well with gentoo before
- # we move it into /usr/bin
- epatch "${FILESDIR}/${P}-charmc-gentoo.patch"
-
- sed -e "s|gentoo-include|${P}|" \
- -e "s|gentoo-libdir|$(get_libdir)|g" \
- -e "s|VERSION|${P}/VERSION|" \
- -i ./src/scripts/charmc || die "failed patching charmc script"
-
- # install binaries
- cd "${S}"/bin
- dobin ./charmd ./charmd_faceless ./charmr* ./charmc ./charmxi \
- ./conv-cpm ./dep.pl || die "Failed to install binaries"
-
- # install headers
- cd "${S}"/include
- insinto /usr/include/${P}
- doins * || die "failed to install header files"
-
- # install static libs
- cd "${S}"/lib
- dolib.a * || die "failed to install static libs"
-
- # install shared libs
- cd "${S}"/lib_so
- dolib.so * || die "failed to install shared libs"
-
- # basic docs
- cd "${S}"
- dodoc CHANGES README || die "Failed to install docs"
-
- # install examples
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
- die "Failed to fix examples"
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:./charmrun:./charmrun ++local:" -i || \
- die "Failed to fix examples"
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/charm++/*
-
- # pdf/html docs
- if use doc; then
- cd "${S}"/doc
- # install pdfs
- insinto /usr/share/doc/${PF}/pdf
- doins doc/pdf/* || die "failed to install pdf docs"
- # install html
- docinto html
- dohtml -r doc/html/* || die "failed to install html docs"
- fi
-}
-
-pkg_postinst() {
- echo
- einfo "Please test your charm installation by copying the"
- einfo "content of /usr/share/doc/${PF}/examples to a"
- einfo "temporary location and run 'make test'."
- echo
-}
diff --git a/sys-cluster/charm/charm-9999.ebuild b/sys-cluster/charm/charm-9999.ebuild
deleted file mode 100644
index 127eba3..0000000
--- a/sys-cluster/charm/charm-9999.ebuild
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="Charm++ is a message-passing parallel language and runtime system."
-LICENSE="charm"
-HOMEPAGE="http://charm.cs.uiuc.edu/"
-SRC_URI="${PN}_src.tar.gz"
-S="${WORKDIR}/${PN}"
-SLOT="0"
-KEYWORDS=""
-IUSE="cmkopt tcp smp doc icc"
-
-RESTRICT="fetch"
-
-DEPEND="icc? ( >=dev-lang/icc-8.1 )
- doc? (
- app-text/poppler
- dev-tex/latex2html
- virtual/tetex
- )"
-
-case ${ARCH} in
-
- x86)
- CHARM_ARCH="net-linux" ;;
-
- amd64)
- CHARM_ARCH="net-linux-amd64" ;;
-esac
-
-CHARM_DOWNLOAD="http://charm.cs.uiuc.edu/download/"
-
-pkg_nofetch() {
- echo
- einfo "Please download the daily ${PN}_src.tar.gz from"
- einfo "${CHARM_DOWNLOAD}"
- einfo "and then move it to ${DISTDIR}"
- einfo "You WILL have to regenerate digests."
- echo
-}
-
-src_unpack() {
- unpack ${A}
-
- # TCP instead of default UDP for socket comunication
- # protocol
- if use tcp; then
- CHARM_OPTS="${CHARM_OPTS} tcp"
- fi
-
- # enable direct SMP support using shared memory
- if [ use smp ] && [ -x ${ARCH} != amd64 ]; then
- CHARM_OPTS="${CHARM_OPTS} smp"
- fi
-
- # compile with icc if requested
- if use icc; then
- if [ $(tc-getCC) != "icc" ]; then
- die "You cannot use $(tc-getCC) with USE='icc'"
- fi
- CHARM_OPTS="${CHARM_OPTS} icc"
- fi
-
- # CMK optimization
- if use cmkopt; then
- append-flags -DCMK_OPTIMIZE=1
- fi
-}
-
-src_compile() {
- # build charmm++ first
-pwd
-cd "${S}"
- ./build charm++ ${CHARM_ARCH} ${CHARM_OPTS} ${CFLAGS} || \
- die "Failed to build charm++"
-
- # make pdf/html docs
- if use doc; then
- cd "${S}"/doc
- make doc || die "failed to create pdf/html docs"
- fi
-}
-
-src_install() {
- # make charmc play well with gentoo before
- # we move it into /usr/bin
- einfo "Fixing paths in charmc wrapper"
- epatch "${FILESDIR}"/${P}-charmc-gentoo.patch
-
- cd "${S}"
- sed -e "s/gentoo-include/${P}/" -i ./src/scripts/charmc || \
- die "failed patching charmc script"
-
- # install binaries
- cd "${S}"/bin
- dobin ./charmd ./charmd_faceless ./charmr* ./charmc ./charmxi \
- ./conv-cpm ./dep.pl || die "Failed to install binaries"
-
- # install headers
- cd "${S}"/include
- insinto /usr/include/${P}
- doins * || die "failed to install header files"
-
- # install static libs
- cd "${S}"/lib
- dolib.a * || die "failed to install static libs"
-
- # install shared libs
- cd "${S}"/lib_so
- dolib.so * || die "failed to install shared libs"
-
- # basic docs
- cd "${S}"
- dodoc CHANGES README || die "Failed to install docs"
-
- # install examples after fixing path to charmc
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
- die "Failed to fix examples"
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:./charmrun:./charmrun ++local:" -i || \
- die "Failed to fix examples"
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/charm++/*
-
- # pdf/html docs
- if use doc; then
- cd "${S}"/doc
- # install pdfs
- insinto /usr/share/doc/${PF}/pdf
- doins doc/pdf/* || die "failed to install pdf docs"
- # install html
- docinto html
- dohtml -r doc/html/* || die "failed to install html docs"
- fi
-}
-
-pkg_postinst() {
- echo
- einfo "Please test your charm installation by copying the"
- einfo "content of /usr/share/doc/${PF}/examples to a"
- einfo "temporary location and run 'make test'."
- echo
-}
diff --git a/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch b/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
deleted file mode 100644
index 5c38ea8..0000000
--- a/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/scripts/charmc.orig 2009-05-31 16:11:24.772005740 -0500
-+++ src/scripts/charmc 2009-05-31 16:12:31.329000876 -0500
-@@ -335,9 +335,9 @@
- PROG_EXT=".exe"
- fi
-
--CHARMLIB="$CHARMBIN/../lib"
--CHARMINC="$CHARMBIN/../include"
--CHARMLIBSO=
-+CHARMLIB="$/usr/gentoo-libdir"
-+CHARMINC="/usr/include/gentoo-include"
-+CHARMLIBSO="/usr/gentoo-libdir"
- if test -d "$CHARMBIN/../lib_so"
- then
- CHARMLIBSO=`cd $CHARMBIN/../lib_so 2>/dev/null && pwd`
diff --git a/sys-cluster/charm/files/charm-6.1.2-charmrun.patch b/sys-cluster/charm/files/charm-6.1.2-charmrun.patch
deleted file mode 100644
index d677051..0000000
--- a/sys-cluster/charm/files/charm-6.1.2-charmrun.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/arch/net/charmrun/charmrun.c.orig 2009-05-30 10:37:32.676819167 -0500
-+++ src/arch/net/charmrun/charmrun.c 2009-05-30 10:38:08.835027500 -0500
-@@ -1291,7 +1291,7 @@
- char *tmp=tmpnam(NULL);/*This was once /tmp/fnord*/
- #endif
- unlink(tmp);
-- fd = open(tmp,O_RDWR | O_CREAT | O_TRUNC);
-+ fd = open(tmp,O_RDWR | O_CREAT | O_TRUNC, 0666);
- if (fd<0) {
- fprintf(stderr,"cannot open temp file /tmp/fnord");
- exit(1);
diff --git a/sys-cluster/charm/files/charm-9999-charmc-gentoo.patch b/sys-cluster/charm/files/charm-9999-charmc-gentoo.patch
deleted file mode 100644
index 1fd352c..0000000
--- a/sys-cluster/charm/files/charm-9999-charmc-gentoo.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- src/scripts/charmc-old 2008-12-30 13:07:56.879847656 -0600
-+++ src/scripts/charmc 2008-12-30 13:11:18.732163260 -0600
-@@ -335,19 +335,9 @@
- PROG_EXT=".exe"
- fi
-
--CHARMLIB="$CHARMBIN/../lib"
--CHARMINC="$CHARMBIN/../include"
--CHARMLIBSO=
--if test -d "$CHARMBIN/../lib_so"
--then
-- CHARMLIBSO=`cd $CHARMBIN/../lib_so 2>/dev/null && pwd`
-- #getting absolute path is harder than thought because of symbolic links and ..
-- #ksh needs cd -P to resolve werid symbolic links, however -P is not portable
-- #csh is ok too if it exists
-- test -z "$CHARMLIBSO" && CHARMLIBSO=`cd -P $CHARMBIN/../lib_so 2>/dev/null && pwd`
-- test -z "$CHARMLIBSO" && CHARMLIBSO=`csh -c "cd $CHARMBIN/../lib_so >& /dev/null && pwd"`
-- test -z "$CHARMLIBSO" && echo "$CHARMBIN/../lib_so: not found" && exit 1
--fi
-+CHARMLIB="/usr/lib"
-+CHARMINC="/usr/include/gentoo-include"
-+CHARMLIBSO="/usr/lib"
-
- ##############################################################################
- #