aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-05-10 16:52:40 +0200
committerJohannes Huber <johu@gentoo.org>2018-05-10 16:52:40 +0200
commit1246f9cd51bb0744690647bf0caec87e710dec39 (patch)
treef598afca76cd094b71f892dad58e356e6f0d8615
parentx11-wm/i3-gaps: Remove package (diff)
downloadjohu-1246f9cd51bb0744690647bf0caec87e710dec39.tar.gz
johu-1246f9cd51bb0744690647bf0caec87e710dec39.tar.bz2
johu-1246f9cd51bb0744690647bf0caec87e710dec39.zip
app-emulation/vagrant-bin: Version bump 2.1.1
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--app-emulation/vagrant-bin/Manifest1
-rw-r--r--app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/vagrant-bin/Manifest b/app-emulation/vagrant-bin/Manifest
index 87c6069..541c7e3 100644
--- a/app-emulation/vagrant-bin/Manifest
+++ b/app-emulation/vagrant-bin/Manifest
@@ -1 +1,2 @@
DIST vagrant_2.0.1_x86_64.deb 78963440 BLAKE2B efd6cbbe36ea803dca913e0d2a65e546f82c1a12d086767432c63c510e16624db95678cb86769bb5916ce2b6acab32da60eec25b125ba67ace62b6fde56ebbae SHA512 b5e13eef75ecf8d56eafde791920fe925dbcfa2ce5c6708767b3dd794507c3887bb8ad99ca3049937d9908fa2c17a2f764a99ace9291f0eecb653b6b8babd2f9
+DIST vagrant_2.1.1_x86_64.deb 43539450 BLAKE2B cd842f229b6a0798324ed2fe8d647020f2324d53f0672df1f29f335b8f739213a94a8ea7ec6828605616794dd02771bbc00fce64934e85dfb83a4c2339f2df5f SHA512 4b130e362d183d53d7eb5d9ed62b2c2c7bd1d1fb869ab94d2533c3804cf3bdb6be2d35deaae77c5ffe9368aae50b4b21475e5085a16662a2dff95fd377ff5b6f
diff --git a/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild b/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild
new file mode 100644
index 0000000..20da036
--- /dev/null
+++ b/app-emulation/vagrant-bin/vagrant-bin-2.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN=${PN/-bin/}
+inherit unpacker eutils
+
+DESCRIPTION="Tool for building and distributing virtual machines"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://releases.hashicorp.com/${MY_PN}/${PV}/${MY_PN}_${PV}_x86_64.deb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}/opt/${MY_PN}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-arch/libarchive
+ net-misc/curl
+ !app-emulation/vagrant
+"
+
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack_deb ${A}
+}
+
+src_install() {
+ local dir="/opt/${MY_PN}"
+ dodir ${dir}
+ cp -ar ./* "${ED}${dir}" || die "copy files failed"
+
+ make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
+}