summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2007-05-21 16:59:02 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2007-05-21 16:59:02 +0000
commit397068e4cea04caaf724d2b3df2c515278a3a48d (patch)
treec7aba9ac525f0a71b80f1e01a0c24b2657832794
parentRevert a change that wasn't supposed to be committed :/ (diff)
downloadkevquinn-397068e4cea04caaf724d2b3df2c515278a3a48d.tar.gz
kevquinn-397068e4cea04caaf724d2b3df2c515278a3a48d.tar.bz2
kevquinn-397068e4cea04caaf724d2b3df2c515278a3a48d.zip
Add 4.2.0 (first attempt), incorporate recent eclass updates from cvs.
svn path=/; revision=203
-rw-r--r--hardened/toolchain/branches/pieworld/distfiles/gcc-4.2.0-piepatches-v9.0.7.tar.bz2bin0 -> 4496 bytes
-rw-r--r--hardened/toolchain/branches/pieworld/eclass/flag-o-matic.eclass43
-rw-r--r--hardened/toolchain/branches/pieworld/eclass/toolchain.eclass25
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest43
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch11
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-crtbeginTS.patch27
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.1.2-r16
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.2.012
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/files/fix_libtool_files.sh8
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.2-r1.ebuild4
-rw-r--r--hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.2.0.ebuild92
11 files changed, 211 insertions, 60 deletions
diff --git a/hardened/toolchain/branches/pieworld/distfiles/gcc-4.2.0-piepatches-v9.0.7.tar.bz2 b/hardened/toolchain/branches/pieworld/distfiles/gcc-4.2.0-piepatches-v9.0.7.tar.bz2
new file mode 100644
index 0000000..6c566d4
--- /dev/null
+++ b/hardened/toolchain/branches/pieworld/distfiles/gcc-4.2.0-piepatches-v9.0.7.tar.bz2
Binary files differ
diff --git a/hardened/toolchain/branches/pieworld/eclass/flag-o-matic.eclass b/hardened/toolchain/branches/pieworld/eclass/flag-o-matic.eclass
index a5f0103..229b30a 100644
--- a/hardened/toolchain/branches/pieworld/eclass/flag-o-matic.eclass
+++ b/hardened/toolchain/branches/pieworld/eclass/flag-o-matic.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.118 2007/03/24 07:07:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.119 2007/05/12 11:45:51 vapier Exp $
#
# Maintainer: toolchain@gentoo.org
@@ -94,18 +94,20 @@ inherit eutils toolchain-funcs multilib
# C[XX]FLAGS that we allow in strip-flags
# Note: shell globs and character lists are allowed
setup-allowed-flags() {
- if [[ -z ${ALLOWED_FLAGS} ]] ; then
- export ALLOWED_FLAGS="-pipe"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -O -O0 -O1 -O2 -mcpu -march -mtune"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -fstack-protector -fstack-protector-all"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -fbounds-checking -fno-bounds-checking"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -fno-PIE -fno-pie -fno-unit-at-a-time"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -g -g[0-9] -ggdb -ggdb[0-9] -gstabs -gstabs+"
- export ALLOWED_FLAGS="${ALLOWED_FLAGS} -fno-ident"
- fi
- # allow a bunch of flags that negate features / control ABI
- ALLOWED_FLAGS="${ALLOWED_FLAGS} -fno-stack-protector -fno-stack-protector-all"
- ALLOWED_FLAGS="${ALLOWED_FLAGS} -mregparm -mno-app-regs -mapp-regs \
+ # Default set of allowed flags - ebuilds may override this set
+ # by setting ALLOWED_FLAGS.
+ [[ -z ${ALLOWED_FLAGS} ]] &&
+ ALLOWED_FLAGS="-pipe -O -O0 -O1 -O2 -mcpu -march -mtune \
+ -fstack-protector -fstack-protector-all -fbounds-checking \
+ -g -g[0-9] -ggdb -ggdb[0-9] -gstabs -gstabs+ \
+ -fno-unit-at-a-time -fno-ident"
+ # allow a bunch of flags that negate features / control ABI - these
+ # are always allowed.
+ # ? Why is -fPIC here? It should be covered by -m<something> where
+ # necessary. Setting -fPIC in C[XX]FLAGS isn't sensible, in general.
+ ALLOWED_FLAGS="${ALLOWED_FLAGS} -fno-PIE -fno-pie -fno-bounds-checking \
+ -fno-stack-protector-all -fno-stack-protector \
+ -mregparm -mno-app-regs -mapp-regs \
-mno-mmx -mno-sse -mno-sse2 -mno-sse3 -mno-3dnow \
-mips1 -mips2 -mips3 -mips4 -mips32 -mips64 -mips16 \
-msoft-float -mno-soft-float -mhard-float -mno-hard-float -mfpu \
@@ -115,6 +117,7 @@ setup-allowed-flags() {
-m32 -m64 -mabi -mlittle-endian -mbig-endian -EL -EB -fPIC \
-mlive-g0 -mcmodel -mstack-bias -mno-stack-bias \
-msecure-plt -D*"
+ export ALLOWED_FLAGS
# C[XX]FLAGS that we are think is ok, but needs testing
# NOTE: currently -Os have issues with gcc3 and K6* arch's
@@ -123,7 +126,7 @@ setup-allowed-flags() {
}
# Return true if the HFILTER_CONTROL permits the requested filter
-# _hfilterok <category/pf> <pie|ssp|relro|now>
+# _hfilter_allowed <category/pf> <pie|ssp|relro|now>
_hfilter_allowed() {
[[ -z ${HFILTER_CONTROL} ]] && return 0
[[ $(awk -v CPF="$1" -v TYPE="$2" 'BEGIN { ok=0 }
@@ -139,14 +142,14 @@ _manage-hardened() {
[[ -z $3 ]] && die "Internal flag-o-matic error ($*) - please report"
if ! $(_hfilter_allowed ${CATEGORY}/${PF} ${newspec/no}); then
- einfo "Hardened compiler filter $1 requested by ebuild - ignored by request in ${HFILTER_CONTROL}"
+ ewarn "Hardened compiler filter $1 requested by ebuild - ignored by request in ${HFILTER_CONTROL}"
return 0
fi
if _gcc-specs-exists ${newspec}.specs; then
[[ -z ${GCC_SPECS} ]] || newspec=":${newspec}"
export GCC_SPECS="${GCC_SPECS}${newspec}.specs"
- einfo "Hardened compiler filtered $1 - GCC_SPECS set to ${GCC_SPECS}"
+ elog "Hardened compiler filtered $1 - GCC_SPECS set to ${GCC_SPECS}"
else
local oldspec=${GCC_SPECS/*\/} newspec=""
case $2 in
@@ -175,13 +178,15 @@ _manage-hardened() {
if [[ -n ${newspec} ]]; then
if _gcc-specs-exists ${newspec}; then
export GCC_SPECS="${newspec}"
- einfo "Hardened compiler filtered $1 - GCC_SPECS set to ${GCC_SPECS}"
+ elog "Hardened compiler filtered $1 - GCC_SPECS set to ${GCC_SPECS}"
else
- die "Internal flag-o-matic error ($*) - please report"
+ # This can happen if the compiler is not built with split-specs
+ #die "Internal flag-o-matic error ($*) - please report"
+ ewarn "Hardened compiler filter $1 requested by ebuild - ignored since neither $2 nor ${newspec} exist"
fi
else
_raw_append_flag $3
- einfo "Hardened compiler filtered $1 - CFLAGS set to ${CFLAGS}"
+ elog "Hardened compiler filtered $1 - CFLAGS set to ${CFLAGS}"
fi
fi
}
diff --git a/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass b/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
index 75f3271..b4152b8 100644
--- a/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
+++ b/hardened/toolchain/branches/pieworld/eclass/toolchain.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.333 2007/05/03 04:51:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain.eclass,v 1.334 2007/05/19 03:16:40 vapier Exp $
#
# Maintainer: Toolchain Ninjas <toolchain@gentoo.org>
@@ -152,14 +152,9 @@ else
IUSE="${IUSE} ip28 ip32r10k n32 n64"
fi
- # these are features introduced in 4.0
- if tc_version_is_at_least "4.0" ; then
- IUSE="${IUSE} objc-gc mudflap"
-
- if tc_version_is_at_least "4.1" ; then
- IUSE="${IUSE} objc++"
- fi
- fi
+ tc_version_is_at_least "4.0" && IUSE="${IUSE} objc-gc mudflap"
+ tc_version_is_at_least "4.1" && IUSE="${IUSE} objc++"
+ tc_version_is_at_least "4.2" && IUSE="${IUSE} openmp"
fi
fi
@@ -688,12 +683,6 @@ create_gcc_env_entry() {
fi
echo "LDPATH=\"${LDPATH}\"" >> ${gcc_envd_file}
-
- local mbits
- CC=$(XGCC) has_m32 && mbits="${mbits:+${mbits} }32"
- CC=$(XGCC) has_m64 && mbits="${mbits:+${mbits} }64"
- echo "GCCBITS=\"${mbits}\"" >> ${gcc_envd_file}
-
echo "MANPATH=\"${DATAPATH}/man\"" >> ${gcc_envd_file}
echo "INFOPATH=\"${DATAPATH}/info\"" >> ${gcc_envd_file}
echo "STDCXX_INCDIR=\"${STDCXX_INCDIR##*/}\"" >> ${gcc_envd_file}
@@ -1172,7 +1161,7 @@ gcc_src_unpack() {
einfo "Touching generated files"
./contrib/gcc_update --touch | \
while read f ; do
- einfo " ${f%%...}"
+ einfo " ${f%%...}"
done
fi
@@ -1351,10 +1340,6 @@ gcc_do_configure() {
fi
elif [[ ${CHOST} != mingw* ]] && [[ ${CHOST} != *-mingw* ]] ; then
confgcc="${confgcc} --enable-shared --enable-threads=posix"
-
- if [[ ${GCCMAJOR}.${GCCMINOR} > 4.1 ]] ; then
- confgcc="${confgcc} --enable-bootstrap"
- fi
fi
[[ ${CTARGET} == *-elf ]] && confgcc="${confgcc} --with-newlib"
# __cxa_atexit is "essential for fully standards-compliant handling of
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest b/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
index 2a39916..9136933 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/Manifest
@@ -62,6 +62,14 @@ AUX 4.1.1/gcc-4.1.1-nopie-crtstuff.patch 2592 RMD160 86d7164aa29cc78f778a8459fd3
MD5 b5e9f0b77badc87920fa780f986c2e5c files/4.1.1/gcc-4.1.1-nopie-crtstuff.patch 2592
RMD160 86d7164aa29cc78f778a8459fd3dbe96e906e181 files/4.1.1/gcc-4.1.1-nopie-crtstuff.patch 2592
SHA256 5a507c94691e185abb2afdf068a4def49451d384735a4c7711176ecfc7d9de91 files/4.1.1/gcc-4.1.1-nopie-crtstuff.patch 2592
+AUX 4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch 537 RMD160 abce74a23b3296a24788633497ab762abae54f4c SHA1 118f15b41d7ad5c6ebe86fde6aed1d71036c0d4d SHA256 4154944bfc4361d7dec4eab8394629068fddf53aaa5b444de6ec28bf7960a688
+MD5 ae54b5d8ffd342a8e7ac8528b6c8b5c9 files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch 537
+RMD160 abce74a23b3296a24788633497ab762abae54f4c files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch 537
+SHA256 4154944bfc4361d7dec4eab8394629068fddf53aaa5b444de6ec28bf7960a688 files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch 537
+AUX 4.2.0/gcc-4.2.0-crtbeginTS.patch 1196 RMD160 33378b49401cf212954693323acd4d7fa5a75204 SHA1 b643df3f5944f076e1a890bf8f1d5b24f05d1893 SHA256 d9dccbe8fce6a70697ebcdcc524d311d6fb206194068b292084b4453c98fcc6f
+MD5 29612a60828c6f09ce4fe0a40c8a1675 files/4.2.0/gcc-4.2.0-crtbeginTS.patch 1196
+RMD160 33378b49401cf212954693323acd4d7fa5a75204 files/4.2.0/gcc-4.2.0-crtbeginTS.patch 1196
+SHA256 d9dccbe8fce6a70697ebcdcc524d311d6fb206194068b292084b4453c98fcc6f files/4.2.0/gcc-4.2.0-crtbeginTS.patch 1196
AUX awk/fixlafiles.awk 7865 RMD160 6283a91bfa309a91f46cbff3c1c4f0d848312ba4 SHA1 0bd923243492496eceb8ec1407ed9f4ac5ad8c1a SHA256 9fccd7f4ee7170a8f05d21777974efc3f23072f501cb7d2a8e9eeea15e541249
MD5 fed3620378df7a876d6709ddf3f7bbec files/awk/fixlafiles.awk 7865
RMD160 6283a91bfa309a91f46cbff3c1c4f0d848312ba4 files/awk/fixlafiles.awk 7865
@@ -78,10 +86,10 @@ AUX c99 451 RMD160 b0e058d8ad3e2eac5f0e7b6e85583de5b1c4be93 SHA1 939df3f67e73790
MD5 b397ff885850ebf98a36fc0b877becbb files/c99 451
RMD160 b0e058d8ad3e2eac5f0e7b6e85583de5b1c4be93 files/c99 451
SHA256 474357dd9ce161b6db3ce88a5c0bd1e536a0f40d66a86894d48abe30226ee193 files/c99 451
-AUX fix_libtool_files.sh 1712 RMD160 01788fd6927a9f7bba4a01ec133d6f3494644fe9 SHA1 157be8228ac7338991ae4461ccd3cea7a702565a SHA256 6b47fb8fa34920ca9ccb449396b25205ad8fe307c869a50e5c4442971e8d4d15
-MD5 1acd56209164ab837c5f91723434464e files/fix_libtool_files.sh 1712
-RMD160 01788fd6927a9f7bba4a01ec133d6f3494644fe9 files/fix_libtool_files.sh 1712
-SHA256 6b47fb8fa34920ca9ccb449396b25205ad8fe307c869a50e5c4442971e8d4d15 files/fix_libtool_files.sh 1712
+AUX fix_libtool_files.sh 1738 RMD160 5872a8e5983b08aa9b4c530fa786f7db20de383a SHA1 1c81c48f057712b6496b89381cecc47b382aaf5f SHA256 c7b26f9f371168771d79487cda9eb2a71e30dc3aaa7e3b4b32778fec8399be70
+MD5 d05f01081a8da7207949967d9bc83b8a files/fix_libtool_files.sh 1738
+RMD160 5872a8e5983b08aa9b4c530fa786f7db20de383a files/fix_libtool_files.sh 1738
+SHA256 c7b26f9f371168771d79487cda9eb2a71e30dc3aaa7e3b4b32778fec8399be70 files/fix_libtool_files.sh 1738
AUX gcc-spec-env.patch 1478 RMD160 c3b9071296dbb7a37901714ef4db75bf04211381 SHA1 1f3cd57bab7187947d244ca843b7bd485f72c633 SHA256 167f2a1994c51c1c82d62943fb214f13540859dc89fe578632f3b60daf79c289
MD5 c4045bfa85d8be780affd465be9d8ca8 files/gcc-spec-env.patch 1478
RMD160 c3b9071296dbb7a37901714ef4db75bf04211381 files/gcc-spec-env.patch 1478
@@ -156,9 +164,13 @@ DIST gcc-4.1.1-patches-1.10.tar.bz2 51907 RMD160 af965233182530ead33d20e12d65ca5
DIST gcc-4.1.1-piepatches-v9.0.7.tar.bz2 5114 RMD160 af21263fabcc2428d58d93f0d28799cb39cc60e0 SHA1 7f78a84180895902dc6077ceb00492d880bb063b SHA256 52dc20f0eaee1117616defd4f0a0cb12778d2e7b88f394ecbfc257a7437288e4
DIST gcc-4.1.1-uclibc-patches-1.1.tar.bz2 20981 RMD160 ca12459f3ec8ee8a9dc5c260bea4bb20d6a80a65 SHA1 c004fbace98a1159115a81f0b733a4a248b2d096 SHA256 f97cf0f9fe52a529b41a78bb5d0d57899805fae00c3e7b2dff87c8192195b6f3
DIST gcc-4.1.1.tar.bz2 39172003 RMD160 0edeac242d900b075a7e36796380492b5b3c8564 SHA1 a398b95d38b6e35f4c4e02c34c0a3bff79811f8f SHA256 985cbb23a486570a8783395a42a8689218f5218a0ccdd6bec590eef341367bb7
-DIST gcc-4.1.2-patches-1.0.tar.bz2 42559 RMD160 9c9e3211bf84c151c700d62d0645fb6bb4f98f58 SHA1 f17c7d530e82ff6d723a6af70180c2e376eff6c8 SHA256 1bff9e6fcc9046dcca01ffc967764d4032679e631fef79f27d17e15d54692be6
+DIST gcc-4.1.2-patches-1.0.1.tar.bz2 43294 RMD160 70184d44cd3f051d154d8cbd957257d1eeefb460 SHA1 0affefdc4673f1781c829dafa24e62433fa868bc SHA256 311cef339fd021c72086cdef361e0aa6409a4a62d21fddaa7a5171bc1545085a
DIST gcc-4.1.2-uclibc-patches-1.0.tar.bz2 20980 RMD160 22e0f27e863e3b7c8fe0a5e4846daee17a49d409 SHA1 28033f25fd9b80102c2ae533b78ba332d490e21d SHA256 c6ed88711a727ed11847c9b9f1cef7023037bc80c0840eda5fca6d60fa02e35a
DIST gcc-4.1.2.tar.bz2 39707720 RMD160 7c5d78e666ccf4c2b2c3db41e2388f08b6cdf722 SHA1 7981b8d1b58b10ddfd7d5142eab16352d9206f3b SHA256 cfc0efbcc6fcde0d416a32dfb246c9df022515a312683fac412578c4fd09a9bc
+DIST gcc-4.2.0-patches-1.0.tar.bz2 12064 RMD160 8f8792fda2fdd1ab5b340c422073ad12cb460ffc SHA1 1ea2c57a58b348b8fe14c1896716f499fe4b1685 SHA256 d893d4619cb85a7fb789fd0763ba643e5d77a729e5ab13e4db675154ede63e2c
+DIST gcc-4.2.0-piepatches-v9.0.7.tar.bz2 4496 RMD160 ad6ab59e440ff79ef9722e491c4a569d4445ffe4 SHA1 c33cc17b2e62492470995b4643472212155d5da9 SHA256 9c74d990bc2ee03be4d821ec893bfd716618416fc5a2c7872e875dd0ee665f96
+DIST gcc-4.2.0-uclibc-patches-1.0.tar.bz2 19153 RMD160 d6ada495d13ce1fb03873450b4943a86290d25b4 SHA1 39b0657f6cf6d6da8300d613257c42a6686a89f9 SHA256 38a4a0cb8fd3a8fe5cd335e31b84ef69e035caaa9909d62ebbb7f1053d44646c
+DIST gcc-4.2.0.tar.bz2 44057527 RMD160 2da06cca1a3e6600cb40c0bfaf5dd27004326092 SHA1 f3b183d544319e4f8c17dafe70f05af7533e1970 SHA256 7b6c56ec37e52d24745a07bcf37e416b22141b0d0f1e80f71f9b1fe375e83268
DIST gdc-0.23-src.tar.bz2 1001644 RMD160 a208ea83f8049633ef067a5182320dc821ee96eb SHA1 ca29514902e05f861ab1bfa73d601cfa85b86d84 SHA256 4f642904f93973dc791c93125d1d227cefe0eb47fc39e364d03cda4784c0a38d
EBUILD gcc-3.4.6-r3.ebuild 5024 RMD160 447d015fe832316eec29bbde1963acad73acd4b5 SHA1 9126ed31179145830472e421f256e207ba349bce SHA256 d79ef43bc13a04992776a42de612f1c3c03be628833ac54c832e7c111acfbc69
MD5 9a4b9092452554690d3a48e216f3e35e gcc-3.4.6-r3.ebuild 5024
@@ -168,16 +180,23 @@ EBUILD gcc-4.1.1-r3.ebuild 3621 RMD160 6680af1e737c03742241b9e52531d45822a66d49
MD5 beadc390569c05a5d7c0dfe2f73e43e3 gcc-4.1.1-r3.ebuild 3621
RMD160 6680af1e737c03742241b9e52531d45822a66d49 gcc-4.1.1-r3.ebuild 3621
SHA256 aadbf598501f69904bf605c1a1e9c1ad8a57d2a2734093381d04e09d4099f688 gcc-4.1.1-r3.ebuild 3621
-EBUILD gcc-4.1.2-r1.ebuild 3618 RMD160 565b714a4144b88e33e45efa3fae55ab3ca33a58 SHA1 d55783632d5526ca0edf224f3e26be77709dd947 SHA256 64d0b13824ceb2e8c11e85d1470c63cae75a35bb34fad59af2d4972ab45171b9
-MD5 3153385646f09e5ca9b907917497ec60 gcc-4.1.2-r1.ebuild 3618
-RMD160 565b714a4144b88e33e45efa3fae55ab3ca33a58 gcc-4.1.2-r1.ebuild 3618
-SHA256 64d0b13824ceb2e8c11e85d1470c63cae75a35bb34fad59af2d4972ab45171b9 gcc-4.1.2-r1.ebuild 3618
+EBUILD gcc-4.1.2-r1.ebuild 3620 RMD160 5cf27cae9a9072717cad3920f2a480e4027632c8 SHA1 ff738d61b7b238748925b35db36429e90c6e9c3f SHA256 c2b85e79222db2b8b632acd090a28bd4e027db0a9bd86ff5af1539c15405dbc2
+MD5 9a3912cda643a8f29156f7620fc7349e gcc-4.1.2-r1.ebuild 3620
+RMD160 5cf27cae9a9072717cad3920f2a480e4027632c8 gcc-4.1.2-r1.ebuild 3620
+SHA256 c2b85e79222db2b8b632acd090a28bd4e027db0a9bd86ff5af1539c15405dbc2 gcc-4.1.2-r1.ebuild 3620
+EBUILD gcc-4.2.0.ebuild 3255 RMD160 6a642800ef3429bb0df2ea771d67c0ed755b649e SHA1 89760742bd8dd6bfdaa009ec480752f97168af7c SHA256 76de7511bc4bdd23aea29fdcbb5a3be3f89cd4e1573f38c9a48e857d305854d5
+MD5 9b21655c13c1e0df8b7c2e757b64cc06 gcc-4.2.0.ebuild 3255
+RMD160 6a642800ef3429bb0df2ea771d67c0ed755b649e gcc-4.2.0.ebuild 3255
+SHA256 76de7511bc4bdd23aea29fdcbb5a3be3f89cd4e1573f38c9a48e857d305854d5 gcc-4.2.0.ebuild 3255
MD5 f2ae42150d118fee847851b13498c67d files/digest-gcc-3.4.6-r3 1623
RMD160 61cd90be115485be70bc0c6511848949fd86e3ff files/digest-gcc-3.4.6-r3 1623
SHA256 fb9bc05b7f310a0ce63c7538d07315a3432bced82fc26c656e9ec0d843df2468 files/digest-gcc-3.4.6-r3 1623
MD5 3279035e9f313a53c1ba32e561f3a1df files/digest-gcc-4.1.1-r3 1072
RMD160 91219e23ecedf352e4fa56a0a112c4c549ae133c files/digest-gcc-4.1.1-r3 1072
SHA256 b95ab9fdf4c17f090e474ffdfd9f4be7632849c428000e8161e851d061e46757 files/digest-gcc-4.1.1-r3 1072
-MD5 2bdc8c1fb4306849f458840686a803d4 files/digest-gcc-4.1.2-r1 1313
-RMD160 e69196a6dadfb6a8241bcd5aac43953b0491badc files/digest-gcc-4.1.2-r1 1313
-SHA256 820a110d4aa3813b786b1571b83596d6fa2a63b32ac9025337c9b983ab0eb1b0 files/digest-gcc-4.1.2-r1 1313
+MD5 21124bfdab767937ebfb74ee1b2741de files/digest-gcc-4.1.2-r1 1319
+RMD160 ccee003e80d1d9494efabeb568c84d750a0305ee files/digest-gcc-4.1.2-r1 1319
+SHA256 62c0c648bbb63531084583261bdbc22e2d2cd81ba12475d05abab7377a5fece7 files/digest-gcc-4.1.2-r1 1319
+MD5 c1523e715c0feb4776226175f0b14f65 files/digest-gcc-4.2.0 1069
+RMD160 de3b2874212fdeb6d1162b5c89e72c64fab71968 files/digest-gcc-4.2.0 1069
+SHA256 fb7ae7e698fb90f819f7c9721ab5771a97ff286427ed7d1dfedbc6fd994d6acb files/digest-gcc-4.2.0 1069
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch
new file mode 100644
index 0000000..99b4de4
--- /dev/null
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-cc1-no-stack-protector.patch
@@ -0,0 +1,11 @@
+--- gcc/Makefile.in.orig 2007-05-20 14:44:14.000000000 +0200
++++ gcc/Makefile.in 2007-05-20 14:44:27.000000000 +0200
+@@ -2641,7 +2641,7 @@
+ output.h $(INSN_ATTR_H) $(SYSTEM_H) toplev.h $(TARGET_H) libfuncs.h \
+ $(TARGET_DEF_H) $(FUNCTION_H) $(SCHED_INT_H) $(TM_P_H) $(EXPR_H) \
+ langhooks.h $(GGC_H) $(OPTABS_H) $(REAL_H) tm-constrs.h
+- $(CC) -c $(ALL_CFLAGS) $(ALL_CPPFLAGS) \
++ $(CC) -c $(ALL_CFLAGS) -fno-stack-protector $(ALL_CPPFLAGS) \
+ $(out_file) $(OUTPUT_OPTION)
+
+ # Build auxiliary files that support ecoff format.
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-crtbeginTS.patch b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-crtbeginTS.patch
new file mode 100644
index 0000000..08be53a
--- /dev/null
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/4.2.0/gcc-4.2.0-crtbeginTS.patch
@@ -0,0 +1,27 @@
+--- gcc/config.gcc.orig 2007-05-20 21:12:05.000000000 +0200
++++ gcc/config.gcc 2007-05-20 21:13:09.000000000 +0200
+@@ -459,7 +459,7 @@
+ ;;
+ *-*-linux* | frv-*-*linux* | *-*-kfreebsd*-gnu | *-*-knetbsd*-gnu)
+ # Must come before *-*-gnu* (because of *-*-linux-gnu* systems).
+- extra_parts="crtbegin.o crtbeginS.o crtbeginT.o crtend.o crtendS.o"
++ extra_parts="crtbegin.o crtbeginS.o crtbeginT.o crtbeginTS.o crtend.o crtendS.o"
+ extra_options="${extra_options} linux.opt"
+ gas=yes
+ gnu_ld=yes
+--- gcc/Makefile.in.orig 2007-05-20 21:09:20.000000000 +0200
++++ gcc/Makefile.in 2007-05-20 21:11:45.000000000 +0200
+@@ -1554,6 +1554,13 @@
+ -c $(srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O \
+ -o $(T)crtbeginT$(objext)
+
++# This is a version of crtbegin for -static -fPIE links.
++$(T)crtbeginTS.o: crtstuff.c $(GCC_PASSES) $(TCONFIG_H) auto-host.h \
++ gbl-ctors.h stmp-int-hdrs tsystem.h coretypes.h $(TM_H)
++ $(GCC_FOR_TARGET) $(CRTSTUFF_CFLAGS) $(CRTSTUFF_T_CFLAGS_S) \
++ -c $(srcdir)/crtstuff.c -DCRT_BEGIN -DCRTSTUFFT_O -DCRTSTUFFS_O \
++ -o $(T)crtbeginTS$(objext)
++
+ # Compile the start modules crt0.o and mcrt0.o that are linked with
+ # every program
+ crt0.o: s-crt0 ; @true
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.1.2-r1 b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.1.2-r1
index c890489..7d4651c 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.1.2-r1
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.1.2-r1
@@ -1,9 +1,9 @@
MD5 deb751842288a97adf3dbd6a0e240538 gcc-4.1.1-piepatches-v9.0.7.tar.bz2 5114
RMD160 af21263fabcc2428d58d93f0d28799cb39cc60e0 gcc-4.1.1-piepatches-v9.0.7.tar.bz2 5114
SHA256 52dc20f0eaee1117616defd4f0a0cb12778d2e7b88f394ecbfc257a7437288e4 gcc-4.1.1-piepatches-v9.0.7.tar.bz2 5114
-MD5 fed1d2b995d1f35c8024a58773824d26 gcc-4.1.2-patches-1.0.tar.bz2 42559
-RMD160 9c9e3211bf84c151c700d62d0645fb6bb4f98f58 gcc-4.1.2-patches-1.0.tar.bz2 42559
-SHA256 1bff9e6fcc9046dcca01ffc967764d4032679e631fef79f27d17e15d54692be6 gcc-4.1.2-patches-1.0.tar.bz2 42559
+MD5 f2819b15f4c40d2d34c3e60b52828ffc gcc-4.1.2-patches-1.0.1.tar.bz2 43294
+RMD160 70184d44cd3f051d154d8cbd957257d1eeefb460 gcc-4.1.2-patches-1.0.1.tar.bz2 43294
+SHA256 311cef339fd021c72086cdef361e0aa6409a4a62d21fddaa7a5171bc1545085a gcc-4.1.2-patches-1.0.1.tar.bz2 43294
MD5 b6b3b22512d6e180bf9344ebb5b248fe gcc-4.1.2-uclibc-patches-1.0.tar.bz2 20980
RMD160 22e0f27e863e3b7c8fe0a5e4846daee17a49d409 gcc-4.1.2-uclibc-patches-1.0.tar.bz2 20980
SHA256 c6ed88711a727ed11847c9b9f1cef7023037bc80c0840eda5fca6d60fa02e35a gcc-4.1.2-uclibc-patches-1.0.tar.bz2 20980
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.2.0 b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.2.0
new file mode 100644
index 0000000..4b3235f
--- /dev/null
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/digest-gcc-4.2.0
@@ -0,0 +1,12 @@
+MD5 ed6b9dce9318fccf125743bccebfdb89 gcc-4.2.0-patches-1.0.tar.bz2 12064
+RMD160 8f8792fda2fdd1ab5b340c422073ad12cb460ffc gcc-4.2.0-patches-1.0.tar.bz2 12064
+SHA256 d893d4619cb85a7fb789fd0763ba643e5d77a729e5ab13e4db675154ede63e2c gcc-4.2.0-patches-1.0.tar.bz2 12064
+MD5 867b962da2a5524010a6c62509dbbabc gcc-4.2.0-piepatches-v9.0.7.tar.bz2 4496
+RMD160 ad6ab59e440ff79ef9722e491c4a569d4445ffe4 gcc-4.2.0-piepatches-v9.0.7.tar.bz2 4496
+SHA256 9c74d990bc2ee03be4d821ec893bfd716618416fc5a2c7872e875dd0ee665f96 gcc-4.2.0-piepatches-v9.0.7.tar.bz2 4496
+MD5 a39e11afcb9c1e21583750a0f79274f8 gcc-4.2.0-uclibc-patches-1.0.tar.bz2 19153
+RMD160 d6ada495d13ce1fb03873450b4943a86290d25b4 gcc-4.2.0-uclibc-patches-1.0.tar.bz2 19153
+SHA256 38a4a0cb8fd3a8fe5cd335e31b84ef69e035caaa9909d62ebbb7f1053d44646c gcc-4.2.0-uclibc-patches-1.0.tar.bz2 19153
+MD5 4798c23548dc791ea12a139e18940684 gcc-4.2.0.tar.bz2 44057527
+RMD160 2da06cca1a3e6600cb40c0bfaf5dd27004326092 gcc-4.2.0.tar.bz2 44057527
+SHA256 7b6c56ec37e52d24745a07bcf37e416b22141b0d0f1e80f71f9b1fe375e83268 gcc-4.2.0.tar.bz2 44057527
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/fix_libtool_files.sh b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/fix_libtool_files.sh
index c144be2..ae684ad 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/fix_libtool_files.sh
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/files/fix_libtool_files.sh
@@ -1,7 +1,7 @@
#!/bin/bash
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/fix_libtool_files.sh,v 1.12 2005/01/30 18:45:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/fix_libtool_files.sh,v 1.13 2007/05/05 01:10:43 vapier Exp $
usage() {
cat << "USAGE_END"
@@ -38,8 +38,8 @@ ARGV1=$1
ARGV2=$2
ARGV3=$3
-source /etc/profile
-source /sbin/functions.sh
+source /etc/profile || exit 1
+source /etc/init.d/functions.sh || exit 1
if [[ ${EUID} -ne 0 ]] ; then
eerror "${0##*/}: Must be root."
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.2-r1.ebuild b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.2-r1.ebuild
index 4e109e6..2a6a244 100644
--- a/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.2-r1.ebuild
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.1.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.2.ebuild,v 1.2 2007/03/09 22:13:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.2.ebuild,v 1.10 2007/05/19 22:58:33 opfer Exp $
-PATCH_VER="1.0"
+PATCH_VER="1.0.1"
UCLIBC_VER="1.0"
PIE_VER="9.0.7"
PIE_GCC_VER="4.1.1"
diff --git a/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.2.0.ebuild b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.2.0.ebuild
new file mode 100644
index 0000000..2642e48
--- /dev/null
+++ b/hardened/toolchain/branches/pieworld/sys-devel/gcc/gcc-4.2.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0.ebuild,v 1.1 2007/05/19 03:22:33 vapier Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+PIE_VER="9.0.7"
+PIE_GCC_VER="4.2.0"
+
+ETYPE="gcc-compiler"
+
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+SSP_STABLE="amd64 ppc ppc64 sparc x86"
+SSP_UCLIBC_STABLE="ppc sparc x86"
+PIE_GLIBC_STABLE="amd64 ppc ppc64 sparc x86"
+PIE_UCLIBC_STABLE="mips ppc x86"
+
+# arch/libc configurations known to be broken with {PIE,SSP}-by-default.
+# gcc-4 SSP is only available on FRAME_GROWS_DOWNWARD arches; so it's not
+# available on pa, c4x, ia64, alpha, iq2000, m68hc11, stormy16
+# (the options are parsed, but they're effectively no-ops).
+# rs6000 has special handling to support SSP; ia64 may get the same:
+# http://developer.momonga-linux.org/viewvc/trunk/pkgs/gcc4/gcc41-ia64-stack-protector.patch?revision=7447&view=markup&pathrev=7447
+SSP_UNSUPPORTED="hppa sh ia64 alpha"
+SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
+PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
+PIE_GLIBC_UNSUPPORTED="hppa"
+
+# This patch is obsoleted by stricter control over how one builds a hardened
+# compiler from a vanilla compiler. By forbidding changing from normal to
+# hardened between gcc stages, this is no longer necessary.
+GENTOO_PATCH_EXCLUDE="51_all_gcc-3.4-libiberty-pic.patch"
+
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+#SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+SPLIT_SPECS=${SPLIT_SPECS-true}
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
+ virtual/libiconv
+ fortran? (
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.2.0_p10
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ hardened? ( elibc_glibc? ( >=sys-libs/glibc-2.4 ) )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
+
+ # Add the crtbeginTS.o file - used for "static PIE" links
+ epatch "${FILESDIR}"/4.2.0/gcc-4.2.0-crtbeginTS.patch
+ # Ensure crtfiles are built fno-PIC/fPIC as appropriate, not fPIE
+ epatch "${FILESDIR}"/4.1.1/gcc-4.1.1-nopie-crtstuff.patch
+}