summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-08-30 22:31:10 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-08-30 22:31:10 +0000
commit5c2a2b931d64eecbd573e39b9f688d04a39ccb17 (patch)
treeab153789be48a3c170084682e85e44597f7351e8
parentadding amd64 keywords (diff)
downloadliquidx-5c2a2b931d64eecbd573e39b9f688d04a39ccb17.tar.gz
liquidx-5c2a2b931d64eecbd573e39b9f688d04a39ccb17.tar.bz2
liquidx-5c2a2b931d64eecbd573e39b9f688d04a39ccb17.zip
add pysvn bindings to my overlay because i need it. (#62852)
svn path=/; revision=69
-rw-r--r--dev-python/pysvn/Manifest12
-rw-r--r--dev-python/pysvn/bug_628520
-rw-r--r--dev-python/pysvn/files/digest-pysvn-1.4.23
-rw-r--r--dev-python/pysvn/pysvn-1.4.2.ebuild54
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/pysvn/Manifest b/dev-python/pysvn/Manifest
new file mode 100644
index 0000000..9c989a1
--- /dev/null
+++ b/dev-python/pysvn/Manifest
@@ -0,0 +1,12 @@
+DIST pysvn-1.4.2.tar.gz 455060 RMD160 d2404a66121c4fcf27c8891387e02c34d983d8d6 SHA1 919572057f3cf5b677ef9f7511c4dafd1c45391c SHA256 c8ffdc188c7c6ef107e56ef9a51fb6c09a5381cbaf2aafe5356a28b952bd6835
+EBUILD pysvn-1.4.2.ebuild 1107 RMD160 8464ebc0072d73b43ff45e869fd97da419c93ceb SHA1 bbde9d728ed600f060051f4c285c9e84c9c1d764 SHA256 d5568df4537894a19d82babb8e775f6b2f9e646be7fa84a7b6367e2cbbe4b920
+MD5 788e6f8659f1657225345245455126a0 pysvn-1.4.2.ebuild 1107
+RMD160 8464ebc0072d73b43ff45e869fd97da419c93ceb pysvn-1.4.2.ebuild 1107
+SHA256 d5568df4537894a19d82babb8e775f6b2f9e646be7fa84a7b6367e2cbbe4b920 pysvn-1.4.2.ebuild 1107
+MISC bug_62852 0 RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 SHA1 da39a3ee5e6b4b0d3255bfef95601890afd80709 SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
+MD5 d41d8cd98f00b204e9800998ecf8427e bug_62852 0
+RMD160 9c1185a5c5e9fc54612808977ee8f548b2258d31 bug_62852 0
+SHA256 e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855 bug_62852 0
+MD5 d03266d37952cbf83b1562d8221d2063 files/digest-pysvn-1.4.2 235
+RMD160 039b13032f1252000a4f94f0011d1d0ad1411c58 files/digest-pysvn-1.4.2 235
+SHA256 5a81959a87086a1dd7a80a38ce6001bb58c336b498a6d80bc78640373dbfacda files/digest-pysvn-1.4.2 235
diff --git a/dev-python/pysvn/bug_62852 b/dev-python/pysvn/bug_62852
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/dev-python/pysvn/bug_62852
diff --git a/dev-python/pysvn/files/digest-pysvn-1.4.2 b/dev-python/pysvn/files/digest-pysvn-1.4.2
new file mode 100644
index 0000000..7344231
--- /dev/null
+++ b/dev-python/pysvn/files/digest-pysvn-1.4.2
@@ -0,0 +1,3 @@
+MD5 05ce9f4c110580a2c1da93fc46fdba5f pysvn-1.4.2.tar.gz 455060
+RMD160 d2404a66121c4fcf27c8891387e02c34d983d8d6 pysvn-1.4.2.tar.gz 455060
+SHA256 c8ffdc188c7c6ef107e56ef9a51fb6c09a5381cbaf2aafe5356a28b952bd6835 pysvn-1.4.2.tar.gz 455060
diff --git a/dev-python/pysvn/pysvn-1.4.2.ebuild b/dev-python/pysvn/pysvn-1.4.2.ebuild
new file mode 100644
index 0000000..274ade1
--- /dev/null
+++ b/dev-python/pysvn/pysvn-1.4.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils python
+
+DESCRIPTION="Object-oriented python bindings for subversion"
+HOMEPAGE="http://pysvn.tigris.org/"
+SRC_URI="http://pysvn.tigris.org/files/documents/1233/31570/${P}.tar.gz"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE="doc"
+DEPEND="dev-lang/python
+ >=dev-util/subversion-1.2.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/Source
+ python setup.py configure || die "unable to configure"
+
+ sed -e 's:^\(CCFLAGS=\)\(.*\):\1$(CFLAGS) \2:g' \
+ -e 's:^\(CCCFLAGS=\)\(.*\):\1$(CXXFLAGS) \2:g' \
+ -i ${S}/Source/Makefile
+}
+
+src_compile() {
+ cd ${S}/Source
+ emake || die "Failed to make."
+}
+
+src_install() {
+ python_version
+
+ local base_dir=${S}/Source/pysvn
+ local module_dir=/usr/lib/python${PYVER}/site-packages/pysvn
+
+ exeinto ${module_dir}
+ doexe ${base_dir}/_pysvn.so
+ insinto ${module_dir}
+ doins ${base_dir}/__init__.py
+
+ if use doc; then
+ for doc in `ls ${S}/Docs/*.{html,js}`; do
+ dohtml $doc
+ done
+ fi
+}