summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:36:54 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-17 00:36:54 +0200
commit0778d1702751427580d7a90124dffb6de09765c0 (patch)
tree0cf102d638c034ba70a9d1578ad3dce55860a0e6 /dev-python/python-poppler/python-poppler-0.10.0.ebuild
parentClaws mail plugins. (diff)
downloadloki_val-0778d1702751427580d7a90124dffb6de09765c0.tar.gz
loki_val-0778d1702751427580d7a90124dffb6de09765c0.tar.bz2
loki_val-0778d1702751427580d7a90124dffb6de09765c0.zip
poppler-python added
Diffstat (limited to 'dev-python/python-poppler/python-poppler-0.10.0.ebuild')
-rw-r--r--dev-python/python-poppler/python-poppler-0.10.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/python-poppler/python-poppler-0.10.0.ebuild b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
new file mode 100644
index 0000000..879ce53
--- /dev/null
+++ b/dev-python/python-poppler/python-poppler-0.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit libtool
+
+EAPI=2
+
+DESCRIPTION="Python bindings to the Poppler PDF library."
+SRC_URI="http://www.gnome.org/~gianmt/pypoppler-${PV}.tar.gz"
+HOMEPAGE="http://launchpad.net/poppler-python"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/pypoppler-${PV}"
+
+# Dependency for PyGObbject is 2.11.3 if building docs,
+# but this ebuild doesn't provide a USE flag for docs yet.
+DEPEND=">=dev-libs/poppler-glib-0.10.0
+ >=dev-python/pygobject-2.11.3
+ >=dev-python/pygtk-2.10.0
+ >=dev-python/pycairo-1.2.0"
+
+src_prepare() {
+ elibtoolize
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -type f -exec rm -f '{}' ';' || die "Removing .la files failed"
+}
+