summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2006-12-15 21:17:21 +0000
committerLuca Barbato <lu_zero@gentoo.org>2006-12-15 21:17:21 +0000
commit5f08d3d90a09a40ddc363fd3d6384765152d4010 (patch)
tree8b99cb52ad42ad08ba5f489d48682468b189ccb8
parentTentative ebuild (diff)
downloadlu_zero-5f08d3d90a09a40ddc363fd3d6384765152d4010.tar.gz
lu_zero-5f08d3d90a09a40ddc363fd3d6384765152d4010.tar.bz2
lu_zero-5f08d3d90a09a40ddc363fd3d6384765152d4010.zip
build/install fixes and improved postinst message
svn path=/; revision=66
-rw-r--r--sys-libs/libspe2/files/spe.rc62
-rw-r--r--sys-libs/libspe2/libspe2-2.0.1.ebuild11
2 files changed, 8 insertions, 5 deletions
diff --git a/sys-libs/libspe2/files/spe.rc6 b/sys-libs/libspe2/files/spe.rc6
index 0776e88..4614b4a 100644
--- a/sys-libs/libspe2/files/spe.rc6
+++ b/sys-libs/libspe2/files/spe.rc6
@@ -17,7 +17,7 @@ start() {
return 1
else
if test -f /proc/sys/fs/binfmt_misc/register
- echo ':spe:M::\x7fELF\x01\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x17::/usr/bin/elfspe:' >/proc/sys/fs/binfmt_misc/register
+ echo ':spe:M::\x7fELF\x01\x02\x01\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x02\x00\x17::/usr/bin/elfspe2:' >/proc/sys/fs/binfmt_misc/register
eend $?
else
eerror "binfmt not available"
diff --git a/sys-libs/libspe2/libspe2-2.0.1.ebuild b/sys-libs/libspe2/libspe2-2.0.1.ebuild
index b0ce544..08539db 100644
--- a/sys-libs/libspe2/libspe2-2.0.1.ebuild
+++ b/sys-libs/libspe2/libspe2-2.0.1.ebuild
@@ -4,7 +4,7 @@
DESCRIPTION="A wrapper library to adapt the JSRE SPU usage model to SPUFS"
HOMEPAGE="http://ozlabs.org/pipermail/cbe-oss-dev/"
-SRC_URI="http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~lu_zero/distfiles/${P}.tar.bz2"
LICENSE="LGPL-2"
SLOT="0"
@@ -37,19 +37,22 @@ src_unpack () {
src_compile() {
myconf=""
use debug && myconf="${myconf} DEBUG=1"
- make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" ${myconf}
+ make all elfspe2-all CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" ${myconf}
}
src_install() {
make CROSS="${CTARGET}-" prefix=/usr SYSROOT="$SYSROOT" \
- DESTDIR="$D" install
+ DESTDIR="$D" install elfspe2-install
cp ${FILESDIR}/spe.rc6 ${T}/elfspe
doinitd ${T}/elfspe
}
-
pkg_postinst() {
einfo "You may want to register elfspe to binfmt using the"
einfo "provided initscript"
einfo "# rc-update add elfspe boot"
+ ewarn "make sure your fstab contains the following line"
+ ewarn "none /spu spufs defaults
+ 0 0"
+ ewarn "and that you have spufs support enabled in the kernel"
}