summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Marineau <marineam@gentoo.org>2007-05-02 00:04:36 +0000
committerMichael Marineau <marineam@gentoo.org>2007-05-02 00:04:36 +0000
commit7ad0aa1a36f57e917f936c40de16e9be860ef707 (patch)
tree6e5ea2c0fca2e7b4f1d7a05858e0c0f280fb6b50 /app-emulation/xen/xen-3.0.2.ebuild
parentFix Manifest for xen and xen-tools (diff)
downloadxen-7ad0aa1a36f57e917f936c40de16e9be860ef707.tar.gz
xen-7ad0aa1a36f57e917f936c40de16e9be860ef707.tar.bz2
xen-7ad0aa1a36f57e917f936c40de16e9be860ef707.zip
Switch from einfo to elog, remove hardened use flag and detect hardened gcc flags as xen-tools does.
svn path=/xen/; revision=29
Diffstat (limited to 'app-emulation/xen/xen-3.0.2.ebuild')
-rw-r--r--app-emulation/xen/xen-3.0.2.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/app-emulation/xen/xen-3.0.2.ebuild b/app-emulation/xen/xen-3.0.2.ebuild
new file mode 100644
index 0000000..06b7a62
--- /dev/null
+++ b/app-emulation/xen/xen-3.0.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit mount-boot flag-o-matic
+
+DESCRIPTION="The Xen virtual machine monitor"
+HOMEPAGE="http://xen.sourceforge.net"
+MY_PV=${PV/_p/_}
+SRC_URI="http://bits.xensource.com/oss-xen/release/${MY_PV/_/-}/src.tgz/xen-${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug custom-cflags pae hardened"
+
+RDEPEND="sys-boot/grub
+ sys-kernel/xen-sources"
+PDEPEND="~app-emulation/xen-tools-${PV}"
+
+RESTRICT="test"
+
+# Approved by QA team in bug #144032
+QA_WX_LOAD="boot/xen-syms-${MY_PV/_/-}"
+
+pkg_setup() {
+ if [[ -z ${XEN_TARGET_ARCH} ]]; then
+ if use x86; then
+ export XEN_TARGET_ARCH="x86_32"
+ elif use amd64; then
+ export XEN_TARGET_ARCH="x86_64"
+ else
+ die "Unsupported architecture!"
+ fi
+ fi
+}
+
+
+src_unpack() {
+ unpack ${A}
+ # if the user *really* wants to use their own custom-cflags, let them
+ if use custom-cflags; then
+ einfo "User wants their own CFLAGS - removing defaults"
+ # try and remove all the default custom-cflags
+ find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
+ -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
+ -i {} \;
+ fi
+ if use hardened; then
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}"-3.0.2-nopiessp.patch
+ fi
+}
+
+src_compile() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ if use custom-cflags; then
+ filter-flags -fPIE -fstack-protector
+ else
+ unset CFLAGS
+ fi
+
+ # Send raw LDFLAGS so that --as-needed works
+ emake LDFLAGS="$(raw-ldflags)" -C xen ${myopt} || die "compile failed"
+}
+
+src_install() {
+ local myopt
+ use debug && myopt="${myopt} debug=y"
+ use pae && myopt="${myopt} pae=y"
+
+ make DESTDIR="${D}" install-xen ${myopt} || die "install failed"
+}
+
+pkg_postinst() {
+ elog "Please visit the Xen and Gentoo wiki:"
+ elog "http://gentoo-wiki.com/HOWTO_Xen_and_Gentoo"
+
+ echo
+ elog "Note: xen tools have been moved to app-emulation/xen-tools"
+
+ if use pae; then
+ echo
+ ewarn "This is a PAE build of Xen. It will *only* boot PAE kernels!"
+ fi
+}