summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/slmon/slmon-0.5.13.ebuild')
-rw-r--r--app-misc/slmon/slmon-0.5.13.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/slmon/slmon-0.5.13.ebuild b/app-misc/slmon/slmon-0.5.13.ebuild
new file mode 100644
index 0000000..b166463
--- /dev/null
+++ b/app-misc/slmon/slmon-0.5.13.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="Colored text-based system performance monitor"
+HOMEPAGE="http://slmon.sourceforge.net/"
+SRC_URI="http://slmon.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="debug"
+
+DEPEND=">=dev-libs/glib-2
+ sys-libs/slang
+ gnome-base/libgtop"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-invalid-free.patch"
+}
+src_compile() {
+ econf $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL README TODO
+}