summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/uptimed/uptimed-0.3.9.ebuild')
-rw-r--r--app-misc/uptimed/uptimed-0.3.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/uptimed/uptimed-0.3.9.ebuild b/app-misc/uptimed/uptimed-0.3.9.ebuild
new file mode 100644
index 0000000..9021436
--- /dev/null
+++ b/app-misc/uptimed/uptimed-0.3.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools
+
+DESCRIPTION="System uptime record daemon that keeps track of your highest uptimes"
+HOMEPAGE="http://podgorny.cz/uptimed/"
+SRC_URI="http://podgorny.cz/uptimed/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # respect DESTDIR
+ sed -i -e 's|-d \(/var/spool.*\)$|-d $(DESTDIR)\1|' Makefile.am || \
+ die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+ keepdir /var/spool/uptimed
+ dodoc ChangeLog README TODO AUTHORS CREDITS INSTALL.cgi sample-cgi/*
+ doinitd "${FILESDIR}/uptimed" || die "failed to install init.d file"
+}
+
+pkg_postinst() {
+ elog "Start uptimed with '/etc/init.d/uptimed start'"
+ elog "To view your uptime records, use the command 'uprecords'."
+}