summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2010-07-09 09:16:53 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2010-07-09 09:16:53 +0900
commitcd6f4a5636044010027a90b0d1848463fc00a280 (patch)
tree859ff1d987f73a0b93401559cbc14cf9b1aea7f5
parentdev-ruby/notify: Convert to ruby-ng. (diff)
downloadmatsuu-cd6f4a5636044010027a90b0d1848463fc00a280.tar.gz
matsuu-cd6f4a5636044010027a90b0d1848463fc00a280.tar.bz2
matsuu-cd6f4a5636044010027a90b0d1848463fc00a280.zip
dev-ruby/termcolor: Convert to ruby-ng.
-rw-r--r--dev-ruby/termcolor/Manifest2
-rw-r--r--dev-ruby/termcolor/termcolor-1.2.0.ebuild17
2 files changed, 12 insertions, 7 deletions
diff --git a/dev-ruby/termcolor/Manifest b/dev-ruby/termcolor/Manifest
index ac1172c..9078aba 100644
--- a/dev-ruby/termcolor/Manifest
+++ b/dev-ruby/termcolor/Manifest
@@ -1,4 +1,4 @@
DIST termcolor-1.1.0.gem 6656 RMD160 4130fb3d29e4d105c67b7ff2f07b385e34ebd187 SHA1 4a2d1b46e40586cc0bb77d95cb3f4dfc86eeb848 SHA256 8155a71d8e887be40217be511bc07fab6d632fbe7401d18be55fa51e800e742c
DIST termcolor-1.2.0.gem 6656 RMD160 234b7c6e5fdae65febe9214442c66062908d91af SHA1 ccb19dc24757f5a2a27f948fe7bfc7a72e8a4601 SHA256 30b9f7c0f1834c2043a80d7d739e8fcf14303bed0244cb56e3a4676608bf8b67
EBUILD termcolor-1.1.0.ebuild 391 RMD160 89cbf596dba7266acea2ea6d4c8b88b112dd4541 SHA1 6e277dc1dffe6360ae39007dbf1a3050b2157d1d SHA256 89cb045a2534ed42fa0eafbe74a74d4c36a815221cee90a8c4b8b57fcb039930
-EBUILD termcolor-1.2.0.ebuild 391 RMD160 89cbf596dba7266acea2ea6d4c8b88b112dd4541 SHA1 6e277dc1dffe6360ae39007dbf1a3050b2157d1d SHA256 89cb045a2534ed42fa0eafbe74a74d4c36a815221cee90a8c4b8b57fcb039930
+EBUILD termcolor-1.2.0.ebuild 613 RMD160 ede427cdce83de5e259e03c2667cba0ee63af801 SHA1 a829841c130833470143887c0d789c11b92b9488 SHA256 58a51aab60d283ff09d1516a73aebfa56adc9638d1d2b2a38315bd94f66687b8
diff --git a/dev-ruby/termcolor/termcolor-1.2.0.ebuild b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
index a584aee..8c535c8 100644
--- a/dev-ruby/termcolor/termcolor-1.2.0.ebuild
+++ b/dev-ruby/termcolor/termcolor-1.2.0.ebuild
@@ -1,8 +1,15 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit gems
+EAPI="2"
+#*** Using highline effectively in JRuby requires manually installing the ffi-ncurses gem.
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
DESCRIPTION="a library for ANSI color formatting like HTML for output in terminal"
HOMEPAGE="http://termcolor.rubyforge.org/"
@@ -12,7 +19,5 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-ruby/highline-1.5.0"
-RDEPEND="${DEPEND}"
-
-USE_RUBY="ruby18"
+ruby_add_bdepend dev-ruby/rspec
+ruby_add_rdepend ">=dev-ruby/highline-1.5.0"