summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMATSUU Takuto <matsuu@gentoo.org>2009-10-03 11:10:28 +0900
committerMATSUU Takuto <matsuu@gentoo.org>2009-10-03 11:10:28 +0900
commit6ce0fd6e99ab0e1ecfa68c34c2b16351444b8073 (patch)
treea3ef1320067cd5378544a4fda446bb02f0e8189b /app-text
parentx11-wm/awesome: Fixed dependency. (diff)
downloadmatsuu-6ce0fd6e99ab0e1ecfa68c34c2b16351444b8073.tar.gz
matsuu-6ce0fd6e99ab0e1ecfa68c34c2b16351444b8073.tar.bz2
matsuu-6ce0fd6e99ab0e1ecfa68c34c2b16351444b8073.zip
app-text/sena: Initial import.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/senna/Manifest2
-rw-r--r--app-text/senna/senna-1.1.4.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/senna/Manifest b/app-text/senna/Manifest
new file mode 100644
index 0000000..496caec
--- /dev/null
+++ b/app-text/senna/Manifest
@@ -0,0 +1,2 @@
+DIST senna-1.1.4.tar.gz 1121030 RMD160 95332d04674e34988aa5472a0fb6ab95b90d078b SHA1 76bd9657c2d320dc2c1cf0e23a37c5a0d333e493 SHA256 fd0fb0ba818d3bed4c4b6fac17cbf8829b58ebc66c88678abd9937113ec8f5bc
+EBUILD senna-1.1.4.ebuild 1134 RMD160 14823c0e30e88bcb0ad54d412410036fd7ce3e8d SHA1 e39067db01bbc80c23142f69dc40f97b6311a787 SHA256 53883c83f3bfd40ac41d6cc099df15248fe4ddfcca4fc9fa38285d5b14eb36ac
diff --git a/app-text/senna/senna-1.1.4.ebuild b/app-text/senna/senna-1.1.4.ebuild
new file mode 100644
index 0000000..99653cf
--- /dev/null
+++ b/app-text/senna/senna-1.1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+DESCRIPTION="Full text search engine with support for various languages and DBs"
+HOMEPAGE="http://qwik.jp/senna/"
+SRC_URI="mirror://sourceforge.jp/${PN}/33763/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug lzo mecab ruby unicode zlib"
+
+RDEPEND="mecab? ( >=app-text/mecab-0.81[unicode?] )
+ ruby? ( virtual/ruby )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf
+ use unicode && myconf="--with-encoding=utf8"
+
+ econf \
+ $(use_enable aio) \
+ $(use_enable debug gcov) \
+ $(use_with zlib) \
+ $(use_with lzo) \
+ $(use_with mecab) \
+ ${myconf} || die "econf failed"
+# $(use_enable nfkc) \
+# $(use_enable fmalloc) \
+# $(use_enable abort) \
+
+ emake || die "emake failed"
+
+ if use ruby ; then
+ emake ruby-bindings || die "emake ruby-bindings failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use ruby ; then
+ emake DESTDIR="${D}" install-ruby-bindings || die
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS doc/*
+}