summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-05-25 01:40:40 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-05-25 01:40:40 +0000
commita7086fa3e84df9b1714f8ff3e7d455043b533b6b (patch)
treec702a3dbb674fdabb77652515aaf7e10c779465c
parentChecking in... (diff)
downloadnichoj-a7086fa3e84df9b1714f8ff3e7d455043b533b6b.tar.gz
nichoj-a7086fa3e84df9b1714f8ff3e7d455043b533b6b.tar.bz2
nichoj-a7086fa3e84df9b1714f8ff3e7d455043b533b6b.zip
Some display changes.
svn path=/; revision=102
-rwxr-xr-xprojects/gentoolkit-nichoj/trunk/rubycommit.rb9
1 files changed, 5 insertions, 4 deletions
diff --git a/projects/gentoolkit-nichoj/trunk/rubycommit.rb b/projects/gentoolkit-nichoj/trunk/rubycommit.rb
index d28897b..1cc2845 100755
--- a/projects/gentoolkit-nichoj/trunk/rubycommit.rb
+++ b/projects/gentoolkit-nichoj/trunk/rubycommit.rb
@@ -55,7 +55,7 @@ end
def show_diff()
if isSvn or isCvs
- display_heading('diff')
+ display_heading('Diff')
if isSvn
system('svn diff')
elsif isCvs
@@ -67,21 +67,21 @@ def show_diff()
end
def show_repoman
- display_heading 'repoman full'
+ display_heading 'Repoman'
system('repoman full')
puts 'Exit status: ' + $?.to_s
return $?
end
def show_qualudis
- display_heading 'qualudis'
+ display_heading 'Qualudis'
system('qualudis')
puts 'Exit status: ' + $?.to_s
return $?
end
def get_logentry()
-# use log entry from command line
+ # use log entry from command line
logentry = ARGV[0]
# or default to your last ChangeLog entry
if logentry.nil? and File.file?('ChangeLog')
@@ -113,6 +113,7 @@ show_logentry(logentry)
line = gets
if line.match(/y|yes/i)
display_heading('Committing...')
+ system ('emanifest *.ebuild')
if isSvn
system("svn commit -m \"#{escaped}\"")
else