summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2010-08-04 11:02:45 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2010-08-04 11:02:45 +0530
commit0874af6193d2feee2adc2f8255e4cc94b8f62f27 (patch)
treebf451bffaaa06de48cdfcd9d06258dc9f7bc0f83
parentx11-drivers/psb-kmod: Need I2C_ALGOBIT (diff)
downloadnirbheek-0874af6193d2feee2adc2f8255e4cc94b8f62f27.tar.gz
nirbheek-0874af6193d2feee2adc2f8255e4cc94b8f62f27.tar.bz2
nirbheek-0874af6193d2feee2adc2f8255e4cc94b8f62f27.zip
dev-util/sysprof: Add 1.1.6, dev version
-rw-r--r--dev-util/sysprof/Manifest2
-rw-r--r--dev-util/sysprof/sysprof-1.1.6.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-util/sysprof/Manifest b/dev-util/sysprof/Manifest
new file mode 100644
index 0000000..2d711b3
--- /dev/null
+++ b/dev-util/sysprof/Manifest
@@ -0,0 +1,2 @@
+DIST sysprof-1.1.6.tar.gz 262385 RMD160 03ab42b4bc13bed77e4f4001f21c6342fb21c615 SHA1 beed5b205b0069ba86582db894c708a2038d4893 SHA256 e7f13142659e629ad6478da482349b30c37e31be2d68cf7144e9f7c8a0ee9d04
+EBUILD sysprof-1.1.6.ebuild 1734 RMD160 20ecf4d7b0ed1bb008d0ea7ce80f5beca7aac5e6 SHA1 5b88293ec3e9bf19b0f96ca3349b15ee8a0cee97 SHA256 fdc4526cbe851e004d4e7be2b9f8b76b0b7b5fdc3e15dce513b5e37eb8e55e5f
diff --git a/dev-util/sysprof/sysprof-1.1.6.ebuild b/dev-util/sysprof/sysprof-1.1.6.ebuild
new file mode 100644
index 0000000..5be2f91
--- /dev/null
+++ b/dev-util/sysprof/sysprof-1.1.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/sysprof/sysprof-1.0.12-r1.ebuild,v 1.1 2009/05/27 11:02:05 remi Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="System-wide Linux Profiler"
+HOMEPAGE="http://www.daimi.au.dk/~sandmann/sysprof/"
+SRC_URI="http://www.daimi.au.dk/~sandmann/sysprof/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ x11-libs/pango
+ >=gnome-base/libglade-2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+pkg_setup() {
+ MODULE_NAMES="sysprof-module(misc:${S}/module)"
+ CONFIG_CHECK="PROFILING"
+ PROFILING_ERROR="You need to enable Profiling support in your kernel. \
+For this you need to enable 'Profiling support' under 'Instrumentation Support'. \
+It is marked CONFIG_PROFILING in the config file"
+ BUILD_TARGETS="all"
+
+ kernel_is -ge 2 6 31
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ make_desktop_entry sysprof Sysprof sysprof-icon
+}
+
+pkg_postinst() {
+ einfo "On many systems, especially amd64, it is typical that with a modern"
+ einfo "toolchain -fomit-frame-pointer for gcc is the default, because"
+ einfo "debugging is still possible thanks to gcc4/gdb location list feature."
+ einfo "However sysprof is not able to construct call trees if frame pointers"
+ einfo "are not present. Therefore -fno-omit-frame-pointer CFLAGS is suggested"
+ einfo "for the libraries and applications involved in the profiling. That"
+ einfo "means a CPU register is used for the frame pointer instead of other"
+ einfo "purposes, which means a very minimal performance loss when there is"
+ einfo "register pressure."
+}