summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-05-17 17:52:47 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-05-17 17:52:47 +0530
commit95f8cf2c5bc5e960e6cbe3948d2af869a65ebce3 (patch)
tree79bd620961c7b3517e806d523838a65b8024b906 /dev-util
parentAdd media-sound/jokosher (diff)
downloadnirbheek-95f8cf2c5bc5e960e6cbe3948d2af869a65ebce3.tar.gz
nirbheek-95f8cf2c5bc5e960e6cbe3948d2af869a65ebce3.tar.bz2
nirbheek-95f8cf2c5bc5e960e6cbe3948d2af869a65ebce3.zip
Add dev-util/ldtp-1.6.0
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ldtp/Manifest2
-rw-r--r--dev-util/ldtp/ldtp-1.6.0.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-util/ldtp/Manifest b/dev-util/ldtp/Manifest
new file mode 100644
index 0000000..e1a9ef7
--- /dev/null
+++ b/dev-util/ldtp/Manifest
@@ -0,0 +1,2 @@
+DIST ldtp-1.6.0.tar.gz 440009 RMD160 41a2a378fbfbe985aa48d7e869c547e5d690daf2 SHA1 61c5149206a4184b538824ae875208aa7bc1dfa9 SHA256 db3d81dfbfc18a355d1b111db061618c03afc2e101abb0ed46206abf0b3cefc7
+EBUILD ldtp-1.6.0.ebuild 968 RMD160 1feb05cb61f749303052efebcea972c1f24f0494 SHA1 a5b3917049948251ee8e99d1f0920c8aa55b0a41 SHA256 2acd0f8bdb74366a3620acb6f5b00aec4afc1dfe9cb5f8e21901a5415ef002bd
diff --git a/dev-util/ldtp/ldtp-1.6.0.ebuild b/dev-util/ldtp/ldtp-1.6.0.ebuild
new file mode 100644
index 0000000..0c70ede
--- /dev/null
+++ b/dev-util/ldtp/ldtp-1.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="1"
+
+inherit versionator
+
+MY_PV="$(get_version_component_range 1-2)"
+DESCRIPTION="A high quality test automation framework for desktop applications"
+HOMEPAGE="http://ldtp.freedesktop.org"
+SRC_URI="http://download.freedesktop.org/${PN}/${MY_PV%%.*}.x/${MY_PV}.x/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="localization +python"
+DEPEND="gnome-extra/at-spi
+ >=dev-libs/glib-2.2.0
+ gnome-extra/libgail-gnome
+ gnome-base/gail
+ python? ( virtual/python )
+ localization? ( sys-devel/gettext )
+ dev-libs/libxml2"
+RDEPEND="${DEPEND}"
+
+
+src_compile() {
+ econf \
+ --enable-goptionparse \
+ --enable-newroles \
+ $(use_enable localization) \
+ $(use_with python pythonmodules)
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README TODO
+}