summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/inkscape/inkscape-0.46_pre16516.ebuild')
-rw-r--r--media-gfx/inkscape/inkscape-0.46_pre16516.ebuild89
1 files changed, 0 insertions, 89 deletions
diff --git a/media-gfx/inkscape/inkscape-0.46_pre16516.ebuild b/media-gfx/inkscape/inkscape-0.46_pre16516.ebuild
deleted file mode 100644
index 64964ae..0000000
--- a/media-gfx/inkscape/inkscape-0.46_pre16516.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/inkscape/inkscape-0.44.ebuild,v 1.7 2006/09/07 14:31:47 gustavoz Exp $
-
-inherit eutils gnome2 subversion
-
-PREVER="${PV/*_pre/}"
-PREVER="${PREVER/*_p/}"
-MV="${PREVER}"
-MP="$PN-$MV"
-DESCRIPTION="A SVG based generic vector-drawing program"
-HOMEPAGE="http://www.inkscape.org/"
-#SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-SRC_URI=""
-ESVN_REPO_URI="https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk"
-ESVN_OPTIONS="-r${PREVER}"
-S=${WORKDIR}/${MP}
-
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="dia gnome mmx inkjar lcms doc postscript spell wmf imagemagick"
-RESTRICT="nomirror test"
-
-COMMON_DEPEND=">=x11-libs/gtk+-2.10.7
- dev-cpp/glibmm
- >=dev-cpp/gtkmm-2.4
- >=dev-libs/boehm-gc-6.4
- >=dev-libs/glib-2.6.5
- >=dev-libs/libsigc++-2.0.12
- dev-libs/popt
- media-libs/fontconfig
- >=media-libs/freetype-2
- media-libs/libpng
- >=x11-libs/pango-1.4.0
- >=dev-libs/libxml2-2.6.20
- dev-perl/XML-Parser
- dev-perl/XML-XQL
- dev-python/pyxml
- virtual/xft
- x11-libs/cairo
- app-text/poppler-bindings
- imagemagick? ( media-gfx/imagemagick )
- gnome? (
- >=gnome-base/gnome-vfs-2.0
- gnome-base/libgnomeprint
- gnome-base/libgnomeprintui
- )
- lcms? ( >=media-libs/lcms-1.14 )
- spell? ( app-text/gtkspell )"
-
-# These only use executables provided by these packages
-# See share/extensions for more details. inkscape can tell you to
-# install these so we could of course just not depend on those and rely
-# on that.
-RDEPEND="
- ${COMMON_DEPEND}
- dia? ( app-office/dia )
- postscript? ( >=media-gfx/pstoedit-3.44 media-gfx/skencil )
- wmf? ( media-libs/libwmf )"
-
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- dev-util/pkgconfig
- x11-libs/libX11
- >=dev-util/intltool-0.29"
-
-pkg_setup() {
- G2CONF="${G2CONF} --with-xft"
- G2CONF="${G2CONF} $(use_with spell gtkspell)"
- #G2CONF="${G2CONF} $(use_with jabber inkboard)"
- G2CONF="${G2CONF} $(use_enable mmx)"
- G2CONF="${G2CONF} $(use_with inkjar)"
- G2CONF="${G2CONF} $(use_with gnome gnome-vfs)"
- G2CONF="${G2CONF} $(use_with gnome gnome-print)"
- G2CONF="${G2CONF} $(use_with imagemagick)"
- G2CONF="${G2CONF} $(use_enable lcms)"
-}
-
-
-src_unpack() {
-# unpack ${A}
- subversion_src_unpack
- cd ${S}
-
- sh autogen.sh || die "failed to create configure"
-}
-
-DOCS="AUTHORS COPYING ChangeLog NEWS README"