summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-04-22 14:44:58 +0000
committerChristian Heim <phreak@gentoo.org>2007-04-22 14:44:58 +0000
commit8bf4a3f6165115fbe0a97f2cca0ac5cb59d236df (patch)
treec9a395442c78bceedae387f1c42e03fca1488d5f /hardened
parentSome simple comment changes, move the env.d entry from postinst to install, a... (diff)
downloadphreak-8bf4a3f6165115fbe0a97f2cca0ac5cb59d236df.tar.gz
phreak-8bf4a3f6165115fbe0a97f2cca0ac5cb59d236df.tar.bz2
phreak-8bf4a3f6165115fbe0a97f2cca0ac5cb59d236df.zip
Really fix #134403 for hardened.
svn path=/; revision=321
Diffstat (limited to 'hardened')
-rw-r--r--hardened/dev-lang/ocaml/Manifest8
-rw-r--r--hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild8
2 files changed, 11 insertions, 5 deletions
diff --git a/hardened/dev-lang/ocaml/Manifest b/hardened/dev-lang/ocaml/Manifest
index ebdebae..0d0a067 100644
--- a/hardened/dev-lang/ocaml/Manifest
+++ b/hardened/dev-lang/ocaml/Manifest
@@ -19,10 +19,10 @@ MD5 bcc5109143faee7e7b8f7f76bd4726a7 files/ocaml-rebuild.sh 1361
RMD160 a9c452fbea18de3b38d8240f887f8595e529643e files/ocaml-rebuild.sh 1361
SHA256 a8004cd4bca96ab3fc595fcfd7dbe88903833f9e430149c3d04c9fda84362b64 files/ocaml-rebuild.sh 1361
DIST ocaml-3.09.3.tar.bz2 2038617 RMD160 fdc124218c556c62c897ee6720970279e2d5426b SHA1 5d63c6e0d13463f85c0d5147d641d2bceef87d6b SHA256 607842b4f4917a759f19541a421370a834f5b948855ca54cef40d22b19a0934f
-EBUILD ocaml-3.09.3-r1.ebuild 4033 RMD160 37198bf3e03d0c51601e4a2a414f2256f4c18814 SHA1 4c4804fa00e1ffbf0111be19a3b6f77370da7871 SHA256 d59c9cfbf6d28d6ad35b3d3937c55c6a1c98d380b6923fada6cf27e704c1f0f5
-MD5 cfa22ed3bcceca85ccf81958acdb5b03 ocaml-3.09.3-r1.ebuild 4033
-RMD160 37198bf3e03d0c51601e4a2a414f2256f4c18814 ocaml-3.09.3-r1.ebuild 4033
-SHA256 d59c9cfbf6d28d6ad35b3d3937c55c6a1c98d380b6923fada6cf27e704c1f0f5 ocaml-3.09.3-r1.ebuild 4033
+EBUILD ocaml-3.09.3-r1.ebuild 4217 RMD160 40f122acfc17d04394567e0f836515f9d9a65738 SHA1 9108d1452d348c8d7666cf2926ba1903fbc8f8d9 SHA256 0ea364289db4ab59f2d4464387ab706e818a692173b1f47010bff256094f37af
+MD5 f197a91f8518b9314a0a62a1305d172d ocaml-3.09.3-r1.ebuild 4217
+RMD160 40f122acfc17d04394567e0f836515f9d9a65738 ocaml-3.09.3-r1.ebuild 4217
+SHA256 0ea364289db4ab59f2d4464387ab706e818a692173b1f47010bff256094f37af ocaml-3.09.3-r1.ebuild 4217
MD5 71f3dc5bc2ee57a403689b56bc1a85c1 files/digest-ocaml-3.09.3-r1 244
RMD160 e7f0898889b94faae3b1481555bac42e9298b370 files/digest-ocaml-3.09.3-r1 244
SHA256 19708f759185ed39623e03921462ba20fb6f3533268673d2bcd7dd07cef57350 files/digest-ocaml-3.09.3-r1 244
diff --git a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
index e12ad32..cd71c86 100644
--- a/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
+++ b/hardened/dev-lang/ocaml/ocaml-3.09.3-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.09.3.ebuild,v 1.9 2007/04/15 20:17:05 corsair Exp $
-inherit flag-o-matic eutils multilib pax-utils versionator
+inherit flag-o-matic eutils multilib pax-utils versionator toolchain-funcs
DESCRIPTION="fast modern type-inferring functional programming language descended from the ML (Meta Language) family"
HOMEPAGE="http://www.ocaml.org/"
@@ -48,6 +48,12 @@ src_unpack() {
}
src_compile() {
+ # ocaml fails on AMD64/hardened due to -PIE being adding to the binaries
+ if use amd64 ; then
+ gcc-specs-pie && append-flags -fno-pie
+ filter-flags -fPIE -fpie
+ fi
+
local myconf="--host ${CHOST}"
# dev-lang/ocaml tends to break/give unexpected results with "unsafe" CFLAGS.