summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'hardened/sys-boot/grub/grub-1.95.ebuild')
-rw-r--r--hardened/sys-boot/grub/grub-1.95.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/hardened/sys-boot/grub/grub-1.95.ebuild b/hardened/sys-boot/grub/grub-1.95.ebuild
new file mode 100644
index 0000000..9883e36
--- /dev/null
+++ b/hardened/sys-boot/grub/grub-1.95.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/grub/grub-1.95.ebuild,v 1.1 2006/10/21 22:46:44 vapier Exp $
+
+inherit mount-boot eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="GNU GRUB 2 boot loader"
+HOMEPAGE="http://www.gnu.org/software/grub/"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="-*"
+IUSE="static netboot custom-cflags"
+
+DEPEND=">=sys-libs/ncurses-5.2-r5
+ dev-libs/lzo"
+PROVIDE="virtual/bootloader"
+
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ use custom-cflags || unset CFLAGS LDFLAGS
+ use static && append-ldflags -static
+
+ filter-flags -fPIE
+
+ econf \
+ --prefix=/ \
+ --datadir=/usr/lib \
+ || die "econf failed"
+ emake || die "making regular stuff"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}