summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2012-07-18 00:07:05 -0500
committerMatthew Thode <mthode@mthode.org>2012-07-18 00:07:05 -0500
commit3444a3e4807ee38f6bfd838cbdfb96ed2b0d8fcd (patch)
tree3228a9cf67e22ed92453b8e02405f1171f8a6172
parentyep... (diff)
downloadprometheanfire-3444a3e4807ee38f6bfd838cbdfb96ed2b0d8fcd.tar.gz
prometheanfire-3444a3e4807ee38f6bfd838cbdfb96ed2b0d8fcd.tar.bz2
prometheanfire-3444a3e4807ee38f6bfd838cbdfb96ed2b0d8fcd.zip
initial add for testing
-rw-r--r--www-misc/pelican/ChangeLog9
-rw-r--r--www-misc/pelican/Manifest3
-rw-r--r--www-misc/pelican/metadata.xml26
-rw-r--r--www-misc/pelican/pelican-2.7.2.ebuild38
4 files changed, 76 insertions, 0 deletions
diff --git a/www-misc/pelican/ChangeLog b/www-misc/pelican/ChangeLog
new file mode 100644
index 0000000..f3c8889
--- /dev/null
+++ b/www-misc/pelican/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for www-misc/pelican
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pelican-2.7.2 (18 Jul 2012)
+
+ 18 Jul 2012; <mthode@gentoo.org> +pelican-2.7.2.ebuild, +metadata.xml:
+ initial add for testing
+
diff --git a/www-misc/pelican/Manifest b/www-misc/pelican/Manifest
new file mode 100644
index 0000000..7ab933e
--- /dev/null
+++ b/www-misc/pelican/Manifest
@@ -0,0 +1,3 @@
+EBUILD pelican-2.7.2.ebuild 901 RMD160 379d42c2e93c514b6a6c8b862d0f626ff47ee83d SHA1 2aabc77ffe5c10db73ac479ea117b370a4786b75 SHA256 954511ee7e4c579f062ca51bed4ab5f15201dd02dc6c6226c62be74626396815
+MISC ChangeLog 247 RMD160 40814594875e58fc54d00b677ddde3031979a5f7 SHA1 e75a44cd73287ad99b46ab606afd67d56f0fe34f SHA256 fc7d45ce726ad7f99f14030269ded9940f619d7edd8286bca2e5f12bcb67b885
+MISC metadata.xml 865 RMD160 07f1aee25b01466217e446e4f0ba962bc0478199 SHA1 4450f172eedb886dec0937bdfd1bc121e7303670 SHA256 e61060d6999ee9f6ff9ed0412eae8bee526717c375bff83cc5dc39026d39c594
diff --git a/www-misc/pelican/metadata.xml b/www-misc/pelican/metadata.xml
new file mode 100644
index 0000000..d84f492
--- /dev/null
+++ b/www-misc/pelican/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <longdescription lang="en">
+ Static blog generator in python, using ReST syntax.
+ </longdescription>
+ <maintainer>
+ <name>Matthew Thode</email>
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='examples'>Install examples.</flag>
+ <flag name='rst'>Add support for reST (restructed text) as an input format.</flag>
+ <flag name='markdown'>Add support for markdown as an input format.</flag>
+ <flag name='pygments'>To have syntactic colorization with resT input.</flag>
+ </use>
+ <upstream>
+ <maintainer>
+ <name>Alexis Metaireau</name>
+ <email>alexis@notmyidea.org</email>
+ </maintainer>
+ <bugs-to>https://github.com/ametaireau/pelican/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
+
diff --git a/www-misc/pelican/pelican-2.7.2.ebuild b/www-misc/pelican/pelican-2.7.2.ebuild
new file mode 100644
index 0000000..ab9240d
--- /dev/null
+++ b/www-misc/pelican/pelican-2.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit distutils git-2
+
+DESCRIPTION="Pelican is a simple weblog generator, written in Python"
+HOMEPAGE="https://github.com/ametaireau/pelican"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/ametaireau/pelican.git
+ https://github.com/ametaireau/pelican.git"
+EGIT_COMMIT="2.7.2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="examples markdown +pygments +rst"
+
+DEPEND=">=dev-lang/python-2.7
+ dev-python/argparse
+ dev-python/feedgenerator
+ dev-python/jinja
+ markdown? ( dev-python/markdown )
+ pygments? ( dev-python/pygments )
+ rst? ( dev-python/docutils )"
+
+DOCS="README.rst CHANGELOG LICENSE THANKS"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "Failed to install examples"
+ fi
+}